[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Proposal for fixing automake



* Joseph Carter (knghtbrd@bluecherry.net) wrote:
> On Sun, Jun 09, 2002 at 04:12:53AM -0400, Eric Dorland wrote:
> > > > are basically compatible, and are certainly more compatible then 1.4
> > > > and 1.5. The reason we *might* want to keep 1.5 around is that it
> > > > still works with autoconf 2.13, whereas 1.6 needs autoconf 2.52 or
> > > > greater.
> > > 
> > > Nuke 1.5, fix the packages to work with both autoconf 2.50 and automake
> > > 1.6.  Call it good.
> > 
> > I agree that within debian it would desirable to do that, but some
> > users might be peeved they can't use automake 1.5 anymore...
> 
> Tough.  ;)
> 
> Seriously though, automake 1.5 never really caught on because unless you
> were using autoconf 2.50+ you were basically asking for trouble.  I'd be
> more concerned with users who want to use autoconf 1.4 for packages
> outside of Debian which don't work with anything later.  It's simply
> unreasonable for Debian to maintain three seperate versions of automake
> for two versions of autoconf until the end of time because someone,
> somewhere out there may have a package which requires a non-1.4 automake
> setup which doesn't support autoconf 2.50+.
> 

Well I've uploaded automake1.6, so once that gets in we'll see well it
works on packages that depend on 1.5. Let's not make any rash
decisions :)

-- 
Eric Dorland <dorland@lords.com>
ICQ: #61138586, Jabber: hooty@jabber.com
1024D/16D970C6 097C 4861 9934 27A0 8E1C  2B0A 61E9 8ECF 16D9 70C6

-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GCS d- s++: a-- C+++ UL+++ P++ L++ E++ W++ N+ o K- w+ 
O? M++ V-- PS+ PE Y+ PGP++ t++ 5++ X+ R tv++ b+++ DI+ D+ 
G e h! r- y+ 
------END GEEK CODE BLOCK------

Attachment: pgpJ7IJWodxVM.pgp
Description: PGP signature


Reply to: