[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: heimdal override disparity



Brian,

On Fri, Nov 30, 2001 at 09:33:58AM +1100, Brian May wrote:

> I upload Heimdal 0.4e-1 as "optional" (as all ways), and get told it
> should be "extra".

> So I upload Heimdal 0.4e-2 and 0.4e-3 as "extra" and get told it
> should be "optional".

Priority is handled on a per-binary-package basis.  It appears that
you're setting the default Priority: in the source section of the
control file, and not setting any other per-package priorities; but some
of these packages must be Priority: extra (I imagine because of
conflicts:), and the others should be optional.

Cheers,
Steve Langasek
postmodern programmer

> Subject: Topics
> 
> Topics:
>    heimdal override disparity
>    heimdal override disparity
>    heimdal override disparity
> 

> From: Debian Installer <installer@ftp-master.debian.org>
> To: Brian May <bam@snoopy.apana.org.au>, Brian May <bam@debian.org>
> Subject: heimdal override disparity
> 
> There are disparities between your recently installed upload and the
> override file for the following file(s):
> 
> heimdal-clients_0.4e-1_i386.deb: priority is overridden from optional to extra.
> heimdal-servers-x_0.4e-1_i386.deb: priority is overridden from optional to extra.
> heimdal-lib_0.4e-1_all.deb: priority is overridden from optional to extra.
> heimdal-servers_0.4e-1_i386.deb: priority is overridden from optional to extra.
> libkadm5clnt4-heimdal_0.4e-1_i386.deb: priority is overridden from optional to extra.
> heimdal-dev_0.4e-1_i386.deb: priority is overridden from optional to extra.
> heimdal-clients-x_0.4e-1_i386.deb: priority is overridden from optional to extra.
> heimdal-kdc_0.4e-1_i386.deb: priority is overridden from optional to extra.
> 
> Either the package or the override file is incorrect.  If you think
> the override is correct and the package wrong please fix the package
> so that this disparity is fixed in the next upload.  If you feel the
> override is incorrect then please reply to this mail and explain why.
> 
> [NB: this is an automatically generated mail; if you replied to one
> like it before and have not received a response yet, please ignore
> this mail.  Your reply needs to be processed by a human and will be in
> due course, but until then the installer will send these automated
> mails; sorry.]
> 
> --
> Debian distribution maintenance software
> 
> (This message was generated automatically; if you believe that there
> is a problem with it please contact the archive administrators by
> mailing ftpmaster@debian.org)
> 

> From: Debian Installer <installer@ftp-master.debian.org>
> To: Brian May <bam@snoopy.apana.org.au>, Brian May <bam@debian.org>
> Subject: heimdal override disparity
> 
> There are disparities between your recently installed upload and the
> override file for the following file(s):
> 
> libgssapi1-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libss0-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libasn1-5-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libroken9-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libkadm5srv7-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> heimdal-docs_0.4e-2_all.deb: priority is overridden from extra to optional.
> libcomerr1-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libhdb7-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libotp0-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> libkrb5-17-heimdal_0.4e-2_i386.deb: priority is overridden from extra to optional.
> 
> Either the package or the override file is incorrect.  If you think
> the override is correct and the package wrong please fix the package
> so that this disparity is fixed in the next upload.  If you feel the
> override is incorrect then please reply to this mail and explain why.
> 
> [NB: this is an automatically generated mail; if you replied to one
> like it before and have not received a response yet, please ignore
> this mail.  Your reply needs to be processed by a human and will be in
> due course, but until then the installer will send these automated
> mails; sorry.]
> 
> --
> Debian distribution maintenance software
> 
> (This message was generated automatically; if you believe that there
> is a problem with it please contact the archive administrators by
> mailing ftpmaster@debian.org)
> 

> From: Debian Installer <installer@ftp-master.debian.org>
> To: Brian May <bam@snoopy.apana.org.au>, Brian May <bam@debian.org>
> Subject: heimdal override disparity
> 
> There are disparities between your recently installed upload and the
> override file for the following file(s):
> 
> libcomerr1-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> heimdal-docs_0.4e-3_all.deb: priority is overridden from extra to optional.
> libss0-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libkadm5srv7-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libkrb5-17-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libasn1-5-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libotp0-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libhdb7-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libroken9-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> libgssapi1-heimdal_0.4e-3_i386.deb: priority is overridden from extra to optional.
> 
> Either the package or the override file is incorrect.  If you think
> the override is correct and the package wrong please fix the package
> so that this disparity is fixed in the next upload.  If you feel the
> override is incorrect then please reply to this mail and explain why.
> 
> [NB: this is an automatically generated mail; if you replied to one
> like it before and have not received a response yet, please ignore
> this mail.  Your reply needs to be processed by a human and will be in
> due course, but until then the installer will send these automated
> mails; sorry.]
> 
> --
> Debian distribution maintenance software
> 
> (This message was generated automatically; if you believe that there
> is a problem with it please contact the archive administrators by
> mailing ftpmaster@debian.org)
> 


> 
> -- 
> Brian May <bam@debian.org>

Attachment: pgpAswCgp_VDj.pgp
Description: PGP signature


Reply to: