[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SDL and related library packages (plus 2 games) uploaded



I have uploaded NMU's of the following packages to auric's incoming:

gengameng
libsdl1.2
sdl-image1.2
sdl-mixer1.2
smpeg
lbreakout
burgerspace

(The last two are not library packages, but the package maintainer gave
me permission to NMU since I was using them to test my NMU's of the
libraries).

REMINDER FOR PEOPLE USING SDL-BASED PACKAGES OUT OF UNSTABLE/SID:

You might want to put libsdl1.2 on hold for a few days.  Here's how:

echo "libsdl1.2 hold" | dpkg --set-selections

When you're ready to take the plunge and get current again, just tell
apt you want the new one:

apt-get install libsdl1.2debian

REMINDER FOR PACKAGE MAINTAINERS OF SDL-BASED PACKAGES:

Packages that build-depend on the following packages should
add versioning to that build dependency as follows:

libgameng-dev           libgameng-dev (>= 3.0-4.1)
libsdl-image1.2-dev     libsdl-image1.2-dev (>= 1.2.0-1.1)
libsdl-mixer1.2-dev     libsdl-mixer1.2-dev (>= 1.2.0-1.1)
libsdl1.2-dev           libsdl1.2-dev (>= 1.2.2-3.1)
libsmpeg-dev            libsmpeg-dev (>= 0.4.4-2.1)

Thanks to Eric Gillespie, Jr. and Jeff Licquia of Progeny Linux Systems
for help getting these packages fixed up.  The GNU autotools give me
heartburn.

-- 
G. Branden Robinson                |
Debian GNU/Linux                   |       kernel panic -- causal failure
branden@debian.org                 |       universe will now reboot
http://people.debian.org/~branden/ |

Attachment: pgpp81DjoFCGg.pgp
Description: PGP signature


Reply to: