[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: All services that require a restart from libc6 upgrade...



* Ben Collins in "All services that require a restart from libc6
* upgrade..." dated 2000/10/16 16:23 wrote:

> ----
> check=$(/etc/init.d/service nss-check 2>&1 || true)
> 
> if [ "$check" = "restart" ]; then
> 	# this service needs to be restarted
> 	...
> fi
> ----
[..snip..]
> 
> The only problem I forsee is that some init.d scripts execute
> regardless of the options passed to it. IMO, this needs to be
> specifically forbidden atleast in runlevels 2-5.

Shouldn't you also check to see that the script is linked in the rc?.d
directory corresponding to the current runlevel?

-- 
ashley clark

Attachment: pgpcG1qdAxnz7.pgp
Description: PGP signature


Reply to: