[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Preparation of Debian GNU/Linux 3.0r1



Preparation of Debian GNU/Linux 3.0r1
=====================================

An up-to-date version is at <http://master.debian.org/~joey/3.0r1/>.

I am preparing the first revision of the current stable Debian
distribution (woody) and will infrequently send reports so people can
actually comment on it and intervene whenever this is required.

If you disagree with one bit or another, please reply to this mail and
explain to me why certain packages should be handled differently.
There is still time to reconsider.  It requires good arguments, though.

Several security updates got lost partially or totally or were
rejected by the katie archive system.  I'm working on bits I can work
on, others will have to be left to the ftp people.

The plan is to release this revision in the middle of November, 2002.
James Troup still has to give the final approval for each package
since he is the ftpmaster involved with stable revisions.  However, I
will try to make his work as easy as possible in the hope to get the
next revision out properly.

The regulations for stable are quite conservative.  The requirements
for packages to get into stable are:

 1. The package fixes a security problem.  An advisory by our own
    Security Team is required.  Updates need to be approved by the
    security team.

 2. The package fixes a critical bug which can lead into data loss,
    data corruption, or an overly broken system, or the package is
    broken or not usable (anymore).

 3. The stable version of the package is not installable at all due to
    broken or unmet dependencies or broken installation scripts.

 4. All released architectures have to be in sync.

It is (1 OR 2 OR 3) AND 4

Since this is the first revision of stable, I may be a little bit lax
about enforcing reason 2.

However, regular bugs and upgrade problems should instead be
documented in the Release Notes which are maintained by Rob Bradford
<robster@debian.org> and found at
<http://www.debian.org/releases/woody/releasenotes>.

Packages, which will most probably be rejected:

  . Packages that fix non-critical bugs.

  . Misplaced uploads, i.e. packages that were uploaded to 'stable
    unstable' or `frozen unstable' or similar.

  . Packages for which its binary packages are out of sync with regard
    to all supported architectures in the stable distribution.

  . Binary packages for which the source got lost somehow.

Accepted Packages
-----------------

These packages will be installed into the stable Debian distribution
and will be part of the next revision.

bugzilla    stable    2.14.2-0woody1  all, source
bugzilla    updates   2.14.2-0woody2  all, source

	DSA-173 bugzilla - privilege escalation

cacti       stable    0.6.7-2     all, source
cacti       updates   0.6.7-3     all, source

	DSA-164 cacti - arbitrary code execution

	0.6.7-3 contains a tempfile race condition

cron-apt    stable    0.0.6        all, source
cron-apt    updates   0.0.6woody1  all, source

	* Added default path so the upgrade will work fine. Thanks to Donovan
	  Baarda <abo@minkirri.apana.org.au> for pointing out the problem.
	  Closes: #158869.

	Rationale: Without the path, this package doesn't run out of
	the box on woody anymore.

debiandoc-sgml  stable    1.1.67        all, source
debiandoc-sgml  updates   1.1.67woody1  all, source

	On a machine which was upgraded from potato to woody a couple of
	months before release, there is a wrong entry in transitional.cat,
	which causes debiandoc to be unusable.  My opinion is, it is bad
	enough (and simple enough to fix) so that it must go into 3.0r1.

	* debian/postinst: added invocation of 'install-sgmlcatalog
	  --remove debiandoc-sgml' to clean up cruft potentially left
	  over from the SGML catalog transition in a potato -> woody
	  upgrade (closes: Bug#154737)

dietlibc-dev  stable    0.12-2      alpha, arm, i386, mips, mipsel, powerpc, sparc
dietlibc-dev  updates   0.12-2.4    alpha, arm, i386, mips, mipsel, powerpc, sparc
dietlibc      stable    0.12-2      source
dietlibc      updates   0.12-2.4    source

	DSA-146 dietlibc - integer overflow

docbook-xml-slides  stable    1.1-2          all, source
docbook-xml-slides  updates   1.1-2.1woody2  all, source

	Don't depend on obsolete library anymore.

	This bug is just an incorrect dependency in the control file,
	which makes docbook-xml-slides insist on pulling the obsolete
	docbook-xsl-stylesheets instead of recent docbook-xsl.  This
	in turns causes other packages to be uninstallable, because
	they correctly depend on the new one.

elkdoc      stable    3.0-8.1     all
elk         stable    3.0-8.1     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
elk         updates   3.0-8.1     alpha

	Get architectures in sync (IA-64 is missing, though, but the
	package doesn't seem to compile on that arch)

ethereal-common  stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
ethereal-common  updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ethereal-dev     stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
ethereal-dev     updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ethereal         stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc, source
ethereal         updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tethereal        stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
tethereal        updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-162 ethereal - buffer overflow

fam         stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fam         updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
libfam-dev  stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam-dev  updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam0     stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam0     updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-154 fam - privilege escalation

fetchmail-common  stable    5.9.11-6    all
fetchmail-common  updates   5.9.11-6.1  all
fetchmailconf     stable    5.9.11-6    all
fetchmailconf     updates   5.9.11-6.1  all
fetchmail         stable    5.9.11-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fetchmail         updates   5.9.11-6.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-171 fetchmail - buffer overflows

fetchmail-ssl     stable    5.9.11-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fetchmail-ssl     updates   5.9.11-6.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-171 fetchmail - buffer overflows

gaim-common  stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gaim-common  updates   1:0.58-2.2  sparc
gaim-common  updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
gaim-gnome   stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gaim-gnome   updates   1:0.58-2.2  sparc
gaim-gnome   updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
gaim         stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gaim         updates   1:0.58-2.2  sparc, source
gaim         updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	DSA-158 gaim - arbitrary program execution

gallery     stable    1.2.5-6          all, source
gallery     updates   1.2.5-7.woody.0  all, source

	DSA-138 gallery - remote exploit

chill-2.95              stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
chill-2.95              updates   1:2.95.4-11woody1     i386
cpp-2.95-doc            stable    1:2.95.4-7            all
cpp-2.95-doc            updates   1:2.95.4-11woody1     all
cpp-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
cpp-2.95                updates   1:2.95.4-11woody1     i386
g++-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
g++-2.95                updates   1:2.95.4-11woody1     i386
g77-2.95-doc            stable    1:2.95.4-7            all
g77-2.95-doc            updates   1:2.95.4-11woody1     all
g77-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
g77-2.95                updates   1:2.95.4-11woody1     i386
gcc-2.95-doc            stable    1:2.95.4-7            all
gcc-2.95-doc            updates   1:2.95.4-11woody1     all
gcc-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gcc-2.95                stable    2.95.4.ds11-7         source
gcc-2.95                updates   1:2.95.4-11woody1     i386
gcc-2.95                updates   2.95.4.ds13-11woody1  source
gobjc-2.95              stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gobjc-2.95              updates   1:2.95.4-11woody1     i386
gpc-2.95-doc            stable    1:2.95.4-7            all
gpc-2.95-doc            updates   1:2.95.4-11woody1     all
gpc-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gpc-2.95                updates   1:2.95.4-11woody1     i386
libg++2.8.1.3-dbg       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-dbg       updates   1:2.95.4-11woody1     i386
libg++2.8.1.3-dev       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-dev       updates   1:2.95.4-11woody1     i386
libg++2.8.1.3-glibc2.2  stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-glibc2.2  updates   1:2.95.4-11woody1     i386
libstdc++2.10-dbg       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-dbg       stable    1:2.96-8              ia64
libstdc++2.10-dbg       updates   1:2.95.4-11woody1     i386
libstdc++2.10-dev       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-dev       stable    1:2.96-8              ia64
libstdc++2.10-dev       updates   1:2.95.4-11woody1     i386
libstdc++2.10-glibc2.2  stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-glibc2.2  stable    1:2.96-8              ia64
libstdc++2.10-glibc2.2  updates   1:2.95.4-11woody1     i386
protoize-2.95           stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
protoize-2.95           updates   1:2.95.4-11woody1     i386

	- Fix profiling for arm.

	- Fix internal compiler errors on s390.

	Most architectures are missing.

glibc              stable    2.2.5-6     source
glibc              updates   2.2.5-11.1  source
glibc-doc          stable    2.2.5-6     all
glibc-doc          updates   2.2.5-11.1  all
libc6-dbg          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dbg          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dev-sparc64  stable    2.2.5-6     sparc
libc6-dev-sparc64  updates   2.2.5-11.1  sparc
libc6-dev          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dev          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-pic          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-pic          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-prof         stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-prof         updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-sparc64      stable    2.2.5-6     sparc
libc6-sparc64      updates   2.2.5-11.1  sparc
libc6.1-dbg        stable    2.2.5-6     alpha, ia64
libc6.1-dbg        updates   2.2.5-11.1  alpha, ia64
libc6.1-dev        stable    2.2.5-6     alpha, ia64
libc6.1-dev        updates   2.2.5-11.1  alpha, ia64
libc6.1-pic        stable    2.2.5-6     alpha, ia64
libc6.1-pic        updates   2.2.5-11.1  alpha, ia64
libc6.1-prof       stable    2.2.5-6     alpha, ia64
libc6.1-prof       updates   2.2.5-11.1  alpha, ia64
libc6.1            stable    2.2.5-6     alpha, ia64
libc6.1            updates   2.2.5-11.1  alpha, ia64
libc6              stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6              updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
locales            stable    2.2.5-6     all
locales            updates   2.2.5-11.1  all
nscd               stable    2.2.5-6     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
nscd               updates   2.2.5-11.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	(DSA-149 glibc - integer overflow)

gnome-gv    stable    1.1.96-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gnome-gv    updates   1.1.96-3.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-179 gnome-gv - buffer overflow

gnome-pim-conduits  stable    1.4.6-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gnome-pim-conduits  updates   1.4.6-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gnome-pim           stable    1.4.6-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gnome-pim           updates   1.4.6-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	According to the bug reports mentioned in the changelog, one
	program from this package crashed upon startup, rendering it
	useless.  Hence, an update.

	* Fixing RC bugs:
	  + Closes: #145411: Gnomecal segfaults upon start
	  + Closes: #145517: gnomecal segfaults at startup
	  + Closes: #151781 (for stable): Problem loading GnomeCal conduit
	  + Closes: #155221: Gnomecal segfaults upon start and no fixed version of
	    gnome-pim is available in stable

gv          stable    1:3.5.8-26    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gv          updates   1:3.5.8-26.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-176 gv - buffer overflow

htcheck-php  stable    1:1.1-1     all
htcheck-php  updates   1:1.1-1.1   all
htcheck      stable    1:1.1-1     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
htcheck      updates   1:1.1-1.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-169 htcheck - cross site scripting

hylafax-client  stable    1:4.1.1-1    alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-client  updates   1:4.1.1-1.1  alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-doc     stable    1:4.1.1-1    all
hylafax-doc     updates   1:4.1.1-1.1  all
hylafax-server  stable    1:4.1.1-1    alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-server  updates   1:4.1.1-1.1  alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax         stable    1:4.1.1-1    source
hylafax         updates   1:4.1.1-1.1  source

	DSA-148 hylafax - buffer overflows and format string vulnerabilities

interchange-cat-foundation  stable  4.8.3.20020306-1         all
interchange-cat-foundation  updates 4.8.3.20020306-1.woody.1 all
interchange-ui              stable  4.8.3.20020306-1         all
interchange-ui              updates 4.8.3.20020306-1.woody.1 all
interchange                 stable  4.8.3.20020306-1         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
interchange                 updates 4.8.3.20020306-1.woody.1 alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
libapache-mod-interchange   stable  4.8.3.20020306-1         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libapache-mod-interchange   updates 4.8.3.20020306-1.woody.1 alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-150 interchange - illegal file exposition

irssi-text  stable    0.8.4-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
irssi-text  updates   0.8.4-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-157 irssi-text - denial of service

kannel      stable    1.1.5-2     alpha, arm, hppa, i386, ia64, m68k, mips, powerpc, s390, sparc, source
kannel      updates   1.1.5-2     mipsel

	non-US

	Get architectures in sync.

kamera        stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kamera        updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kcoloredit    stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kcoloredit    updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdegraphics   stable    4:2.2.2-6.4  source
kdegraphics   updates   4:2.2.2-6.8  source
kfract        stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kfract        updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kghostview    stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kghostview    updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kiconedit     stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kiconedit     updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kooka         stable    4:2.2.2-6.4  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kooka         updates   4:2.2.2-6.8  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kpaint        stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kpaint        updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kruler        stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kruler        updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ksnapshot     stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ksnapshot     updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kview         stable    4:2.2.2-6.4  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kview         updates   4:2.2.2-6.8  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkscan-dev  stable    4:2.2.2-6.4  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkscan-dev  updates   4:2.2.2-6.8  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkscan1     stable    4:2.2.2-6.4  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkscan1     updates   4:2.2.2-6.8  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-182 kdegraphics - buffer overflow

kdelibs-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs-dev    updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-bin   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-bin   updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-cups  stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-cups  updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-doc   stable    4:2.2.2-13          all
kdelibs3-doc   updates   4:2.2.2-13.woody.3  all
kdelibs3       stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3       updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs        stable    4:2.2.2-13          source
kdelibs        updates   4:2.2.2-13.woody.3  source
libarts-alsa   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-alsa   updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-dev    updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts        stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts        updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-alsa   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-alsa   updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-dev    updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid        stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid        updates   4:2.2.2-13.woody.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-155 kdelibs - privacy escalation with Konqueror

	DSA-167 kdelibs - cross site scripting

krb5-admin-server  stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-admin-server  updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-clients       stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-clients       updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-doc           stable    1.2.4-5        all
krb5-doc           updates   1.2.4-5woody3  all
krb5-ftpd          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-ftpd          updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-kdc           stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-kdc           updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-rsh-server    stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-rsh-server    updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-telnetd       stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-telnetd       updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-user          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-user          updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5               stable    1.2.4-5        source
krb5               updates   1.2.4-5woody3  source
libkadm55          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkadm55          updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb5-dev        stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb5-dev        updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb53           stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb53           updates   1.2.4-5woody3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-143 krb5 - integer overflow

	DSA-183 krb5 - buffer overflow

libgd-dev        stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd-dev        updates   1.8.4-17.woody1  hppa
libgd-dev        updates   1.8.4-17.woody2  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd-noxpm-dev  stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd-noxpm-dev  updates   1.8.4-17.woody1  hppa
libgd-noxpm-dev  updates   1.8.4-17.woody2  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1-noxpm     stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1-noxpm     updates   1.8.4-17.woody1  hppa
libgd1-noxpm     updates   1.8.4-17.woody2  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1           stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1           updates   1.8.4-17.woody1  hppa
libgd1           updates   1.8.4-17.woody2  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd            stable    1.8.4-16         source
libgd            updates   1.8.4-17.woody2  source

	* "Major Brown Bag"-release.
	* Make shlibs depend on libgd1-noxpm (not the non-existing libgd1-
	  xpm). This closes: bug#143856 - thanks to Ben Finney
	  <bignose@zip.com.au> for being awake when I am not.
	* Set urgency=high - same reasoning as -16.

	woody2 fix uninstallable on ia32 due to broken dependencies,
	fixed packages are to be uploaded soon.

libpng2-dev  stable    1.0.12-3          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2-dev  updates   1.0.12-3.woody.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2      stable    1.0.12-3          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2      updates   1.0.12-3.woody.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng       stable    1.0.12-3          source
libpng       updates   1.0.12-3.woody.2  source

	DSA-140 libpng - buffer overflow

logtool     stable    1.0.6-7          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
logtool     updates   1.0.6-7.woody.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	* Backported fix for file-existence-error bug from unstable version.
	  (Closes: #153414). Release manager: this is just a one-character
	  change from 'test -f' to 'test -L', where the latter is the right
	  thing to do, is being done so for the other three cases, and works as is
	  for a few months now in unstable

	The bug report demonstrates that the package is not
	installable under certain circumstances without this fix.

mailman     stable    2.0.11-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
mailman     updates   2.0.11-1woody4  i386
mailman     updates   2.0.11-1woody5  alpha, arm, hppa, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-147 mailman - cross-site scripting

	Plus: Fix a permission bug that renders the package
	uninstallable (upgrade with corrected perms would work,
	though)

mantis      stable    0.17.1-2    all, source
mantis      updates   0.17.1-2.5  all, source

	DSA-153 mantis - cross site code execution and privilege escalation

	DSA-161 mantis - privilege escalation

mhonarc     stable    2.5.2-1     all, source
mhonarc     updates   2.5.2-1.1   all, source

	DSA-163 mhonarc - cross site scripting

mpack       stable    1.5-7        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
mpack       updates   1.5-7woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-141 mpack - buffer overflow

msttcorefonts  stable    1.0.0       all, source
msttcorefonts  updates   1.0.2       all, source

	The woody package was useless since the path was changed.

muddleftpd  stable    1.3.11-7woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
muddleftpd  updates   1.3.11-7woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Corrected the logfile security fix.

libnessus-dev     stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libnessus-dev     updates   1.0.10-2.0.1  s390
libnessus1        stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libnessus1        updates   1.0.10-2.0.1  s390
nessus-core       stable    1.0.10-2      source
nessus-dev        stable    1.0.10-2      all
nessus-libraries  stable    1.0.10-2      source
nessusd           stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, sparc
nessusd           updates   1.0.10-2      powerpc
nessusd           updates   1.0.10-2.0.1  s390
nessus            stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, sparc
nessus            updates   1.0.10-2      powerpc
nessus            updates   1.0.10-2.0.1  s390

	Get architectures in sync (despite BNMU)

octave2.1-doc      stable    2.1.35-7        all
octave2.1-doc      updates   2.1.35-7woody1  all
octave2.1-emacsen  stable    2.1.35-7        all
octave2.1-emacsen  updates   2.1.35-7woody1  all
octave2.1-headers  stable    2.1.35-7        alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
octave2.1-headers  updates   2.1.35-7woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
octave2.1-htmldoc  stable    2.1.35-7        all
octave2.1-htmldoc  updates   2.1.35-7woody1  all
octave2.1-info     stable    2.1.35-7        all
octave2.1-info     updates   2.1.35-7woody1  all
octave2.1          stable    2.1.35-7        alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
octave2.1          updates   2.1.35-7woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Rebuilt against current atlas*-dev package with corrected
	shlibs.default to ensure proper handling of virtual depends
	on blas2 with default of blas and atlas2-base

libopenafs-dev          stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
libopenafs-dev          updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-client          stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-client          updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-dbserver        stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-dbserver        updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-fileserver      stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-fileserver      updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-kpasswd         stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-kpasswd         updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-modules-source  stable    1.2.3final2-5  all
openafs-modules-source  updates   1.2.3final2-6  all
openafs                 stable    1.2.3final2-5  source
openafs                 updates   1.2.3final2-6  source

	DSA-142 openafs - integer overflow

libssl-dev   stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libssl-dev   updates   0.9.6c-2.woody.0  m68k
libssl-dev   updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libssl0.9.6  stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libssl0.9.6  updates   0.9.6c-2.woody.0  m68k
libssl0.9.6  updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
openssl      stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
openssl      updates   0.9.6c-2.woody.0  m68k
openssl      updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc, source
ssleay       stable    0.9.6c-2          all
ssleay       updates   0.9.6g-0.woody.1  all

	0.9.6c-2.woody.0: DSA-136 openssl - multiple remote exploits

	0.9.6c-2.woody.1: DSA-136 openssl - multiple remote exploits
	(update on security.debian.org)

	0.9.6g-0.woody.1 says:

	* new upstream version

	* fix manpage names (closes: #156717, #156718, #156719, #156721)

	* Use proper error handling instead of 'assertions' in buffer
	  overflow checks added in 0.9.6e.  This prevents DoS (the
	  assertions could call abort()). (closes: #155985, #156495)

	* Fix ASN1 checks. Check for overflow by comparing with LONG_MAX
	  and get fix the header length calculation.

	* include support for new sh* architectures (closes: #155117)

	Doesn't sound like it should make it into stable, hence reject	

php3-cgi-gd      stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-gd      updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-imap    stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-imap    updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-ldap    stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-ldap    updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-magick  stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-magick  updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-mhash   stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-mhash   updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-mysql   stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-mysql   updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-snmp    stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-snmp    updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-xml     stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi-xml     updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi         stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-cgi         updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-dev         stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-dev         updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-doc         stable    3:3.0.18-23          all
php3-doc         updates   3:3.0.18-23.1woody1  all
php3-gd          stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-gd          updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-imap        stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-imap        updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-ldap        stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-ldap        updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-magick      stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-magick      updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-mhash       stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-mhash       updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-mysql       stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-mysql       updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-snmp        stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-snmp        updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3-xml         stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
php3-xml         updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php3             stable    3:3.0.18-23          alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
php3             updates   3:3.0.18-23.1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-168 php - bypassing safe_mode, CRLF injection

caudium-php4  stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
caudium-php4  updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-cgi      stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-cgi      updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-curl     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-curl     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-dev      stable    4:4.1.2-4   all
php4-dev      updates   4:4.1.2-6   all
php4-domxml   stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-domxml   updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-gd       stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-gd       updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-imap     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-imap     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-ldap     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-ldap     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mcal     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mcal     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mhash    stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mhash    updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mysql    stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-mysql    updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-odbc     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-odbc     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-pear     stable    4:4.1.2-4   all
php4-pear     updates   4:4.1.2-6   all
php4-recode   stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-recode   updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-snmp     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-snmp     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-sybase   stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-sybase   updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-xslt     stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4-xslt     updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
php4          stable    4:4.1.2-4   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
php4          updates   4:4.1.2-6   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-168 php - bypassing safe_mode, CRLF injection

	-6 is: Backport fix from 4.2.3 to avoid using pread() and
	pwrite() functions from glibc, as they are broken on many
	architectures in Debian.

postfix-tls  stable    1.1.11+tls0.7.15-0.woody1  alpha, hppa, i386, ia64, mips, mipsel, powerpc, s390, source
postfix-tls  updates   1.1.11+tls0.7.15-0.woody1  arm, m68k, sparc

	Get architectures in sync

purity      stable    1-14        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
purity      updates   1-14.2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-166 purity - buffer overflows

python1.5   stable    1.5.2-23    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python1.5   updates   1.5.2-23.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-159 python - insecure temporary files

libpam-smbpass    stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpam-smbpass    updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient-dev  stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient-dev  updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient      stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient      updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
samba-common      stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
samba-common      updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
samba-doc         stable    2.2.3a-6    all
samba-doc         updates   2.2.3a-9    all
samba             stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
samba             updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
smbclient         stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
smbclient         updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
smbfs             stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
smbfs             updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
swat              stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
swat              updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
winbind           stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
winbind           updates   2.2.3a-9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	Partially important fixes to make the package usable on stable
	again.  Tons of new debconf stuff as well, unfortunately.

libscrollkeeper-dev  stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper-dev  updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper0     stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper0     updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
scrollkeeper         stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
scrollkeeper         updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-160 scrollkeeper - insecure temporary file creation

silo        stable    1.2.5-1     sparc, source
silo        updates   1.2.5-2     sparc, source

	The silo I've uploaded to proposed-updates adds a patch from
	DaveM to support the newest UltraSPARC III+ machines.  Without
	it, they cannot be booted from disk.

	Add patch for UltraSPARC III+ (Cheetah+) support from DaveM.

snort-common         stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-common         updates   1.8.4beta1-3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-doc            stable    1.8.4beta1-2  all
snort-doc            updates   1.8.4beta1-3  all
snort-mysql          stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-mysql          updates   1.8.4beta1-3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-rules-default  stable    1.8.4beta1-2  all
snort-rules-default  updates   1.8.4beta1-3  all
snort                stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
snort                updates   1.8.4beta1-3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	I was told that snort doesn't work in woody, so the update is
	accepted.

	Changelog says:

	  + Mandatory upload to stable because the previous package
	    had serious problems that were fixed only one package release
	    later that JUST didn't get into woody.

	  ! Fixed 'snort.debian.conf is empty at fresh install'

	  + New 'snort-stat' included, fixes 'Empty subject' bugs

	  + Fixes to daily cronjob's email thingy.
	    Now honours DEBIAN_SNORT_STAT_TRESHOLD

tinyproxy   stable    1.4.3-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tinyproxy   updates   1.4.3-2woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-145 tinyproxy - doubly freed memory

libtomcat4-java  stable    4.0.3-3        all
libtomcat4-java  updates   4.0.3-3woody1  all
tomcat4-webapps  stable    4.0.3-3        all
tomcat4-webapps  updates   4.0.3-3woody1  all
tomcat4          stable    4.0.3-3        all, source
tomcat4          updates   4.0.3-3woody1  all, source

	DSA-170 tomcat4 - source code disclosure

weex        stable    2.6.1-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
weex        updates   2.6.1-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Really fixed the mkstemp patch which could make weex core dump.

libwings-dev     stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwings-dev     updates   0.80.0-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwmaker0-dev   stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwmaker0-dev   updates   0.80.0-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2-dev  stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2-dev  updates   0.80.0-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2      stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2      updates   0.80.0-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
wmaker           stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
wmaker           updates   0.80.0-4woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Fixes broken libpng2/3 transition by re-linking against
	libpng2.  This is said to fix wdm as well.

wwwoffle    stable    2.7a-1      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
wwwoffle    updates   2.7a-1.2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-144 wwwoffle - improper input handling

xinetd      stable    1:2.3.4-1.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
xinetd      updates   1:2.3.4-1.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-151 xinetd - pipe exposure

Requires further Investigation
------------------------------

These packages need further investigation.  One reason the package is
listed here could be that I'm not yet convinced this package should go
into stable, but don't want to reject it entirely at the moment.

Another reason could be that released and updated architectures are
not yet in sync.

afterstep   stable    1.8.11-5woody1  alpha, hppa, i386, ia64, mips, mipsel, s390, sparc, source
afterstep   updates   1.8.11-5woody1  powerpc

	Try to sync architectures.

	There is an m68k package hooked up in testing-proposed-updates as well.

	The arm package was built on July 4th, but didn't make it into
	the archive, strangely.

	MISSING arm

arcboot     stable    0.3.1       mips, source

	Guido writes:

	- it don't lets failures to read from an ext2 fs completely crash the loader
	  (like when you enter a non existent partition in the prom)

	- it introduces tip22 as a separate binary package[1], a "piggyback" style
	  tftp loader that is used to pack kernel and initrd into one ecoff
	  file which can be tftpbooted. This finally solves the whole initrd
	  issues on mips. Without that mips will not be able to use kernels >
	  2.4.16 since Ralf revamped head.S(among others) which breaks our
	  current addinitrd method completely. Agreed, we could revert the
	  head.S changes but I'd rather like to avoid that because we might
	  trip on unwanted side effects. I already have a 2 line patch against
	  bootfloppies to use tip22 but don't want to commit it until it's sure
	  tip22 can go into r1.

	Before uploading packages, a new overrides line is required.

	ftpmaster is scared, so the upload has to happen before the
	overrides line will be added.  Guido will upload a package at
	the weekend.

fvwm        stable    2.4.6-2        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fvwm        updates   2.4.6-2woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source

	Changelog says:

	* "No, restart Fvwm" command correction. Previous was to run
	  /usr/bin/X11/fvwm2, even fvwm is in /usr/bin since 2.4.5-2
	  (closes: #153983)

	This upload only corrects the path in the Debian menu.  The
	correction looks clean.  However, this problem only occurs to
	rather few people who restart fvwm.  This upload does not
	correct the font problem mentioned in the same bug report (not
	sure if it's fvwm's fault at all, though).

	MISSING arm
	MISSING sparc

chill-2.95              stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
chill-2.95              updates   1:2.95.4-11woody1     alpha, i386, powerpc
cpp-2.95-doc            stable    1:2.95.4-7            all
cpp-2.95-doc            updates   1:2.95.4-11woody1     all
cpp-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
cpp-2.95                updates   1:2.95.4-11woody1     alpha, i386, powerpc
g++-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
g++-2.95                updates   1:2.95.4-11woody1     alpha, i386, powerpc
g77-2.95-doc            stable    1:2.95.4-7            all
g77-2.95-doc            updates   1:2.95.4-11woody1     all
g77-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
g77-2.95                updates   1:2.95.4-11woody1     alpha, i386, powerpc
gcc-2.95-doc            stable    1:2.95.4-7            all
gcc-2.95-doc            updates   1:2.95.4-11woody1     all
gcc-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gcc-2.95                stable    2.95.4.ds11-7         source
gcc-2.95                updates   1:2.95.4-11woody1     alpha, i386, powerpc
gcc-2.95                updates   2.95.4.ds13-11woody1  source
gobjc-2.95              stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gobjc-2.95              updates   1:2.95.4-11woody1     alpha, i386, powerpc
gpc-2.95-doc            stable    1:2.95.4-7            all
gpc-2.95-doc            updates   1:2.95.4-11woody1     all
gpc-2.95                stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
gpc-2.95                updates   1:2.95.4-11woody1     alpha, i386, powerpc
libg++2.8.1.3-dbg       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-dbg       updates   1:2.95.4-11woody1     alpha, i386, powerpc
libg++2.8.1.3-dev       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-dev       updates   1:2.95.4-11woody1     alpha, i386, powerpc
libg++2.8.1.3-glibc2.2  stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libg++2.8.1.3-glibc2.2  updates   1:2.95.4-11woody1     alpha, i386, powerpc
libstdc++2.10-dbg       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-dbg       stable    1:2.96-8              ia64
libstdc++2.10-dbg       updates   1:2.95.4-11woody1     alpha, i386, powerpc
libstdc++2.10-dev       stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-dev       stable    1:2.96-8              ia64
libstdc++2.10-dev       updates   1:2.95.4-11woody1     alpha, i386, powerpc
libstdc++2.10-glibc2.2  stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
libstdc++2.10-glibc2.2  stable    1:2.96-8              ia64
libstdc++2.10-glibc2.2  updates   1:2.95.4-11woody1     alpha, i386, powerpc
protoize-2.95           stable    1:2.95.4-7            alpha, arm, i386, m68k, mips, mipsel, powerpc, s390, sparc
protoize-2.95           updates   1:2.95.4-11woody1     alpha, i386, powerpc

	Important update for ARM and S/390 systems.

	MISSING arm
	MISSING m68k
	MISSING mips
	MISSING mipsel
	MISSING s390
	MISSING sparc

kerberos4kth-clients-x   stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-clients-x   updates   1.1-8-2     sparc
kerberos4kth-clients-x   updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-clients     stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-clients     updates   1.1-8-2     sparc
kerberos4kth-clients     updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-dev-common  stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-dev-common  updates   1.1-8-2     sparc
kerberos4kth-dev-common  updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-dev         stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-dev         updates   1.1-8-2     sparc
kerberos4kth-dev         updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-docs        stable    1.1-8-2     all
kerberos4kth-docs        updates   1.1-8-2     all
kerberos4kth-kdc         stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-kdc         updates   1.1-8-2     sparc
kerberos4kth-kdc         updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-kip         stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-kip         updates   1.1-8-2     sparc
kerberos4kth-kip         updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-servers-x   stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-servers-x   updates   1.1-8-2     sparc
kerberos4kth-servers-x   updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-servers     stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kerberos4kth-servers     updates   1.1-8-2     sparc
kerberos4kth-servers     updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
kerberos4kth-services    stable    1.1-8-2     all
kerberos4kth-services    updates   1.1-8-2     all
kerberos4kth-user        stable    1.1-8-2     all
kerberos4kth-user        updates   1.1-8-2     all
kerberos4kth-x11         stable    1.1-8-2     all
kerberos4kth-x11         updates   1.1-8-2     all
kerberos4kth1            stable    1.1-8-2     all
kerberos4kth1            updates   1.1-8-2     all
krb4                     stable    1.1-8-2     source
krb4                     updates   1.1-8-2     source
libacl1-kerberos4kth     stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libacl1-kerberos4kth     updates   1.1-8-2     sparc
libacl1-kerberos4kth     updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libkadm1-kerberos4kth    stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkadm1-kerberos4kth    updates   1.1-8-2     sparc
libkadm1-kerberos4kth    updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libkdb-1-kerberos4kth    stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkdb-1-kerberos4kth    updates   1.1-8-2     sparc
libkdb-1-kerberos4kth    updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libkrb-1-kerberos4kth    stable    1.1-8-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb-1-kerberos4kth    updates   1.1-8-2     sparc
libkrb-1-kerberos4kth    updates   1.1-8-2.2   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	DSA-184 krb4 - buffer overflow

	The sparc upload got lost somehow.
	

liblocale-gettext-perl  stable    1.01-11         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
liblocale-gettext-perl  updates   1.01-11a.woody  alpha, arm, hppa, i386, ia64, m68k, mipsel, powerpc, s390, sparc, source

	* The bugs #156381 is also in the stable version of the package. Since
	  it renders basic packages like debconf unusable when it's installed,
	  I'm providing this updated package to fix it.
	* Added the include <libintl.h> in the .xs file this time.
	* Really stupid version number to have a version number lower than
	  1.01-11bis which is in unstable...

	The bug report demonstrates that this problem may render an
	entire installation/upgrade broken.  Hence, an update is
	required.

	MISSING mips

libquota-perl  stable    1.4.1-1     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
libquota-perl  updates   1.4.1-2     alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Backported change for C code from unstable version (1.4.6) to
	fix major brokenness (Closes: #162385)

	The changes are too instrusive and large for me to check or
	author them.  An inquiry to the bug reporter is sent and
	should help clarification.

	MISSING arm

log2mail    stable    0.2.5       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
log2mail    updates   0.2.5.1     hppa, m68k, mipsel, s390

	DSA-186 log2mail - buffer overflow

	Half of the security update got thrown away by katie.

lsb         stable    1.1.0-11       all, source
lsb         updates   1.2-5.woody.1  all, source

	Too intrusive changes

	* Support LSB 1.2 in woody.  Includes all changes through 1.2-6 in sid.

	* Fix call to shadowconfig in postinst.  (Closed: #166041)

	* Add text to the debconf template that lets the user know that shadow
	  passwords are not needed by most LSB applications.

	* Remove duplicate --retry 5 from start-stop-daemon call.  (Closed: #165395)

	* Fix bugs in the init script registry code.  (Closed: #165038)

	* Support more specifications for the signal in "killproc".
	  (Closed: #163109)

	* Return non-zero exit status if "pidofproc" can't find the process.
	  (Closed: #157314)

	* Fix silly typos in install_initd.  (Closed: #152544)

	* Fix duplicated --retry 5.  (Closed: #152552)

	* Added support for facilities introduced in gLSB 1.2.  (Closed: #148568)
	  - $time: start >= S24, stop <= K21
	  - $portmap: start >= S19, stop <= K34

	* Removed support for the $netdaemons facility, which vanished from the
	  specification.  Hopefully nobody is using it...

	* Call pidof if it's available and /var/run/$1.pid doesn't exist.

murasaki    stable    0.5.4-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
murasaki    updates   0.5.4-2.1   alpha, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc, source

	The package in woody will break violently if you are installing it on a kernel
	without hotplug support, and will refuse to be removed if your
	kernel doesn't have hotplug support.

	MISSING arm
	MISSING ia64

libmysqlclient10-dev  stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libmysqlclient10-dev  updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libmysqlclient10      stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libmysqlclient10      updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
mysql-client          stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
mysql-client          updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
mysql-common          stable    3.23.49-8        all
mysql-common          updates   3.23.51-1woody4  all
mysql                 stable    3.23.49-8        source
mysql-dfsg            updates   3.23.51-1woody4  source
mysql-server          stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
mysql-server          updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	The Changelog says:

	* Please see 3.23.51-1woody2 for reasons that justify the woody update!
	* As ps doesn't work on all autobuilders (maybe no /proc in chroot)
	  I now disabled this check in ./configure as our target system will
	  be the same Linux anyway.

	Christian Hammers explained that 3.23.50 contains a fix
	against a bug resulting in a segementation fault that was
	fixed upstream.  3.23.51 also has some scripts changed.

	Creating a diff through both versions is not possible.  Many
	differences are made in documentation and file locations, and
	the source package was renamed as well.  I'm not convinced
	this should go into stable.

	Apart from that, arm and sparc ar mising, and .changes files for
	alpha, i386, ia64, mips, mipsel, powerpc and s390 are missing as well.

	MISSING arm
	MISSING sparc

ocaml-base              stable    3.04-12     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ocaml-base              updates   3.04-14     alpha, hppa, i386, ia64, m68k, mips, mipsel, s390, sparc
ocaml-native-compilers  stable    3.04-12     alpha, arm, i386, powerpc, sparc
ocaml-native-compilers  updates   3.04-14     alpha, i386, sparc
ocaml-source            stable    3.04-12     all
ocaml-source            updates   3.04-14     all
ocaml                   stable    3.04-12     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
ocaml                   updates   3.04-14     alpha, hppa, i386, ia64, m68k, mips, mipsel, s390, sparc, source

	Fixed postinst-ocamlld so it will now do its work also when
	upgrading a package, and not only when removing it.

	MISSING arm
	MISSING powerpc

qpopper-drac  stable    4.0.4-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
qpopper-drac  updates   4.0.4-2.woody.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
qpopper       stable    4.0.4-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
qpopper       updates   4.0.4-2.woody.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	qpopper couldn't work with Eudora clients and openssl
	0.9.6c-2.woody.1 that was provided in DSA-136.  This verison
	fixed that bug.

	MISSING arm

libprinterconf-dev  stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libprinterconf-dev  updates   0.5-4.woody.2  alpha, i386, m68k, mips, mipsel, powerpc, sparc
libprinterconf0     stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libprinterconf0     updates   0.5-4.woody.2  alpha, i386, m68k, mips, mipsel, powerpc, sparc
libprinterconf      stable    0.4-2          source
libprinterconf      updates   0.5-4.woody.2  source
libsnmpkit-dev      stable    0.9-1          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsnmpkit-dev      updates   0.9-4.woody.1  ia64
libsnmpkit-dev      updates   0.9-4.woody.2  alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libsnmpkit1         stable    0.9-1          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsnmpkit2         updates   0.9-4.woody.1  ia64
libsnmpkit2         updates   0.9-4.woody.2  alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
pconf-detect        stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
pconf-detect        updates   0.5-4.woody.2  alpha, i386, m68k, mips, mipsel, powerpc, sparc
snmpkit             stable    0.9-1          source
snmpkit             updates   0.9-4.woody.2  source

	Due to a maintainer bug the package libsnmpkit1 did not only
	contain libsnmpkit2.so.* but also lacked the libsnmpkit2.so
	link.  Hence, it's not exactly usable in woody.  In turn this
	renders packages like pconf-detect, gnulpr and printtool
	useless.

	Buildds are hopefully catching up.

	MISSING arm
	MISSING ia64
	MISSING s390
	MISSING sparc

	MISSING ia64
	MISSING sparc



super       stable    3.16.1-1    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
super       updates   3.16.1-1.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-139 super - format string vulnerability

	For some very strange reason, the arm package is missing and
	nobody noticed.

	MISSING arm

tkmail      stable    4.0beta9-8    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tkmail      updates   4.0beta9-8.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-172 tkmail - insecure temporary files

	Files for the ARM architecture got lost by katie, though

uptimed     stable    1:0.1.7-2        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
uptimed     updates   1:0.1.7-2woody0  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Fixed upgrade path from potato (Closes: #157918)

	This does not warrant an updated package, though.  Hmm, this
	could be considered as data desctruction during upgrade, hence
	it may warrant an upgrade.

	MISSING arm

xnc         stable    4.4.7-3          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
xnc         updates   4.4.7-3.woody.1  alpha, i386, ia64, m68k, mips, mipsel, s390, sparc, source

	Previous version was causing Debian menu system breakage when installed.

	MISSING arm
	MISSING hppa
	MISSING powerpc

Rejected Packages
-----------------

These packages don't meet the requirements and will be rejected (if
katie supports that, otherwise we'll just carry them with us until the
end of time).

debootstrap       stable    0.1.17      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
debootstrap       unstable  0.1.17.9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
debootstrap-udeb  unstable  0.1.17.9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	New code

docbook-xml-slides  stable    1.1-2          all, source
docbook-xml-slides  updates   1.1-2.1woody2  all, source

	Don't depend on obsolete library anymore.

	This bug is just an incorrect dependency in the control file,
	which makes docbook-xml-slides insist on pulling the obsolete
	docbook-xsl-stylesheets instead of recent docbook-xsl.  This
	in turns causes other packages to be uninstallable, because
	they correctly depend on the new one.

initrd-tools  stable    0.1.24         all, source
initrd-tools  updates   0.1.32woody.1  all, source

	Lots of intrusive changes, only one is priority high and it
	only affects people with ataraid.  Suited for unstable.

iamerican   stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
iamerican   updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
ibritish    stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ibritish    updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
ispell      stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
ispell      updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source
wbritish    stable    3.1.20-21.1       all
wbritish    updates   3.1.20.0-0woody1  all

	* for stable, same as 3.1.20.0-1, urgency low

	Probably no package that needs to be required in stable

	MISSING arm

kernel-patch-2.4.17-s390  stable    0.0.20020415-1          all, source
kernel-patch-2.4.17-s390  updates   0.0.20020816-0.woody.1  all, source

	* Integrated a new kernel-patch from the IBM Developerworks
	  website (released on 2002.06.12).
	  This patch fixes the DASD deadlock problem and some other severe
	  problems.
	
	* Removed NMU DASD deadlock fix.
	
	* Integrated a new kernel-patch from the IBM Developerworks
	  website (released on 2002.08.16).
	  This patch fixes a problem related to the IUCV driver.

	This sounds like a more or less regular update to me, which
	should not target the stable release.

partimage   stable    0.6.1-13        arm, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
partimage   updates   0.6.1-13woody1  arm, i386, m68k, mips, mipsel, powerpc, s390, sparc, source

	Changelog says:

	* This package doesn't contains documentation so, the call to install-docs
	  fails. Now, install-docs it's only called if there are something in
	  /usr/share/doc-base. Closes: #155023

	* Last package was a critical bug that becomes it on uninstable. The
	  problem was on a non existant directory needed by the postinstall script.
	  This package closes: #153835

	The package installs, upgrades and reinstalls fine, so no
	upgrade is required.

libecpg3            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libecpg3            updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
libpgperl           stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgperl           updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
libpgsql2           stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgsql2           updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
libpgtcl            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgtcl            updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
odbc-postgresql     stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
odbc-postgresql     updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
pgaccess            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
pgaccess            updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
postgresql-client   stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-client   updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
postgresql-contrib  stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-contrib  updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
postgresql-dev      stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-dev      updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390
postgresql-doc      stable    7.2.1-2          all
postgresql-doc      updates   7.2.2-0.woody.1  all
postgresql          stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
postgresql          updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390, source
python-pygresql     stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
python-pygresql     updates   7.2.2-0.woody.1  alpha, hppa, i386, mips, mipsel, s390

	Version 6.5.3-27.2 would be DSA-165 postgresql - buffer overflows

	Version 7.2.2-0.woody.1 is not an authorized new upstream version.

	Files from DSA-165 got lost though

python2.1   stable    2.1.3-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.1   updates   2.1.3-4.3   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.2   stable    2.2.1-4     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.2   updates   2.2.1-4.3   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	python2.1_2.1.3-3.2 is missing for 8 architectures, which got
	lost during the transfer from security.debian.org to ftp-master.

	The packages are completely fucked up except for python 1.5,
	hence, separated.  I guess we need mechanisms to avoid such
	situations.  Random maintainers uploading packages with higher
	versions than security updates, partially render the packages
	from security.debian.org unreachable and hence unusable.

libmilter-dev  stable    8.12.3-4       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libmilter-dev  updates   8.12.6-6Woody  alpha, hppa, i386, ia64, mipsel, powerpc, s390
sendmail-doc   stable    8.12.3-4       all
sendmail-doc   updates   8.12.6-6Woody  all
sendmail       stable    8.12.3-4       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
sendmail       updates   8.12.6-6Woody  alpha, hppa, i386, ia64, mipsel, powerpc, s390, source

	New upstream version.

libsocks4       stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsocks4       updates   4.3.beta2-12.woody.0  alpha, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
socks4-clients  stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
socks4-clients  updates   4.3.beta2-12.woody.0  alpha, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
socks4-server   stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
socks4-server   updates   4.3.beta2-12.woody.0  alpha, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc, source

	Changelog only says:

	* changed priority of libsocks4 to optional

	* fix building of rtelnet

	MISSING arm
	MISSING m68k

syslog-ng   stable    1.5.15-1    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
syslog-ng   updates   1.5.15-3    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Version 1.5.15-1.1 would be DSA-175 syslog-ng - buffer overflow

	Version 1.5.15-3 is not an authorized version.

	Files from DSA-175 got lost though

systemimager-bin-i386     stable    2.0.1-3woody0  all
systemimager-bin-i386     updates   2.0.1-3woody1  all
systemimager-client       stable    2.0.1-3woody0  all
systemimager-client       updates   2.0.1-3woody1  all
systemimager-common       stable    2.0.1-3woody0  all
systemimager-common       updates   2.0.1-3woody1  all
systemimager-doc          stable    2.0.1-3woody0  all
systemimager-doc          updates   2.0.1-3woody1  all
systemimager-initrd-i386  stable    2.0.1-3woody0  all
systemimager-initrd-i386  updates   2.0.1-3woody1  all
systemimager-kernel-i386  stable    2.0.1-3woody0  all
systemimager-kernel-i386  updates   2.0.1-3woody1  all
systemimager-server       stable    2.0.1-3woody0  all
systemimager-server       updates   2.0.1-3woody1  all
systemimager              stable    2.0.1-3woody0  source
systemimager              updates   2.0.1-3woody1  source

	fixed manpages which were corrupted in stable.  Closes: 153065

	Documentation fixes don't justify an upload to stable.

tilp        stable    5.03-1      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tilp        updates   5.03-2      alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source

	Changelog only says:

	* Fixed postrm script to not barf on purge (closes: Bug#153718).

	* Fixed segfault when opening a directory not readable by user.

	* Fixed permissions on newly-created directories (closes: Bug#153517).

	MISSING arm
	MISSING sparc

libwine-dev  stable    0.0.20020411-1  i386
libwine-dev  updates   0.0.20020411-2  i386
libwine      stable    0.0.20020411-1  i386
libwine      updates   0.0.20020411-2  i386
wine-doc     stable    0.0.20020411-1  i386
wine-doc     updates   0.0.20020411-2  i386
wine-utils   stable    0.0.20020411-1  i386
wine-utils   updates   0.0.20020411-2  i386
wine         stable    0.0.20020411-1  i386, source
wine         updates   0.0.20020411-2  i386, source

	Changelog says:

	* Explicitly depend on libfreetype6, and changed Wine code
	  to look for libfreetype.so.6 instead of libfreetype.so.
	  Closes: #147571.

	* Removed README.Debian reference to my old apt repository on WineHQ;
	  since they no longer run Debian, I can't host it there anymore.

	* Merged a few other small packaging fixes from unstable:

	  - doubled size of MAX_FONTS

	  - fixed wine-doc.doc-base

	  - updated debconf template translations

Disclaimer
----------

This list intends to help the ftp-masters releasing 3.0r1.  They have the
final power to accept a package or not.  If you want to comment on
this list, please send a mail to Martin Schulze <joey@debian.org>.

Last updated 2002/11/02 23:21 MET

-- 
This is Linux Country.  On a quiet night, you can hear Windows reboot.

Attachment: pgpn4LhGsVX05.pgp
Description: PGP signature


Reply to: