[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bits from the SRM



Not sure if people would like to read more bits, but if so, here are
some.  The first update of Debian woody is on its way.

Preparation of Debian GNU/Linux 3.0r1
=====================================

An up-to-date version is at <http://master.debian.org/~joey/3.0r1/>.

I am preparing the first revision of the current stable Debian
distribution (woody) and will infrequently send reports so people can
actually comment on it and intervene whenever this is required.

The plan is to release this revision at the beginning of October, 2002.
James Troup still has to give the final approval for each package
since he is the ftpmaster involved with stable revisions.  However, I
will try to make his work as easy as possible in the hope to get the
next revision out properly.

The regulations for stable are quite conservative.  The requirements
for packages to get into stable are:

 1. The package fixes a security problem.  An advisory by our own
    Security Team is required.  Updates need to be approved by the
    security team.

 2. The package fixes a critical bug which can lead into data loss,
    data corruption, or an overly broken system, or the package is
    broken or not usable (anymore).

 3. The stable version of the package is not installable at all due to
    broken or unmet dependencies or broken installation scripts.

 4. All released architectures have to be in sync.

It is (1 OR 2 OR 3) AND 4

Since this is the first revision of stable, I may be a little bit lax
about enforcing reason 2.

However, regular bugs and upgrade problems should instead be
documented in the Release Notes which are maintained by Rob Bradford
<robster@debian.org> and found at
<http://www.debian.org/releases/woody/releasenotes>.

Packages, which will most probably be rejected:

  . Packages that fix non-critical bugs.

  . Misplaced uploads, i.e. packages that were uploaded to 'stable
    unstable' or `frozen unstable' or similar.

  . Packages for which its binary packages are out of sync with regard
    to all supported architectures in the stable distribution.

  . Binary packages for which the source got lost somehow.

Accepted Packages
-----------------

These packages will be installed into the stable Debian distribution
and will be part of the next revision.

cacti       stable    0.6.7-2     all, source
cacti       updates   0.6.7-2.1   all, source

	DSA-164 cacti - arbitrary code execution

cron-apt    stable    0.0.6        all, source
cron-apt    updates   0.0.6woody1  all, source

	* Added default path so the upgrade will work fine. Thanks to Donovan
	  Baarda <abo@minkirri.apana.org.au> for pointing out the problem.
	  Closes: #158869.

	Rationale: Without the path, this package doesn't run out of
	the box on woody anymore.

debiandoc-sgml  stable    1.1.67        all, source
debiandoc-sgml  updates   1.1.67woody1  all, source

	On a machine which was upgraded from potato to woody a couple of
	months before release, there is a wrong entry in transitional.cat,
	which causes debiandoc to be unusable.  My opinion is, it is bad
	enough (and simple enough to fix) so that it must go into 3.0r1.

	* debian/postinst: added invocation of 'install-sgmlcatalog
	  --remove debiandoc-sgml' to clean up cruft potentially left
	  over from the SGML catalog transition in a potato -> woody
	  upgrade (closes: Bug#154737)

dietlibc-dev  stable    0.12-2      alpha, arm, i386, mips, mipsel, powerpc, sparc
dietlibc-dev  updates   0.12-2.4    alpha, arm, i386, mips, mipsel, powerpc, sparc
dietlibc      stable    0.12-2      source
dietlibc      updates   0.12-2.4    source

	DSA-146 dietlibc - integer overflow

elkdoc      stable    3.0-8.1     all
elk         stable    3.0-8.1     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
elk         updates   3.0-8.1     alpha

	Get architectures in sync (IA-64 is missing, though, but the
	package doesn't seem to compile on that arch)

ethereal-common  stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
ethereal-common  updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ethereal-dev     stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
ethereal-dev     updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ethereal         stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc, source
ethereal         updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tethereal        stable    0.9.4-1woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
tethereal        updates   0.9.4-1woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-162 ethereal - buffer overflow

fam         stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fam         updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
libfam-dev  stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam-dev  updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam0     stable    2.6.6.1-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libfam0     updates   2.6.6.1-5.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-154 fam - privilege escalation

gallery     stable    1.2.5-6          all, source
gallery     updates   1.2.5-7.woody.0  all, source

	DSA-138 gallery - remote exploit

gnome-pim-conduits  stable    1.4.6-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gnome-pim-conduits  updates   1.4.6-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gnome-pim           stable    1.4.6-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gnome-pim           updates   1.4.6-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	According to the bug reports mentioned in the changelog, one
	program from this package crashed upon startup, rendering it
	useless.  Hence, an update.

	* Fixing RC bugs:
	  + Closes: #145411: Gnomecal segfaults upon start
	  + Closes: #145517: gnomecal segfaults at startup
	  + Closes: #151781 (for stable): Problem loading GnomeCal conduit
	  + Closes: #155221: Gnomecal segfaults upon start and no fixed version of
	    gnome-pim is available in stable

hylafax-client  stable    1:4.1.1-1    alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-client  updates   1:4.1.1-1.1  alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-doc     stable    1:4.1.1-1    all
hylafax-doc     updates   1:4.1.1-1.1  all
hylafax-server  stable    1:4.1.1-1    alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax-server  updates   1:4.1.1-1.1  alpha, arm, hppa, i386, ia64, m68k, powerpc, s390, sparc
hylafax         stable    1:4.1.1-1    source
hylafax         updates   1:4.1.1-1.1  source

	DSA-148 hylafax - buffer overflows and format string vulnerabilities

interchange-cat-foundation  stable  4.8.3.20020306-1         all
interchange-cat-foundation  updates 4.8.3.20020306-1.woody.1 all
interchange-ui              stable  4.8.3.20020306-1         all
interchange-ui              updates 4.8.3.20020306-1.woody.1 all
interchange                 stable  4.8.3.20020306-1         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
interchange                 updates 4.8.3.20020306-1.woody.1 alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
libapache-mod-interchange   stable  4.8.3.20020306-1         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libapache-mod-interchange   updates 4.8.3.20020306-1.woody.1 alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-150 interchange - illegal file exposition

irssi-text  stable    0.8.4-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
irssi-text  updates   0.8.4-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-157 irssi-text - denial of service

kannel      stable    1.1.5-2     alpha, arm, hppa, i386, ia64, m68k, mips, powerpc, s390, sparc, source
kannel      updates   1.1.5-2     mipsel

	non-US

	Get architectures in sync.

krb5-admin-server  stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-admin-server  updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-clients       stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-clients       updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-doc           stable    1.2.4-5        all
krb5-doc           updates   1.2.4-5woody1  all
krb5-ftpd          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-ftpd          updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-kdc           stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-kdc           updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-rsh-server    stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-rsh-server    updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-telnetd       stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-telnetd       updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-user          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5-user          updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
krb5               stable    1.2.4-5        source
krb5               updates   1.2.4-5woody1  source
libkadm55          stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkadm55          updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb5-dev        stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb5-dev        updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb53           stable    1.2.4-5        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkrb53           updates   1.2.4-5woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-143 krb5 - integer overflow

libgd-dev        stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd-dev        updates   1.8.4-17.woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libgd-noxpm-dev  stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd-noxpm-dev  updates   1.8.4-17.woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libgd1-noxpm     stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1-noxpm     updates   1.8.4-17.woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libgd1           stable    1.8.4-16         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libgd1           updates   1.8.4-17.woody1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libgd            stable    1.8.4-16         source
libgd            updates   1.8.4-17.woody1  source

	* "Major Brown Bag"-release.
	* Make shlibs depend on libgd1-noxpm (not the non-existing libgd1-
	  xpm). This closes: bug#143856 - thanks to Ben Finney
	  <bignose@zip.com.au> for being awake when I am not.
	* Set urgency=high - same reasoning as -16.

libpng2-dev  stable    1.0.12-3          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2-dev  updates   1.0.12-3.woody.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2      stable    1.0.12-3          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng2      updates   1.0.12-3.woody.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpng       stable    1.0.12-3          source
libpng       updates   1.0.12-3.woody.2  source

	DSA-140 libpng - buffer overflow

mantis      stable    0.17.1-2    all, source
mantis      updates   0.17.1-2.5  all, source

	DSA-153 mantis - cross site code execution and privilege escalation

	DSA-161 mantis - privilege escalation

mhonarc     stable    2.5.2-1     all, source
mhonarc     updates   2.5.2-1.1   all, source

	DSA-163 mhonarc - cross site scripting

mpack       stable    1.5-7        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
mpack       updates   1.5-7woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-141 mpack - buffer overflow

libnessus-dev     stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libnessus-dev     updates   1.0.10-2.0.1  s390
libnessus1        stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libnessus1        updates   1.0.10-2.0.1  s390
nessus-core       stable    1.0.10-2      source
nessus-dev        stable    1.0.10-2      all
nessus-libraries  stable    1.0.10-2      source
nessusd           stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, sparc
nessusd           updates   1.0.10-2      powerpc
nessusd           updates   1.0.10-2.0.1  s390
nessus            stable    1.0.10-2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, sparc
nessus            updates   1.0.10-2      powerpc
nessus            updates   1.0.10-2.0.1  s390

	Get architectures in sync (despite BNMU)

libopenafs-dev          stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
libopenafs-dev          updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-client          stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-client          updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-dbserver        stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-dbserver        updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-fileserver      stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-fileserver      updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-kpasswd         stable    1.2.3final2-5  alpha, i386, powerpc, s390, sparc
openafs-kpasswd         updates   1.2.3final2-6  alpha, i386, powerpc, s390, sparc
openafs-modules-source  stable    1.2.3final2-5  all
openafs-modules-source  updates   1.2.3final2-6  all
openafs                 stable    1.2.3final2-5  source
openafs                 updates   1.2.3final2-6  source

	DSA-142 openafs - integer overflow

libssl-dev   stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libssl-dev   updates   0.9.6c-2.woody.0  m68k
libssl-dev   updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
libssl0.9.6  stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libssl0.9.6  updates   0.9.6c-2.woody.0  m68k
libssl0.9.6  updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc
openssl      stable    0.9.6c-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
openssl      updates   0.9.6c-2.woody.0  m68k
openssl      updates   0.9.6g-0.woody.1  alpha, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390, sparc, source
ssleay       stable    0.9.6c-2          all
ssleay       updates   0.9.6g-0.woody.1  all

	0.9.6c-2.woody.0: DSA-136 openssl - multiple remote exploits

	0.9.6c-2.woody.1: DSA-136 openssl - multiple remote exploits
	(update on security.debian.org)

	0.9.6g-0.woody.1 says:

	* new upstream version

	* fix manpage names (closes: #156717, #156718, #156719, #156721)

	* Use proper error handling instead of 'assertions' in buffer
	  overflow checks added in 0.9.6e.  This prevents DoS (the
	  assertions could call abort()). (closes: #155985, #156495)

	* Fix ASN1 checks. Check for overflow by comparing with LONG_MAX
	  and get fix the header length calculation.

	* include support for new sh* architectures (closes: #155117)

	Doesn't sound like it should make it into stable, hence reject	

postfix-tls  stable    1.1.11+tls0.7.15-0.woody1  alpha, hppa, i386, ia64, mips, mipsel, powerpc, s390, source
postfix-tls  updates   1.1.11+tls0.7.15-0.woody1  arm, m68k, sparc

	Get architectures in sync

purity      stable    1-14        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
purity      updates   1-14.2      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-166 purity - buffer overflows

python1.5   stable    1.5.2-23    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python1.5   updates   1.5.2-23.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-159 python - insecure temporary files

libscrollkeeper-dev  stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper-dev  updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper0     stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libscrollkeeper0     updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
scrollkeeper         stable    0.3.6-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
scrollkeeper         updates   0.3.6-3.1   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-160 scrollkeeper - insecure temporary file creation

silo        stable    1.2.5-1     sparc, source
silo        updates   1.2.5-2     sparc, source

	The silo I've uploaded to proposed-updates adds a patch from
	DaveM to support the newest UltraSPARC III+ machines.  Without
	it, they cannot be booted from disk.

	Add patch for UltraSPARC III+ (Cheetah+) support from DaveM.

tinyproxy   stable    1.4.3-1        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tinyproxy   updates   1.4.3-2woody2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-145 tinyproxy - doubly freed memory

wwwoffle    stable    2.7a-1      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
wwwoffle    updates   2.7a-1.2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-144 wwwoffle - improper input handling

xinetd      stable    1:2.3.4-1.1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
xinetd      updates   1:2.3.4-1.2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-151 xinetd - pipe exposure

Requires further Investigation
------------------------------

These packages need further investigation.  One reason the package is
listed here could be that I'm not yet convinced this package should go
into stable, but don't want to reject it entirely at the moment.

Another reason could be that released and updated architectures are
not yet in sync.

afterstep   stable    1.8.11-5woody1  alpha, hppa, i386, ia64, mips, mipsel, s390, sparc, source
afterstep   updates   1.8.11-5woody1  powerpc

	Try to sync architectures.

	There is an m68k package hooked up in testing-proposed-updates as well.

	The arm package was built on July 4th, but didn't make it into
	the archive, strangely.

	MISSING arm

arcboot     stable    0.3.1       mips, source

	Guido writes:

	- it don't lets failures to read from an ext2 fs completely crash the loader
	  (like when you enter a non existent partition in the prom)

	- it introduces tip22 as a separate binary package[1], a "piggyback" style
	  tftp loader that is used to pack kernel and initrd into one ecoff
	  file which can be tftpbooted. This finally solves the whole initrd
	  issues on mips. Without that mips will not be able to use kernels >
	  2.4.16 since Ralf revamped head.S(among others) which breaks our
	  current addinitrd method completely. Agreed, we could revert the
	  head.S changes but I'd rather like to avoid that because we might
	  trip on unwanted side effects. I already have a 2 line patch against
	  bootfloppies to use tip22 but don't want to commit it until it's sure
	  tip22 can go into r1.

	Before uploading packages, a new overrides line is required.

	ftpmaster is scared, so the upload has to happen before the
	overrides line will be added.  Guido will upload a package at
	the weekend.

docbook-xml-slides  stable    1.1-2       all, source

	This bug is just an incorrect dependency in the control file,
	which makes docbook-xml-slides insist on pulling the obsolete
	docbook-xsl-stylesheets instead of recent docbook-xsl.  This
	in turns causes other packages to be uninstallable, because
	they correctly depend on the new one.

	Yann will upload a fixed package.

fvwm        stable    2.4.6-2        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
fvwm        updates   2.4.6-2woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source

	Changelog says:

	* "No, restart Fvwm" command correction. Previous was to run
	  /usr/bin/X11/fvwm2, even fvwm is in /usr/bin since 2.4.5-2
	  (closes: #153983)

	This upload only corrects the path in the Debian menu.  The
	correction looks clean.  However, this problem only occurs to
	rather few people who restart fvwm.  This upload does not
	correct the font problem mentioned in the same bug report (not
	sure if it's fvwm's fault at all, though).

	MISSING arm
	MISSING sparc

gaim-common  stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gaim-common  updates   1:0.58-2.2  sparc
gaim-common  updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
gaim-gnome   stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
gaim-gnome   updates   1:0.58-2.2  sparc
gaim-gnome   updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
gaim         stable    1:0.58-2    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
gaim         updates   1:0.58-2.2  sparc, source
gaim         updates   1:0.58-2.3  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	DSA-158 gaim - arbitrary program execution

	Sparc and source packages got lost on the path from satie to auric

glibc              stable    2.2.5-6     source
glibc              updates   2.2.5-11.1  source
glibc-doc          stable    2.2.5-6     all
glibc-doc          updates   2.2.5-11.1  all
libc6-dbg          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dbg          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dev-sparc64  stable    2.2.5-6     sparc
libc6-dev-sparc64  updates   2.2.5-11.1  sparc
libc6-dev          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-dev          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-pic          stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-pic          updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-prof         stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-prof         updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6-sparc64      stable    2.2.5-6     sparc
libc6-sparc64      updates   2.2.5-11.1  sparc
libc6.1-dbg        stable    2.2.5-6     alpha, ia64
libc6.1-dbg        updates   2.2.5-11.1  alpha, ia64
libc6.1-dev        stable    2.2.5-6     alpha, ia64
libc6.1-dev        updates   2.2.5-11.1  alpha, ia64
libc6.1-pic        stable    2.2.5-6     alpha, ia64
libc6.1-pic        updates   2.2.5-11.1  alpha, ia64
libc6.1-prof       stable    2.2.5-6     alpha, ia64
libc6.1-prof       updates   2.2.5-11.1  alpha, ia64
libc6.1            stable    2.2.5-6     alpha, ia64
libc6.1            updates   2.2.5-11.1  alpha, ia64
libc6              stable    2.2.5-6     arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
libc6              updates   2.2.5-11.1  hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc
locales            stable    2.2.5-6     all
locales            updates   2.2.5-11.1  all
nscd               stable    2.2.5-6     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
nscd               updates   2.2.5-11.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	(DSA-149 glibc - integer overflow)

	Alleged security fix (fix commented out though *maintainer harrass*)

	Apart from that, the arm binary packages got lost on the way
	from satie to auric.

kdelibs-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs-dev    updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-bin   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-bin   updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-cups  stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-cups  updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3-doc   stable    4:2.2.2-13          all
kdelibs3-doc   updates   4:2.2.2-13.woody.3  all
kdelibs3       stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs3       updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
kdelibs        stable    4:2.2.2-13          source
kdelibs        updates   4:2.2.2-13.woody.3  source
libarts-alsa   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-alsa   updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts-dev    updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts        stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libarts        updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-alsa   stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-alsa   updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-dev    stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid-dev    updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid        stable    4:2.2.2-13          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libkmid        updates   4:2.2.2-13.woody.3  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	DSA-167 kdelibs - cross site scripting

	The arm packages got lost during transfer from
	security.debian.org to ftp-master, though.

.

	Anthony requested it's upload...

liblocale-gettext-perl  stable    1.01-11         alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
liblocale-gettext-perl  updates   1.01-11a.woody  alpha, arm, hppa, i386, ia64, m68k, mipsel, powerpc, s390, sparc, source

	* The bugs #156381 is also in the stable version of the package. Since
	  it renders basic packages like debconf unusable when it's installed,
	  I'm providing this updated package to fix it.
	* Added the include <libintl.h> in the .xs file this time.
	* Really stupid version number to have a version number lower than
	  1.01-11bis which is in unstable...

	The bug report demonstrates that this problem may render an
	entire installation/upgrade broken.  Hence, an update is
	required.

	MISSING mips

logtool     stable    1.0.6-7          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
logtool     updates   1.0.6-7.woody.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	* Backported fix for file-existence-error bug from unstable version.
	  (Closes: #153414). Release manager: this is just a one-character
	  change from 'test -f' to 'test -L', where the latter is the right
	  thing to do, is being done so for the other three cases, and works as is
	  for a few months now in unstable

	The bug report demonstrates that the package is not
	installable under certain circumstances without this fix.

	MISSING arm

mailman     stable    2.0.11-1woody1  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
mailman     updates   2.0.11-1woody4  i386
mailman     updates   2.0.11-1woody5  alpha, arm, hppa, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-147 mailman - cross-site scripting

	Plus: Fix a permission bug that renders the package
	uninstallable (upgrade with corrected perms would work,
	though)

	MISSING i386

libmysqlclient10-dev  stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libmysqlclient10-dev  updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libmysqlclient10      stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libmysqlclient10      updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
mysql-client          stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
mysql-client          updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
mysql-common          stable    3.23.49-8        all
mysql-common          updates   3.23.51-1woody4  all
mysql                 stable    3.23.49-8        source
mysql-dfsg            updates   3.23.51-1woody4  source
mysql-server          stable    3.23.49-8        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
mysql-server          updates   3.23.51-1woody4  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	The Changelog says:

	* Please see 3.23.51-1woody2 for reasons that justify the woody update!
	* As ps doesn't work on all autobuilders (maybe no /proc in chroot)
	  I now disabled this check in ./configure as our target system will
	  be the same Linux anyway.

	Doesn't sound like it needs to go into stable.

	Christian Hammers explained that 3.23.50 contains a fix
	against a bug resulting in a segementation fault that was
	fixed upstream.  3.23.51 also has some scripts changed.

	Creating a diff through both versions is not possible.  Many
	differences are made in documentation and file locations, and
	the source package was renamed as well.  I'm not convinced
	this should go into stable.

	Apart from that, arm and sparc ar mising, and .changes files
	for alpha, i386, ia64, mips, mipsel, powerpc and s390 are missing.

	MISSING arm
	MISSING sparc

php3        stable    3:3.0.18-23  alpha, arm, hppa, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
php4        stable    4:4.1.2-4    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
php4        updates   4:4.1.2-5    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-168 php - bypassing safe_mode, CRLF injection

	PHP3 is missing all along, it got lost on the way from satie
	to auric, apparently.

python2.1   stable    2.1.3-3     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.1   updates   2.1.3-4.3   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.2   stable    2.2.1-4     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
python2.2   updates   2.2.1-4.3   alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	python2.1_2.1.3-3.2 is missing for 8 architectures, which got
	lost during the transfer from security.debian.org to ftp-master.

	The packages are completely fucked up except for python 1.5,
	hence, separated.  I guess we need mechanisms to avoid such
	situations.  Random maintainers uploading packages with higher
	versions than security updates, partially render the packages
	from security.debian.org unreachable and hence unusable.

libpam-smbpass    stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpam-smbpass    updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libsmbclient-dev  stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient-dev  updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
libsmbclient      stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsmbclient      updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
samba-common      stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
samba-common      updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
samba-doc         stable    2.2.3a-6    all
samba-doc         updates   2.2.3a-8    all
samba             stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
samba             updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source
smbclient         stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
smbclient         updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
smbfs             stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
smbfs             updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
swat              stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
swat              updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
winbind           stable    2.2.3a-6    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
winbind           updates   2.2.3a-8    alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390

	Partially important fixes to make the package usable on stable
	again.  Tons of new debconf stuff as well, unfortunately.

	MISSING arm
	MISSING sparc

libprinterconf-dev  stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libprinterconf-dev  updates   0.5-4.woody.2  sparc
libprinterconf0     stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libprinterconf0     updates   0.5-4.woody.2  sparc
libprinterconf      stable    0.4-2          source
libprinterconf      updates   0.5-4.woody.2  source
libsnmpkit-dev      stable    0.9-1          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsnmpkit-dev      updates   0.9-4.woody.1  ia64, m68k
libsnmpkit-dev      updates   0.9-4.woody.2  sparc
libsnmpkit1         stable    0.9-1          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsnmpkit2         updates   0.9-4.woody.1  ia64, m68k
libsnmpkit2         updates   0.9-4.woody.2  sparc
pconf-detect        stable    0.4-2          alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
pconf-detect        updates   0.5-4.woody.2  sparc
snmpkit             stable    0.9-1          source
snmpkit             updates   0.9-4.woody.2  source

	Due to a maintainer bug the package libsnmpkit1 did not only
	contain libsnmpkit2.so.* but also lacked the libsnmpkit2.so
	link.  Hence, it's not exactly usable in woody.  In turn this
	renders packages like pconf-detect, gnulpr and printtool
	useless.

	Buildds are likely to catch up.

	MISSING alpha
	MISSING arm
	MISSING i386
	MISSING ia64
	MISSING m68k
	MISSING mips
	MISSING mipsel
	MISSING powerpc
	MISSING s390
	MISSING sparc

	MISSING alpha
	MISSING arm
	MISSING i386
	MISSING ia64
	MISSING m68k
	MISSING mips
	MISSING mipsel
	MISSING powerpc
	MISSING s390
	MISSING sparc



super       stable    3.16.1-1    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
super       updates   3.16.1-1.1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	DSA-139 super - format string vulnerability

	For some very strange reason, the arm package is missing and
	nobody noticed.

uptimed     stable    1:0.1.7-2        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
uptimed     updates   1:0.1.7-2woody0  alpha, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Fixed upgrade path from potato (Closes: #157918)

	This does not warrant an updated package, though.  Hmm, this
	could be considered as data desctruction during upgrade, hence
	it may warrant an upgrade.

	MISSING arm
	MISSING hppa

Rejected Packages
-----------------

These packages don't meet the requirements and will be rejected (if
katie supports that, otherwise we'll just carry them with us until the
end of time).

debootstrap       stable    0.1.17      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
debootstrap       unstable  0.1.17.9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
debootstrap-udeb  unstable  0.1.17.9    alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

	New code

iamerican   stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
iamerican   updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
ibritish    stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
ibritish    updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390
ispell      stable    3.1.20-21.1       alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
ispell      updates   3.1.20.0-0woody1  alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source
wbritish    stable    3.1.20-21.1       all
wbritish    updates   3.1.20.0-0woody1  all

	* for stable, same as 3.1.20.0-1, urgency low

	Probably no package that needs to be required in stable

	MISSING arm

murasaki    stable    0.5.4-2     alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
murasaki    updates   0.5.4-2.1   i386, source

	* NMU

	* Init script now exists silently if hotplug isn't supported by the
	  kernel (closes: #150615)

	Doesn't sound like a valid update to stable

partimage   stable    0.6.1-13        arm, i386, m68k, mips, mipsel, powerpc, s390, sparc, source
partimage   updates   0.6.1-13woody1  arm, i386, m68k, mips, mipsel, powerpc, s390, sparc, source

	Changelog says:

	* This package doesn't contains documentation so, the call to install-docs
	  fails. Now, install-docs it's only called if there are something in
	  /usr/share/doc-base. Closes: #155023

	* Last package was a critical bug that becomes it on uninstable. The
	  problem was on a non existant directory needed by the postinstall script.
	  This package closes: #153835

	The package installs, upgrades and reinstalls fine, so no
	upgrade is required.

libecpg3            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libecpg3            updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
libpgperl           stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgperl           updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
libpgsql2           stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgsql2           updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
libpgtcl            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libpgtcl            updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
odbc-postgresql     stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
odbc-postgresql     updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
pgaccess            stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
pgaccess            updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
postgresql-client   stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-client   updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
postgresql-contrib  stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-contrib  updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
postgresql-dev      stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
postgresql-dev      updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390
postgresql-doc      stable    7.2.1-2          all
postgresql-doc      updates   7.2.2-0.woody.1  all
postgresql          stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
postgresql          updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390, source
python-pygresql     stable    7.2.1-2          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
python-pygresql     updates   7.2.2-0.woody.1  alpha, i386, mips, mipsel, s390

	Version 6.5.3-27.2 would be DSA-165 postgresql - buffer overflows

	Version 7.2.2-0.woody.1 is not an authorized new upstream version.

	Files from DSA-165 got lost though

snort-common         stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-common         updates   1.8.4beta1-3  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-doc            stable    1.8.4beta1-2  all
snort-doc            updates   1.8.4beta1-3  all
snort-mysql          stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-mysql          updates   1.8.4beta1-3  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
snort-rules-default  stable    1.8.4beta1-2  all
snort-rules-default  updates   1.8.4beta1-3  all
snort                stable    1.8.4beta1-2  alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
snort                updates   1.8.4beta1-3  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Changelog says:

	  + Mandatory upload to stable because the previous package
	    had serious problems that were fixed only one package release
	    later that JUST didn't get into woody.

	  ! Fixed 'snort.debian.conf is empty at fresh install'

	  + New 'snort-stat' included, fixes 'Empty subject' bugs

	  + Fixes to daily cronjob's email thingy.
	    Now honours DEBIAN_SNORT_STAT_TRESHOLD

	New code and a bug that should rather be documented in the
	release notes

	MISSING hppa

libsocks4       stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libsocks4       updates   4.3.beta2-12.woody.0  alpha, i386, ia64, mips, mipsel, powerpc, s390, sparc
socks4-clients  stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
socks4-clients  updates   4.3.beta2-12.woody.0  alpha, i386, ia64, mips, mipsel, powerpc, s390, sparc
socks4-server   stable    4.3.beta2-12          alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
socks4-server   updates   4.3.beta2-12.woody.0  alpha, i386, ia64, mips, mipsel, powerpc, s390, sparc, source

	Changelog only says:

	* changed priority of libsocks4 to optional

	* fix building of rtelnet

	MISSING arm
	MISSING hppa
	MISSING m68k

systemimager-bin-i386     stable    2.0.1-3woody0  all
systemimager-bin-i386     updates   2.0.1-3woody1  all
systemimager-client       stable    2.0.1-3woody0  all
systemimager-client       updates   2.0.1-3woody1  all
systemimager-common       stable    2.0.1-3woody0  all
systemimager-common       updates   2.0.1-3woody1  all
systemimager-doc          stable    2.0.1-3woody0  all
systemimager-doc          updates   2.0.1-3woody1  all
systemimager-initrd-i386  stable    2.0.1-3woody0  all
systemimager-initrd-i386  updates   2.0.1-3woody1  all
systemimager-kernel-i386  stable    2.0.1-3woody0  all
systemimager-kernel-i386  updates   2.0.1-3woody1  all
systemimager-server       stable    2.0.1-3woody0  all
systemimager-server       updates   2.0.1-3woody1  all
systemimager              stable    2.0.1-3woody0  source
systemimager              updates   2.0.1-3woody1  source

	fixed manpages which were corrupted in stable.  Closes: 153065

	Documentation fixes don't justify an upload to stable.

tilp        stable    5.03-1      alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
tilp        updates   5.03-2      alpha, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, source

	Changelog only says:

	* Fixed postrm script to not barf on purge (closes: Bug#153718).

	* Fixed segfault when opening a directory not readable by user.

	* Fixed permissions on newly-created directories (closes: Bug#153517).

	MISSING arm
	MISSING sparc

libwine-dev  stable    0.0.20020411-1  i386
libwine-dev  updates   0.0.20020411-2  i386
libwine      stable    0.0.20020411-1  i386
libwine      updates   0.0.20020411-2  i386
wine-doc     stable    0.0.20020411-1  i386
wine-doc     updates   0.0.20020411-2  i386
wine-utils   stable    0.0.20020411-1  i386
wine-utils   updates   0.0.20020411-2  i386
wine         stable    0.0.20020411-1  i386, source
wine         updates   0.0.20020411-2  i386, source

	Changelog says:

	* Explicitly depend on libfreetype6, and changed Wine code
	  to look for libfreetype.so.6 instead of libfreetype.so.
	  Closes: #147571.

	* Removed README.Debian reference to my old apt repository on WineHQ;
	  since they no longer run Debian, I can't host it there anymore.

	* Merged a few other small packaging fixes from unstable:

	  - doubled size of MAX_FONTS

	  - fixed wine-doc.doc-base

	  - updated debconf template translations

libwings-dev     stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwings-dev     updates   0.80.0-4woody1  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwmaker0-dev   stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwmaker0-dev   updates   0.80.0-4woody1  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2-dev  stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2-dev  updates   0.80.0-4woody1  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2      stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
libwraster2      updates   0.80.0-4woody1  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc
wmaker           stable    0.80.0-4        alpha, arm, hppa, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source
wmaker           updates   0.80.0-4woody1  alpha, arm, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc, source

	Changelog says

	* debian/control: revert move to libpng-dev introduced in previous
	  release.  This breaks packages that depend on libwraster2.  There
	  are a couple of packages (e.g., wdm) currently in woody which are
	  affected by this.

	* debian/rules: import changes from 0.80.0-5; it removes all those
	  superfluous libraries from get-wraster-config's output.  These are
	  handled by the linker itself.  It prevents applications from linking
	  against spurious libraries.  Also bumps shlibs info for libwraster2 to
	  this version.

	* With these changes this effectively duplicates 0.80.0-5

	I believe the changes are rather intrusive and should
	therefore not make it into a stable update.

	MISSING hppa

Disclaimer
----------

This list intends to help the ftp-masters releasing 3.0r1.  They have the
final power to accept a package or not.  If you want to comment on
this list, please send a mail to Martin Schulze <joey@debian.org>.

Regards,

	Joey

PS: SRM = Stable Release Manager
-- 
Whenever you meet yourself you're in a time loop or in front of a mirror.

Attachment: pgp63Du0h18YO.pgp
Description: PGP signature


Reply to: