[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem cross-compiling glib based program



On 2016-11-24 20:32, Wookey wrote:
> On 2016-11-24 19:56 +0100, W. Martin Borgert wrote:
> > This brings me to the next problem: When installing libglib2.0-dev:armel,
> > libglib2.0-dev gets uninstalled, same for libglib2.0-dev:armhf.
> > That's probably #648621/#683593, right?
>
> Oh dear, yes. Still not fixed after 5 years. And lots of things use glib.

Reading https://bugs.debian.org/683593#30 it looks not so easy
to fix. Breaking libglib2.0-dev would not contribute to ones
popularity, I assume.

> The workaround is to do your crossbuilds in a chroot where the native
> glib is not installed.

That's what I thought, but wanted to avoid. Be it then...


Reply to: