[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#872114: cloud-init: fdisk dependency needed



Source: cloud-init
Version: 0.7.9-3
Severity: important
User: util-linux@packages.debian.org
Usertags: fdisk-dependency

Hello,

As recently announced on debian-devel-announce[1] packages who need
any of sfdisk, cfdisk or fdisk will need to add a dependency on the
new fdisk package.

Your package cloud-init showed up on codesearch.debian.net and a very
quick analysis suggested you might want to add a dependency (and/or
build-dependency if you use it at build-time, eg. tests).

Please use the backwards-compatible way of specifying the dependency
as suggested in the debian-devel-announce mail:

fdisk | util-linux (<< 2.29.2-3~)

(and if only for tests you might want to add the build profile
<!nocheck>)

Please reassign this bug report to the binary package shipping the
affected part of your source.

If your more detailed analysis shows this should be a recommends,
suggests or even no relationship at all to the fdisk package then
please just close this bug report stating the results of your
analysis (and if so sorry for bothering you).

Regards, Andreas Henriksson

[1]:
https://lists.debian.org/debian-devel-announce/2017/08/msg00005.html 


Reply to: