[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#1001366: plakati: autopkgtest tests for all supported python3s but fails to install them,08-12-2021 23:05



Source: plakativ
Version: 0.5-1
Severity: serious
X-Debbugs-CC: debian-ci@lists.debian.org
Tags: sid bookworm
User: debian-ci@lists.debian.org
Usertags: needs-update
Control: affects -1 src:python3-defaults

Dear maintainer(s),

With a recent upload of python3-defaults the autopkgtest of plakativ fails in testing when that autopkgtest is run with the binary packages of python3-defaults from unstable. It passes when run with only packages from testing. In tabular form:

                       pass            fail
python3-defaults       from testing    3.9.8-1
plakativ               from testing    0.5-1
all others             from testing    from testing

I copied some of the output at the bottom of this report. It seems the test tries to test for all supported Python3 versions, but fails to ensure all those versions are actually installed during the test.

Currently this regression is blocking the migration of python3-defaults to testing [1].

More information about this bug and the reason for filing it can be found on
https://wiki.debian.org/ContinuousIntegration/RegressionEmailInformation

Paul

[1] https://qa.debian.org/excuses.php?package=python3-defaults

https://ci.debian.net/data/autopkgtest/testing/amd64/p/plakativ/17393444/log.gz

env: ‘python3.10’: No such file or directory
autopkgtest [12:12:17]: test testsuite

Attachment: OpenPGP_signature
Description: OpenPGP digital signature


Reply to: