[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 内核升级后X启动问题 ?



On Wed, Jul 16, 2008 at 04:30:23PM +0800, Jason wrote:
> > 再请教一个简单点的问题:
> > /etc/network/interfaces
> > 里面默认的配置是dhcp模式的,我将其改成了静态IP模式,但每次系统启动后都没有IP,需要手动执行"sudo ifup eth0"才能获得。
> >
> > 为什么改成静态之后该脚本就不再调用了昵(原来dhcp模式时每次启动都有IP的,说明该文件有被调用啊) ?
> >
> 
>  /etc/network/interfaces加上:
> auto eth0
> 
> >
> > 2008/7/16 zwang <wzc0066@gmail.com>:
> >>
> >> 各位好:
> >>
> >> 系统是debian lenny, 现象系统有两个版本的内核(新的2.6.25-2是前两天刚更新的)。
> >>
> >>
> >> 在使用旧内核时,为了使用compiz而装了nvidia驱动;现在使用新内核进行启动时,X启动不起来了,看Log中说好像是因为nvidia模块加载失败的问题!(搜索了一下nvidia.ko,nvidia好像是被装到老的内核module中去了)
> >>
> >> 然后用新内核启动后准备重新安装一下nvidia驱动,可提示说该内核是xen版本,nvidia不支持,那么我该如果让 X 在新内核下工作昵?
> >> BTW:用旧的内核启动都还是正常的。
我是 sid, NV Geforce2, bug#477643 [1],已经有更新的驱动包了。其实只要把 NV 驱动
(脚本) 里面关于xen 检测的代码删掉就可以了。

zwang, 你不妨可以自己打 patch 或者用新的 etch 的 driver package。其实 google 
一下就清楚了 [2]。=)

> >
> 
> 那么你装的是xen版本的内核喽?新力德里搜一下 2.6.25,装和老内核一样后缀的版本.
> 另外,如果nvidia的驱动是nvidia网站上下的话,装了新内核之后,要重编译nvidia的内核模块.切换到终端,
> sudo /etc/init.d/gdm stop
> sudo YOUR_DRIVER_FILE_PATH_AND_FILE -K

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477643
[2]
http://www.google.com/search?q=Xen+kernel+debian+nvidia+&ie=utf-8&oe=utf-8&aq=t&rls=org.debian:en-US:unofficial&client=iceweasel-a

-- 
Regards,
Kov Chai
2008.07.16 Wed

--
PI=
3.141592653589793238462643383279502884
19716939937510582097494459230781640628
6208998628034825342117067982148086513...

Attachment: signature.asc
Description: Digital signature


Reply to: