[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bilow autobuilder cannot build ISO images



The autobuilder which had been working fine for some time has suddenly
started failing with an unsatisfiable dependency against the live mirror:

debian@guardian:/usr/share/debian-cd$ make correctstatus
Apt-get is updating his files ... Reading Package Lists... Done
Building Dependency Tree... Done
# You may need to launch correctstatus more than one time
# in order to correct all dependencies
#
# Removing packages from the system :
#
# Adding packages to the system :
libstdc++2.10-dev
E: read, still have 2 to read but none left
#
# Showing the output of apt-get check :
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  g++: Depends: libstdc++2.10-dev (>= 1:2.95.2-10) but it is not installed
E: Unmet dependencies. Try using -f.
make: *** [correctstatus] Error 100

I am not exactly sure what is happening here, since the package in the
mirror looks to be installable.  $APTTMP/potato-i386/temp.apt-selection
contains:

Reading Package Lists...
Building Dependency Tree...
Correcting dependencies... Done
The following extra packages will be installed:
  libstdc++2.10-dev
The following NEW packages will be installed:
  libstdc++2.10-dev
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Inst libstdc++2.10-dev
Conf libstdc++2.10-dev

-- Mike




Reply to: