[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#594330: libusb2 doesn't detect any devices

Package: libusb2
Version: 8.1-3
Severity: grave
Tags: patch


libusb2 is unusable because libusb_get_device_list doesn't detect any devices. This happens because libusb20_be_alloc_ugen20 is disabled.

This problem can be reproduced with lsusb from http://code.google.com/p/segin-utils/source/browse/trunk/freebsd-utils/lsusb-libusb.c.

I'm providing a patch.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: kfreebsd-amd64 (x86_64)

Kernel: kFreeBSD 8.1-1-amd64
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libusb2 depends on:
ii  libbsd0                       0.2.0-1    utility functions from BSD systems
ii  libc0.1                       2.11.2-2   Embedded GNU C Library: Shared lib

libusb2 recommends no packages.

libusb2 suggests no packages.

-- no debconf information
diff -Nurp freebsd-libs-8.1/lib/libusb/libusb20.c freebsd-libs-8.1-new/lib/libusb/libusb20.c
--- freebsd-libs-8.1/lib/libusb/libusb20.c	2010-04-06 20:34:05.000000000 -0400
+++ freebsd-libs-8.1-new/lib/libusb/libusb20.c	2010-08-25 06:54:51.453938361 -0400
@@ -1166,7 +1166,7 @@ libusb20_be_alloc_ugen20(void)
 	struct libusb20_backend *pbe;
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
 	pbe = libusb20_be_alloc(&libusb20_ugen20_backend);
 	pbe = NULL;

Reply to: