[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#895620: marked as done (debian-installer fails due to DHCP issue)

Your message dated Fri, 13 Apr 2018 20:18:27 +0200
with message-id <87zi27ynpo.fsf@hands.com>
and subject line Re: Bug#895620: please ignore this for now
has caused the Debian Bug report #895620,
regarding debian-installer fails due to DHCP issue
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

895620: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895620
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer

My setup: 

Debian PXE server  -----------severalL3 segments -----DHCP-Proxy--------Debian DHCP/PXE Client 
Debian DHCP server
Debian TFTP server
Debian HTTP server 

I am trying to use PXE boot by using debian stretch and i am trying to load a preseed file. 
After a successful pxe (client system got IP from dhcp server, i can see the PXE options dialogue), I select  the debian auto installer which kicks in but it fails at taking the preseed file. After looking into it it seem to me that the problem is that the system does not wait for DHCP long enough.   

I monitored the activity on the network side and i see 2 strange things: 

-Debian Installer says that it successfully configured the network but this is false as i can see that there was no new request coming to the DHCP server. Also on the L3 switch (DHCP proxy) side where the debian DHCP client is directly connected  i do not see an arp entry anymore after the installer kicks in nor do i see the client sending a DHCP DISCOVER hitting it from client side. 
-I have noticed that if i wait long enough (while blue screen is on) and i get the failure message related to the preseed file GET failure. If at this point i go back to the "configure network" menu and i relaunch it , i can get an IP address fine now and subsequently then the preseed file is taken successfully also. 

Here are some things i tried to resolve the issue: 
-I went into BOOT_DEBUG=2 and once i see the network issue. i can go right back to "configure network", i get an IP. This works every time. 

-I tried adjusting the link detect time to 10 instead of default 3 but this did not help. 

I can consistently reproduce this problem. 


--- End Message ---
--- Begin Message ---
George Roman <georgeroman@gmail.com> writes:

> Hi guys,
> Please ignore this "bug" for now.

That looks like a request to close the bug, so that's what I'm doing.

For future reference, you could have done that yourself by adding the
-done after the bug number, as I do now.

BTW it sounds like you've got another DHCP server somewhere on your
network, that's answering faster than the proxied server -- normally the
DHCPACK gets logged, along with the IP address of the server than sent
it, so that ought to tell you where it's hiding.

Cheers, Phil.
|)|  Philip Hands  [+44 (0)20 8530 9560]  HANDS.COM Ltd.
|-|  http://www.hands.com/    http://ftp.uk.debian.org/
|(|  Hugo-Klemm-Strasse 34,   21075 Hamburg,    GERMANY

Attachment: signature.asc
Description: PGP signature

--- End Message ---

Reply to: