[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#597223: marked as done (udev: The First partition on USB flashdrives always attempts to be mounted as ISOFS)

Your message dated Wed, 27 Jul 2011 16:47:20 +0000
with message-id <E1Qm7GS-0003A8-Bk@franck.debian.org>
and subject line Bug#597223: fixed in partman-target 75
has caused the Debian Bug report #597223,
regarding udev: The First partition on USB flashdrives always attempts to be mounted as ISOFS
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

597223: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=597223
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: udev
Version: 160-1
Severity: important

I tried 4 or 5 different brands of flash drives all with the same result.
There are three partition setup on this flash drive.
sdb2 and sdb3 automount and work without any problems but
sbb1 will always attempt to mount as an ISOFS.
I'm guessing for some reason udev is assuming it's a U3 image?

kernel: [ 1603.007096] usb-storage: device found at 6
kernel: [ 1603.007101] usb-storage: waiting for device to settle before
kernel: [ 1608.007795] usb-storage: device scan complete
kernel: [ 1608.008314] scsi 9:0:0:0: Direct-Access     SanDisk  SanDisk Cruzer
8.02 PQ: 0 ANSI: 0 CCS
kernel: [ 1608.010113] sd 9:0:0:0: Attached scsi generic sg2 type 0
kernel: [ 1608.010886] sd 9:0:0:0: [sdb] 15753215 512-byte logical blocks:
(8.06 GB/7.51 GiB)
kernel: [ 1608.011382] sd 9:0:0:0: [sdb] Write Protect is off
kernel: [ 1608.011385] sd 9:0:0:0: [sdb] Mode Sense: 45 00 00 08
kernel: [ 1608.011387] sd 9:0:0:0: [sdb] Assuming drive cache: write through
kernel: [ 1608.014133] sd 9:0:0:0: [sdb] Assuming drive cache: write through
kernel: [ 1608.014141]  sdb: sdb1 sdb2 sdb3
kernel: [ 1608.016644] sd 9:0:0:0: [sdb] Assuming drive cache: write through
kernel: [ 1608.016649] sd 9:0:0:0: [sdb] Attached SCSI removable disk
kernel: [ 1609.068133] UDF-fs: No VRS found
kernel: [ 1609.068137] UDF-fs: Rescanning with blocksize 2048
kernel: [ 1609.602188] EXT4-fs (sdb2): mounted filesystem with ordered data
kernel: [ 1609.683431] UDF-fs: No VRS found
kernel: [ 1609.683439] UDF-fs: No partition found (1)
kernel: [ 1609.726774] ISOFS: Unable to identify CD-ROM format.
ntfs-3g[3073]: Version 2010.3.6 integrated FUSE 27
ntfs-3g[3073]: Mounted /dev/sdb3 (Read-Write, label "Cruize_Ntfs", NTFS 3.1)
ntfs-3g[3073]: Cmdline options:
ntfs-3g[3073]: Mount options:
ntfs-3g[3073]: Global ownership and permissions enforced, configuration type 1
ntfs-3g[3073]: Unmounting /dev/sdb3 (Cruize_Ntfs)
kernel: [ 1749.583274] usb 3-1: USB disconnect, address 6

Unable to mount Cruize_BAD
Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

what works?
mount -t ext4 /dev/sdb1 /media/Cruize_BAD
The filesystem will mount and work fine but mount can only be used with root

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages udev depends on:
ii  debconf [debconf-2.0]        1.5.35      Debian configuration management sy
ii  libc6                        2.11.2-5    Embedded GNU C Library: Shared lib
ii  libselinux1                  2.0.96-1    SELinux runtime shared libraries
ii  libudev0                     160-1       libudev shared library
ii  libusb-0.1-4                 2:0.1.12-16 userspace USB programming library
ii  lsb-base                     3.2-23.1    Linux Standard Base 3.2 init scrip
ii  util-linux                   2.17.2-3.1  Miscellaneous system utilities

Versions of packages udev recommends:
ii  pciutils                      1:3.1.7-5  Linux PCI Utilities
ii  usbutils                      0.87-5     Linux USB utilities

udev suggests no packages.

-- debconf information:
  udev/new_kernel_needed: false

--- End Message ---
--- Begin Message ---
Source: partman-target
Source-Version: 75

We believe that the bug you reported is fixed in the latest version of
partman-target, which is due to be installed in the Debian FTP archive:

  to main/p/partman-target/partman-target_75.dsc
  to main/p/partman-target/partman-target_75.tar.gz
  to main/p/partman-target/partman-target_75_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 597223@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Jérémy Bobbio <lunar@debian.org> (supplier of updated partman-target package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA256

Format: 1.8
Date: Wed, 27 Jul 2011 18:39:59 +0200
Source: partman-target
Binary: partman-target
Architecture: source all
Version: 75
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Jérémy Bobbio <lunar@debian.org>
 partman-target - Provides partman with ability to prepare /target (udeb)
Closes: 597223
 partman-target (75) unstable; urgency=low
   [ Jérémy Bobbio ]
   * Stop treating ISO hybrid images on USB sticks as real optical drives.
     (Closes: #597223)
   [ Updated translations ]
   * Macedonian (mk.po) by Arangel Angov
   * Sinhala (si.po) by Danishka Navin
 a887cec02d4646dcf87e77cad3990e46816f7bf2 1586 partman-target_75.dsc
 526778ee26a5588dc629bb13bc272eb9178aaa49 138165 partman-target_75.tar.gz
 8378462412c1adf0bfab737939cc226e3fe690b2 112504 partman-target_75_all.udeb
 e8a64b42d8e0d5b62c7261bb78e15abc40f91cb23076e92c9c8fb827971611dc 1586 partman-target_75.dsc
 e893cc1fe4cc75df5d16a70a5eaba29246fe7109c74596d78442f9efb10f17f2 138165 partman-target_75.tar.gz
 78de71fffdfadc02b4893c20ab153dbbf4565218a3488328978d745ee9f7f1b0 112504 partman-target_75_all.udeb
 3b89ddd94be40a3a3eabdbcef8a372bd 1586 debian-installer standard partman-target_75.dsc
 89180f83dd4413a28e378f45f4878080 138165 debian-installer standard partman-target_75.tar.gz
 6f3f2deec770621002a276ce1fe5ca48 112504 debian-installer standard partman-target_75_all.udeb
Package-Type: udeb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: