[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#533091: marked as done (archive.gpg in amd64 netboot.tar.gz for etch)

Your message dated Sat, 16 Oct 2010 17:44:14 +0200
with message-id <20101016154414.GA5421@dedibox.ebzao.info>
and subject line Re: Bug#533091: archive.gpg in amd64 netboot.tar.gz for etch
has caused the Debian Bug report #533091,
regarding archive.gpg in amd64 netboot.tar.gz for etch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

533091: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=533091
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


For some time now, I've been running into the problem where I just get the error "Downloading a file failed" in the initial stages of installation, but I didn't get around to finding the cause until recently. As far as I can tell, the /usr/share/keyrings/archive.gpg file in the initrd is out of date, but only in the amd64 netinstaller for etch. The i386 netinstaller works just fine. Because it's out of date it cannot verify the authenticity of the Release file.

So I tried replacing the /usr/share/keyrings/archive.gpg file in the amd64 initrd with the same file from the i386 initrd. Problem solved!



-- Package-specific info:

Boot method: network
Image version: http://ftp.us.debian.org/debian/dists/etch/main/installer-amd64/current/images/netboot/netboot.tar.gz 2009-Apr-07 23:08:05
Date: 2009-Jun-11 20:00:00

Machine: various Dell PowerEdge servers and virtual machines
Partitions: N/A

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [ ]
Load installer modules: [E]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]

--- End Message ---
--- Begin Message ---
Version: 20070308etch7

Verified OK against the last release installer in oldstable.

diff ./i386/debian-installer/i386/usr/share/keyrings/archive.gpg ./amd64/debian-installer/amd64/usr/share/keyrings/archive.gpg

On Tue, Jun 16, 2009 at 08:00:19PM +0200, Luk Claes wrote:
> Otavio Salvador wrote:
> > Hello Pascal,
> > 
> > On Tue, Jun 16, 2009 at 5:58 AM, Pascal
> > Vandeputte<debian-bugs@asmodeus.be> wrote:
> > [...]
> >> # ls -al initrd-{amd64,i386}/usr/share/keyrings/archive.gpg
> >> -rw-r--r-- 1 pvdputte pvdputte 4148 2009-06-16 10:42
> >> initrd-amd64/usr/share/keyrings/archive.gpg
> >> -rw-r--r-- 1 pvdputte pvdputte 5801 2009-06-16 10:42
> >> initrd-i386/usr/share/keyrings/archive.gpg
> >>
> >> You can see that the i386 archive.gpg file is clearly larger.
> > [...]
> > 
> > This is indeed a problem; probably the package were not up to date on
> > the used mirror :(
> > 
> > RM team,
> > 
> > Is there a way to update the installer in case?
> If it's binNMU safe, we could try a binNMU, otherwise it's best to
> either do a porter NMU if possible or a sourceful upload otherwise.
> The resulting package will be in oldstable-proposed-updates till the
> next oldstable point release.

Simon Paillard

--- End Message ---

Reply to: