[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#598601: marked as done (installation-reports)

Your message dated Sat, 2 Oct 2010 14:10:48 +0200
with message-id <20101002121048.GP25211@mykerinos.kheops.frmug.org>
and subject line Re: Bug#598601: Now successfull install PDX-057T-5A
has caused the Debian Bug report #598601,
regarding installation-reports
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

598601: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598601
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Boot method: USB memory stick (Kingston datatrafeler 1 GB)
Image version: http://people.debian.org/~joeyh/d-i/images/daily/hd-media/ 30-Sep 10:06
Date: 2010-09-30 13:15 EET

Machine: PDX-057T-5A panel PC
Processor: Vortex86DX
Memory: 256 Mt
Output of lspci -knn (or lspci -nn):
Will provide this later when I boot the panel pc again.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O ]
Detect network card:    [O ]
Configure network:      [O ]
Detect CD:              [ ]
Load installer modules: [O ]
Detect hard drives:     [E ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [E ]

Comments/Problems: Installer did not find Compact Flash card or SD-card installed in card reader. Only "hard disk" found was the USB memory I booted from. Could not continue with the install, since target media was not detected. Still, this is better than Lenny where installation ended in kernel panic after getting network settings from DHCP (seems driver for ethernet is only in newer kernels).

--- End Message ---
--- Begin Message ---
Quoting Tapio Lehtonen (tapio.lehtonen@dnainternet.net):
> Christian PERRIER kirjoitti:
> >Quoting Tapio Lehtonen (tapio.lehtonen@dnainternet.net):
> >
> >
> >>Then SD-card showed up as /dev/sdb and USB stick as /dev/sda.
> >>Boot media was USB stick, installed on SD-card. I guessed boot
> >>fails because SD card becomes /dev/sda when USB-stick is
> >>removed, so at the boot after installation I changed GRUB2
> >>config, changed
> >>  set root='(hd1,msdos1)'
> >>to
> >>  set root='(hd0,msdos1)'
> >>
> >>Now panel pc works fine.
> >
> >
> >Hmmm, do you think that something needs to be fixed in d-i or do you
> >finally consider this as a fully successful install?
> >
> >
> My understanding is, the first install failed because BIOS on this
> embedded computer is screwy. BIOS did not show inserted flash cards
> as IDE devices, and booting from live Debian I still could not see
> the flash cards in card reader, only the usb memory stick or SD card
> I booted from. Some setting in BIOS was unsuitable, resetting to
> factory defaults set the BIOS to sensible values and installation
> succeeded. It would have been nice if d-i had managed to see all the
> media in the computer, but it is not reasonable to expect d-i to
> work around BIOS settings that are somehow unsuitable.
> So I think d-i was *not* at fault. Debian installer from Squeeze
> works on this embedded computer (but lenny does not, lenny kernel
> does not have drivers for ethernet device).

OK, that was what I suspected. Just wanted to confirm. Hence closing
the installation report.

Thanks for your report.

--- End Message ---

Reply to: