[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#504721: marked as done (Console broken on debian-installer on Sparc LDOM)

Your message dated Fri, 05 Dec 2008 13:17:02 +0000
with message-id <E1L8aYI-0003cS-Nt@ries.debian.org>
and subject line Bug#504721: fixed in rootskel 1.71
has caused the Debian Bug report #504721,
regarding Console broken on debian-installer on Sparc LDOM
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

504721: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504721
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: rootskel
Version: 1.69
Severity: important

Hi rootskel maintainers :)

I've been trying to get debian-installer (lenny) working on a Sun LDOM
(i.e., SPARC, sun4v).  I'm having some trouble, though.  When the
installer boots, you get a mono console, and the arrow keys, tab, and
enter don't do as expected (enter scrolls down the screen, tab does a
tab, etc) rather than moving through the menu.

I booted with BOOT_DEBUG=3 to pin down where this is happening.
Looking at /etc/inittab, first, debian-installer-startup is run.  I
run this and the console still behaves normally.  When I run the
second script, debian-installer, the menu launches and my keyboard
doesn't drive the menu any more.

Theres some discussion on why this might be happening and methods I've
tried on debian-boot (Frans Pop has been very helpful!), and it looks
like it may be something to do with reopen-console.  I'm not an expert
on the console though, so there may be something I've missed.  As the
scripts are run via reopen-console then sourced (debian-installer
being a wrapper round a bunch of sourced scripts), I'm unable to
recreate the exact environment.  If I don't use reopen-console and I
run debian-installer from the shell on my own, it works as expected.

I've raised this bug on Frans' recommendation, and the thread on
debian-boot is here:

I'm happy to try out any recommendations you have on this kit while I
still have it (its try-n-buy, its actually a Sun T6230 blade).

Many thanks,


--- End Message ---
--- Begin Message ---
Source: rootskel
Source-Version: 1.71

We believe that the bug you reported is fixed in the latest version of
rootskel, which is due to be installed in the Debian FTP archive:

  to pool/main/r/rootskel/rootskel-bootfloppy_1.71_amd64.udeb
  to pool/main/r/rootskel/rootskel_1.71.dsc
  to pool/main/r/rootskel/rootskel_1.71.tar.gz
  to pool/main/r/rootskel/rootskel_1.71_amd64.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 504721@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Frans Pop <fjp@debian.org> (supplier of updated rootskel package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 05 Dec 2008 14:08:21 +0100
Source: rootskel
Binary: rootskel rootskel-bootfloppy
Architecture: source amd64
Version: 1.71
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Frans Pop <fjp@debian.org>
 rootskel   - Skeleton root filesystem used by debian-installer (udeb)
 rootskel-bootfloppy - Skeleton root filesystem used by debian-installer boot floppy (udeb)
Closes: 504721
 rootskel (1.71) unstable; urgency=low
   * Add a check in reopen-console that the console reported as "handed over"
     is of the correct type. In some cases dmesg reports a virtual console,
     while the actual console the init process is running on is serial.
     A simplified version of busybox' cttyhack is used to perform the check.
     Closes: #504721.
 cbb45bee045f831d8597cd514937362b327fa12e 946 rootskel_1.71.dsc
 a6c51b6a87a8b4a183154fe1a87564326219f743 31671 rootskel_1.71.tar.gz
 7400ce853bc77de4f0d84cdc8016ccd290705729 8750 rootskel_1.71_amd64.udeb
 b6d8a995b29b43857c2d4d3ccdd0879b77ec36de 2778 rootskel-bootfloppy_1.71_amd64.udeb
 49efea3fd6aaa003bb3c49da64e356fea0f465bf7d77cbb4f50481c5de83fd09 946 rootskel_1.71.dsc
 f0b11b93501085308b9b7eaa7ef833e5c0508955c1b75602329baf60bca7ac4c 31671 rootskel_1.71.tar.gz
 4ab5001421ede0923bd8e9914c304579b27e1ebf947cbad0ac7a358ed4e0c49e 8750 rootskel_1.71_amd64.udeb
 ed5b5d256224989b1d6546c3bb5e85595495ae52727653dd629ec87de78e24db 2778 rootskel-bootfloppy_1.71_amd64.udeb
 c974313115fa3781f059fc9dce03e82c 946 debian-installer standard rootskel_1.71.dsc
 79c6945f50e11f75e8f084a9ca8675a4 31671 debian-installer standard rootskel_1.71.tar.gz
 2fcc0262c25b419b4e332ec768f0bd16 8750 debian-installer standard rootskel_1.71_amd64.udeb
 5e7d72d862fcaa9f0c4e16ff3613908e 2778 debian-installer extra rootskel-bootfloppy_1.71_amd64.udeb
Package-Type: udeb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: