[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#388846: installation: Warn of sarge apt-proxy

Package: installation
Severity: wishlist

I tried to install debian behind an apt-proxy and the installations
hangs when fetching packages during installation (Errormsg on ALT-F4).
See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=388769 .

It seems that all Debian etch installations and probably upgrades
behind a sarge apt-proxy fail because of apt-proxy bug 374405:
> Incompatible with full URL HTTP requests from recent apt versions
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=374405

Upgrading the apt-proxy from sarge to backports.org solved the 

IMHO it would be nice to have a hint / warning about sarge apt-proxy
in the sarge to etch upgrade instructions. Otherwise many people may stumble
over this incompatibility.

For installation a hint in d-i mirror selection could be sufficient.
See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=388845 .


-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (21, 'testing'), (20, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.27-3-586tsc
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Reply to: