[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270550: marked as done (Installer not usable as rescue disk)

Your message dated Thu, 13 Oct 2005 16:07:48 -0400
with message-id <20051013200748.GA29155@kitenet.net>
and subject line closing old installation report
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 7 Sep 2004 21:52:04 +0000
>From siward@wanadoo.nl Tue Sep 07 14:52:04 2004
Return-path: <siward@wanadoo.nl>
Received: from master.debian.org [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C4nsd-0005mh-00; Tue, 07 Sep 2004 14:51:59 -0700
Received: from smtp04.wanadoo.nl [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C4nsc-0003dJ-00; Tue, 07 Sep 2004 16:51:58 -0500
Received: from Si (c529da352.cable.wanadoo.nl [])
	by smtp4.wanadoo.nl (Postfix) with ESMTP id 7353D5484A
	for <bugs@debian.org>; Tue,  7 Sep 2004 23:51:55 +0200 (CEST)
Received: from root by Si with local (Exim 3.35 #1 (Debian))
	id 1C4nsb-000082-00
	for <bugs@debian.org>; Tue, 07 Sep 2004 23:51:57 +0200
Content-Type: text/plain;
From: siward <siward.via@freeler.nl>
To: B.Bunny <bugs@debian.org>
Subject: Installer not usable as rescue disk
Date: Tue, 7 Sep 2004 23:51:57 +0200
X-Mailer: KMail [version 1.3.2]
MIME-Version: 1.0
Message-Id: <E1C4nsb-000082-00@Si>
Content-Transfer-Encoding: quoted-printable
Delivered-To: bugs@debian.org
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.1 required=4.0 tests=BAYES_44,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports
Version: sarge-i386-netinst.20040906.iso

Hello installer hackers and list readers,
  i tried an install once more,
  but this time didnt get far due to my particular hardware.

I'd read about horrible things happening in partitioner,
  and thought it prudent to not risk my main harddisk's partition table,
  so i dug in that pile of scrap that i call my hobby room
  to see if i couldnt find an old one.
I found a 585 MB ide, and a 1GB scsi plus scsi controller but without cab=
I had gotten this scsi disk years ago, and never tried it,
  so i thought i'd try if kernel recognized scsi controller,
  and plugged into a free slot.
This caused a bios error when it tried to set up scsi devices ;
  bios reacted to it by turning off boot-from-harddisk,
  though it still allows boot from cd.
I dont have password for this pc, and removing battery didnt help.

Anyway, not an immediate problem,
  because i had already got a daily snapshot iso from www.debian.org,
  namely that of sarge-i386-netinst.20040906.iso,
  except that it's filename doesnt include a date.

[wishlist] add a date (or other version identifier)
  to filenames of daily snapshots,
  so some install reports on debian-boot become clearer.

I had burned this iso to a disc, so next i tried to install with it,
  so i typed 'linux' <enter> ,
  and got :
	Loading /install/vmlinuz...
	Loading /install/initrd.gz...
	_   <- blinking

That's all it did.
  if instead of 'linux <enter>' typing only <enter>,
  same thing happens, except screen is cleared first.

This looked like same blinking underscore that i got when
   bios didnt boot from disk and there was no cd in drive.
Does installer go via bios ? or is this a bug ?

I got woody discs out of drawer, and tried with these :
  it could (and did) install linux on this 585MB disk.

[not a bug really] maybe use same method woody's installer did ?

However, woody's installer can not make this disk bootable (lilo fails)
  (i tried that because i wanted to take disk over to an other old pc).
I assume this is also due to bios,
  as i never hit a boot-floppies bug in woody's installer yet.

Then i noticed a difference between woody installer and sarge installer :

[wishlist+] sarge installer CD is not usable as a rescue disk.

woody CD is, so i can boot there with arguments :
	rescbf24 root=3D/dev/hda10 hdc=3Dide-scsi
but i cant update that kernel if there's a security problem with it,
and i can't use it to run sarge,
  as it uses a different 2.4 kernel (or can i ?),
and i can't run kernel 2.6 .

though i was thinking of buying new hardware anyway,
  i still want to keep this machine runnable,
  so i would appreciate if someone could give me a pointer to how to :
  * change kernel on the fly,
  * clear bios password on an ancient 200MHz PackardBell, or
  * create a bootable CD image with a custom kernel

no need to CC me, i subscribed a couple of days ago.

have fun,


Received: (at 270550-done) by bugs.debian.org; 13 Oct 2005 20:08:08 +0000
>From joey@kitenet.net Thu Oct 13 13:08:08 2005
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1EQ9N2-000320-00; Thu, 13 Oct 2005 13:08:08 -0700
Received: from dragon.kitenet.net (97-148-dial.xtn.net [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 18B5D17FF3
	for <270550-done@bugs.debian.org>; Thu, 13 Oct 2005 20:08:06 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id 47642BFA45; Thu, 13 Oct 2005 16:07:48 -0400 (EDT)
Date: Thu, 13 Oct 2005 16:07:48 -0400
From: Joey Hess <joeyh@debian.org>
To: 270550-done@bugs.debian.org
Subject: closing old installation report
Message-ID: <20051013200748.GA29155@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="6c2NcOVqGQ03X4Wi"
Content-Disposition: inline
User-Agent: Mutt/1.5.10i
Delivered-To: 270550-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Closing this report; the rescue functionality is implelemented and the
rest doesn't look valid with current d-i.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (GNU/Linux)



Reply to: