[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#299001: marked as done (lilo can not handle multiple partitions with identical names)



Your message dated Fri, 11 Mar 2005 14:17:39 -0500
with message-id <E1D9pdj-0006nh-00@newraff.debian.org>
and subject line Bug#299001: fixed in os-prober 1.04
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 11 Mar 2005 01:38:25 +0000
>From chris@chiappa.net Thu Mar 10 17:38:25 2005
Return-path: <chris@chiappa.net>
Received: from lumberjack.snurgle.org [66.92.66.221] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D9Z6f-00046U-00; Thu, 10 Mar 2005 17:38:25 -0800
Received: by lumberjack.snurgle.org (Postfix, from userid 30466)
	id 9C36E3AA97; Thu, 10 Mar 2005 20:38:23 -0500 (EST)
Date: Thu, 10 Mar 2005 20:38:23 -0500
From: Chris Chiappa <chris@chiappa.net>
To: submit@bugs.debian.org
Subject: Installation report
Message-ID: <20050311013823.GA20788@snurgle.org>
Reply-To: chris@chiappa.net
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-Mail-This-For-Blacklisting: trap@snurgle.org
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-Spam-Level: 

Package: installation-reports

INSTALL REPORT

Debian-installer-version: RC2 I think?
-rw-r--r--   1 griffon     users     35723264 2004-11-21 17:09 sarge-i386-businesscard.iso
uname -a:
Linux KeyserSoze 2.6.10-1-686 #1 Tue Jan 18 04:34:19 EST 2005 i686 GNU/Linux
(was 2.6.8 before upgrading)
Date: March 10, 2005 ~23:00 EST
Method: Originally tried a network install, but that wasn't all that happy
so I went with the businesscard install using mirrors.kernel.org for network
downloads.  No proxy.
Machine: IBM Thinkpad T42 2378FVU
Processor: Pentium M 1.7GHz
Memory: 256MB
Root Device: IDE, /dev/hda5
Root Size/partition table: 
Disk /dev/hda: 40.0 GB, 40007761920 bytes
16 heads, 63 sectors/track, 77520 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       29065    14648728+   7  HPFS/NTFS
/dev/hda2           67981       77520     4808160   12  Compaq diagnostics
/dev/hda3           29066       67980    19613160    f  W95 Ext'd (LBA)
/dev/hda5           29066       66849    19043104+  83  Linux
/dev/hda6           66850       67780      469192+  82  Linux swap / Solaris
/dev/hda7           67781       67980      100768+  83  Linux

Partition table entries are not in disk order

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda5             19032832    814540  18218292   5% /
tmpfs                   128016         0    128016   0% /dev/shm
/dev/hda7                97570     13973     78559  16% /boot
/dev/hda1             14648724   5751996   8896728  40% /c

/dev/hda1 originally was 35GB, the installer's NTFS resize utility was very
nice, although it was a little confusing when it told me it needed to write
changes even though I hadn't done any fiddling with the partition table yet.

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
0000:02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
0000:02:02.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)

0000:00:00.0 0600: 8086:3340 (rev 03)
0000:00:01.0 0604: 8086:3341 (rev 03)
0000:00:1d.0 0c03: 8086:24c2 (rev 01)
0000:00:1d.1 0c03: 8086:24c4 (rev 01)
0000:00:1d.2 0c03: 8086:24c7 (rev 01)
0000:00:1d.7 0c03: 8086:24cd (rev 01)
0000:00:1e.0 0604: 8086:2448 (rev 81)
0000:00:1f.0 0601: 8086:24cc (rev 01)
0000:00:1f.1 0101: 8086:24ca (rev 01)
0000:00:1f.3 0c05: 8086:24c3 (rev 01)
0000:00:1f.5 0401: 8086:24c5 (rev 01)
0000:00:1f.6 0703: 8086:24c6 (rev 01)
0000:01:00.0 0300: 1002:4e50
0000:02:00.0 0607: 104c:ac46 (rev 01)
0000:02:00.1 0607: 104c:ac46 (rev 01)
0000:02:01.0 0200: 8086:101e (rev 03)
0000:02:02.0 0280: 8086:4220 (rev 05)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

Comments/Problems:
First time through I tried installing GRUB even though I was using XFS.  It
hung, but I can't say the installer didn't warn me.  Next time through I
tried LILO and it misidentified my /dev/hda2 (which is the "hidden" recovery
partition table) as "Windows" and generated two "Windows" entries in
lilo.conf which broke it - I fixed this by flipping over to the shell.

Not really related to the install I don't think, but post-reboot I get a ton
of useless modules I can't remove:
via82cxxx              13788  0 [permanent]
rz1000                  2432  0 [permanent]
...etc
(I remember having a Pentium 60 with an RZ1000!)

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

-- 

..ooOO chris@chiappa.net              | My opinions are my own  OOoo..
..ooOO chris.chiappa@oracle.com       | and certainly not those OOoo..
..ooOO http://www.chiappa.net/~chris/ | of my employer          OOoo..

---------------------------------------
Received: (at 299001-close) by bugs.debian.org; 11 Mar 2005 19:23:03 +0000
>From katie@ftp-master.debian.org Fri Mar 11 11:23:02 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [208.185.25.31] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D9piw-00005K-00; Fri, 11 Mar 2005 11:23:02 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1D9pdj-0006nh-00; Fri, 11 Mar 2005 14:17:39 -0500
From: Joey Hess <joeyh@debian.org>
To: 299001-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#299001: fixed in os-prober 1.04
Message-Id: <E1D9pdj-0006nh-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Fri, 11 Mar 2005 14:17:39 -0500
Delivered-To: 299001-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-Spam-Level: 

Source: os-prober
Source-Version: 1.04

We believe that the bug you reported is fixed in the latest version of
os-prober, which is due to be installed in the Debian FTP archive:

os-prober_1.04.dsc
  to pool/main/o/os-prober/os-prober_1.04.dsc
os-prober_1.04.tar.gz
  to pool/main/o/os-prober/os-prober_1.04.tar.gz
os-prober_1.04_i386.udeb
  to pool/main/o/os-prober/os-prober_1.04_i386.udeb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 299001@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Joey Hess <joeyh@debian.org> (supplier of updated os-prober package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 11 Mar 2005 14:06:00 -0500
Source: os-prober
Binary: os-prober
Architecture: source i386
Version: 1.04
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
Description: 
 os-prober  - utility to detect other OSes on a set of drives (udeb)
Closes: 299001
Changes: 
 os-prober (1.04) unstable; urgency=low
 .
   * Joey Hess
     - Fix micosoft and lsb tests to use count_next_label to get unique
       short labels. Closes: #299001
Files: 
 615ff2757fef1f6eb8e7583c5d0ee0eb 594 debian-installer optional os-prober_1.04.dsc
 9eeda95ba7b6e821f334fbbc899a40de 11775 debian-installer optional os-prober_1.04.tar.gz
 4a231ee548a78abf0f74b5fbe93f2e86 6536 debian-installer optional os-prober_1.04_i386.udeb
package-type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCMeyI2tp5zXiKP0wRAo4kAJ9xgb/t0PsoBLA7m/96hTi832Iz8gCgwkuJ
HTEl48ZhMY2bdc5gYzrF55E=
=P6Xj
-----END PGP SIGNATURE-----



Reply to: