[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#266601: marked as done ([MERGED] Does not list partitions (seam like unaligned))

Your message dated Thu, 3 Mar 2005 19:14:46 -0800
with message-id <20050304031445.GD5425@mauritius.dodds.net>
and subject line Sometimes changes the disk geometry and leaves Windows unbootable
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 18 Aug 2004 11:55:03 +0000
>From jblache@debian.org Wed Aug 18 04:55:03 2004
Return-path: <jblache@debian.org>
Received: from frigate.technologeek.org [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BxP1z-0004yy-00; Wed, 18 Aug 2004 04:55:03 -0700
Received: by frigate.technologeek.org (Postfix, from userid 1000)
	id 2C2D21470970; Wed, 18 Aug 2004 13:54:53 +0200 (CEST)
To: submit@bugs.debian.org
Subject: installation report: d-i RC1 on HP Pavillion ze4200
From: Julien BLACHE <jblache@debian.org>
Date: Wed, 18 Aug 2004 13:54:53 +0200
Message-ID: <877jrwy836.fsf@frigate.technologeek.org>
User-Agent: Gnus/5.1006 (Gnus v5.10.6) XEmacs/21.4 (Security Through
 Obscurity, linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: RC1 business card
uname -a: 2.6.7-1-686
Date: 20040817
 Boot on the business card CD, install using a local mirror.

Machine: HP Pavillion ze4200
Processor: Intel Celeron
Memory: 256 MB (- 64 MB VRAM)
Root Device: IDE
Root Size/partition table: 
  hda1  9.2 GB     Windows XP
  hda5  500 MB     Swap
  hda6  10 GB      /

Output of lspci:
0000:00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
0000:00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
0000:00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
0000:00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
0000:00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
0000:00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
0000:00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
0000:00:12.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M

Base System Installation Checklist:

Initial boot worked:    [E/O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E/O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Booting on the default 2.4 kernel led to a non-working keyboard; this
also happened with RedHat and other installers about a year
ago. Booting with the linux26 kernel worked like a charm.

Partitionning went a bit funny. The disk layout was :
   hda1     9.2 GB      Windows XP
   >>> FREE SPACE   0.04 MB <<<
   hda2     10 GB       /

[that thing was generated by a previous Mandrake installation]

It seems this layout managed to confuse partman; it wouldn't list the
existing partitions (only the entire disk was available in the menu).

After deleting hda2 using cfdisk on another terminal, everything
worked fine.


 Julien BLACHE <jblache@debian.org>  |  Debian, because code matters more 
 Debian & GNU/Linux Developer        |       <http://www.debian.org>
 Public key available on <http://www.jblache.org> - KeyID: F5D6 5169 
 GPG Fingerprint : 935A 79F1 C8B3 3521 FD62 7CC7 CD61 4FD7 F5D6 5169 

Received: (at 258880-done) by bugs.debian.org; 4 Mar 2005 03:14:49 +0000
>From vorlon@debian.org Thu Mar 03 19:14:49 2005
Return-path: <vorlon@debian.org>
Received: from dsl093-039-086.pdx1.dsl.speakeasy.net (localhost.localdomain) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1D73H7-0001zn-00; Thu, 03 Mar 2005 19:14:49 -0800
Received: by localhost.localdomain (Postfix, from userid 1000)
	id B9E08171D63; Thu,  3 Mar 2005 19:14:46 -0800 (PST)
Date: Thu, 3 Mar 2005 19:14:46 -0800
From: Steve Langasek <vorlon@debian.org>
To: 258880-done@bugs.debian.org
Subject: Re: Sometimes changes the disk geometry and leaves Windows unbootable
Message-ID: <20050304031445.GD5425@mauritius.dodds.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="jL2BoiuKMElzg3CS"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: 258880-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

The version of partman that should fix this problem has been accepted into
testing, and will be included in the upcoming d-i release candidate.

Steve Langasek
postmodern programmer

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Reply to: