[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#229313: marked as done (Should use backup capability)

Your message dated Thu, 05 Feb 2004 16:02:16 -0500
with message-id <E1Aoqdc-0003am-00@newraff.debian.org>
and subject line Bug#229313: fixed in lilo-installer 0.30
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 24 Jan 2004 00:27:02 +0000
>From tbm@cyrius.com Fri Jan 23 16:27:02 2004
Return-path: <tbm@cyrius.com>
Received: from bangpath.uucico.de [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AkBdd-0006Q6-00; Fri, 23 Jan 2004 16:27:01 -0800
Received: by bangpath.uucico.de (Postfix, from userid 10)
	id 6543226B24; Sat, 24 Jan 2004 01:27:00 +0100 (CET)
Received: by unjust.cyrius.com (Postfix, from userid 1000)
	id ED7CE6C20; Sat, 24 Jan 2004 00:27:05 +0000 (GMT)
Date: Sat, 24 Jan 2004 00:27:05 +0000
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: no lilo go back, too much crap installed, 75% wait, /tmp-Xhack
Message-ID: <20040124002705.GA6122@unjust.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_01_20 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Package: installation-reports


Debian-installer-version: daily from 2004-01-09
uname -a: 2.4.23-1-386
Method: booted off daily CD image

Machine: Standard PC
Processor: Pentium II
Memory: 384 MB
Root Device: First with SCSI, then with IDE (both worked)
Output of lspci:

50:tbm@unjust: ~] lspci
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0a.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2064W [Millennium] (rev 01)
00:0b.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 22)
00:0c.0 RAID bus controller: CMD Technology Inc PCI0680 (rev 02)
00:0e.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]

51:tbm@unjust: ~] lspci -n
00:00.0 Class 0600: 8086:7190 (rev 03)
00:01.0 Class 0604: 8086:7191 (rev 03)
00:07.0 Class 0601: 8086:7110 (rev 02)
00:07.1 Class 0101: 8086:7111 (rev 01)
00:07.2 Class 0c03: 8086:7112 (rev 01)
00:07.3 Class 0680: 8086:7113 (rev 02)
00:0a.0 Class 0300: 102b:0519 (rev 01)
00:0b.0 Class 0200: 1011:0009 (rev 22)
00:0c.0 Class 0104: 1095:0680 (rev 02)
00:0e.0 Class 0200: 10b7:9050

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O] didn't leave an option
Reboot:                 [O] too much crap was installed
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


1. Progress bar "Installing base packages..." wait at 75%
2. LILO offers no "go back"
3. Too many packages installed
4. A filed /tmp-Xhack existed, which certainly shouldn't exist.
5. loop in base-config (setting up APT)

The installation went without any problems.  Just minor things which
have been reported already, and the two following issues:

1. At "Installing base packages..." the progress bar stayed at 75% for
quite a while.  I think this has been reported before, but I don't
think it's fixed yet.  This PC isn't particularly slow, but it waited
there for quite a while.  It would be nice to have a better update of
the progress bar.  I stored the output of "ps aux" in a file in case
you don't know what's going on at 75%.

2. One thing I'm not sure has been reported before is the LILO
installer only gave you the choice to "continue".  There was no "go
back", which is a pity because I really wanted to install GRUB

After the install:

3. Too many packages are installed.  There is crap like eject which
I'll certainly never need.  I understand you need this during d-i to
eject the CD, but please remove it right at the beginning of
base-config.  This package doesn't have to be on every installation.

Also, kernel-pcmcia-* & pcmcia-cs was installed even though this is a
PC without PCMCIA.  Please only install this if PCMCIA is available.

libopencdk8 & libgnutls7 was installed, even though nothing depends on
it?  Also, ash was installed (along with dash), even though ash is
just a transition package for dash.

ipchains was installed? *boggle*

fdutils was installed (the PC doesn't have a floppy drive...).

read-edid & mdetect: this should be removed after X configuration (or
are they needed to run X?  I think they're only for configuration,

[I'm aware these are issues in base-config, debootstrap and probably
others.  Please clone/reassign as appropriate.]

4. A file /tmp-Xhack exists after install, which certainly shouldn't exist.

5. There was a loop in base-config when setting up APT.  I chose
"ftp", chose "enter information" (or what it's called), entered the
name and directory of a FTP Debian server, and when I pressed okay I
was back in the menu where I can choose between cdrom/http/ftp/etc.
It wouldn't let me continue... so I pressed "cancel".

Also, the apt sources line said "main  contrib" (two space, should be
one).  And why is contrib in there anyway?

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux unjust.cyrius.com 2.4.23-1-386 #1 Sun Nov 30 16:49:14 EST 2003 i686
Locale: LANG=en_US, LC_CTYPE=en_US
Martin Michlmayr

Received: (at 229313-close) by bugs.debian.org; 5 Feb 2004 21:04:34 +0000
>From katie@ftp-master.debian.org Thu Feb 05 13:04:34 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Aoqfq-0001eI-00; Thu, 05 Feb 2004 13:04:34 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1Aoqdc-0003am-00; Thu, 05 Feb 2004 16:02:16 -0500
From: Joey Hess <joeyh@debian.org>
To: 229313-close@bugs.debian.org
X-Katie: $Revision: 1.43 $
Subject: Bug#229313: fixed in lilo-installer 0.30
Message-Id: <E1Aoqdc-0003am-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Thu, 05 Feb 2004 16:02:16 -0500
Delivered-To: 229313-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=HAS_BUG_NUMBER autolearn=no 

Source: lilo-installer
Source-Version: 0.30

We believe that the bug you reported is fixed in the latest version of
lilo-installer, which is due to be installed in the Debian FTP archive:

  to pool/main/l/lilo-installer/lilo-installer_0.30.dsc
  to pool/main/l/lilo-installer/lilo-installer_0.30.tar.gz
  to pool/main/l/lilo-installer/lilo-installer_0.30_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 229313@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated lilo-installer package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu,  5 Feb 2004 14:42:06 -0500
Source: lilo-installer
Binary: lilo-installer
Architecture: source i386
Version: 0.30
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 lilo-installer - Install LILO on a hard disk (udeb)
Closes: 183362 229313
 lilo-installer (0.30) unstable; urgency=low
   * Joey Hess
     - Add (quick and dirty) support for backing up to the main menu.
       Closes: #183362, #229313
     - Reword the bootdev question to emphasize that it overwrites the MBR by
   * Translations
     - Bartosz Fenski
       - Updated Polish (pl) translation.
     - Giuseppe Sacco
       - applied patch for normalizing menus and some italian translation (it.po)
     - h3lios
       - Added Albanian translation (sq.po)
     - Christian Perrier
       - Update French translation (fr.po)
     - Carlos Z.F. Liu
       - update Simplifed Chinese translation (zh_CN.po)
     - Miroslav Kure
       - Update Czech translation
     - Jordi Mallach
       - Update Catalan translation (ca.po).
     - Claus Hindsgaul
       - Update da (Danish) translation.
     - Konstantinos Margaritis
       - Update Greek translation
     - Kenshi Muto
       - Updated Japanese translation (ja.po)
     - Miguel Figueiredo
       - Updated Portuguese translation (pt.po)
     - Bart Cornelis
       - Updated Dutch (nl.po) translation
     - Alwin Meschede
       - Updated German (de.po) translation
     - André Luís Lopes
       - Updated Brazilian Portuguese (pt_BR) translation.
 36a1081e8d2430234c8bbd604c7338a7 707 debian-installer standard lilo-installer_0.30.dsc
 4ff8700c6e8c07eae1fb53abe47ded20 29652 debian-installer standard lilo-installer_0.30.tar.gz
 205825fe87e3744811dd66d9b245be9e 17742 debian-installer standard lilo-installer_0.30_i386.udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: