[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#226213: marked as done (businesscard installation report + full desktop install)

Your message dated Wed, 4 Feb 2004 18:19:57 +0100
with message-id <20040204171957.GH10244@mykerinos>
and subject line Installation report categorized
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 5 Jan 2004 04:53:08 +0000
>From joey@kitenet.net Sun Jan 04 22:53:07 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AdHMh-0004jy-00; Sun, 04 Jan 2004 17:08:59 -0600
Received: from dragon.kitenet.net (pm3naxs13-126.access.naxs.com [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 3EC7117E75
	for <submit@bugs.debian.org>; Sun,  4 Jan 2004 23:08:53 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id CD1406EC87; Sun,  4 Jan 2004 16:58:58 -0500 (EST)
Date: Sun, 4 Jan 2004 16:58:58 -0500
From: Joey Hess <joey@kitenet.net>
To: submit@bugs.debian.org
Subject: businesscard installation report + full desktop install
Message-ID: <20040104215858.GA11517@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="uAKRQypu60I7Lcqm"
Content-Disposition: inline
User-Agent: Mutt/1.5.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-4.0 required=4.0 tests=DATING,HAS_PACKAGE 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: installation-reports

Debian-installer-version: jan 03 businesscard iso, plus jan 02 hd-media ima=

	Arrived at tri cities regional airport with a blank usb memory stick,
	two laptops (one running debian, one blank). Went to observation
	lounge, and got online. Downloaded above images using installed
	laptop. Wrote to memory stick. Used this to boot my test laptop,
	inserted my orinoco card, and downloaded rest of debian over the
	wireless network.

Machine: lc2000 laptop
Processor: p4
Memory: 512 mb
Root Device: 32 mb ide
Root Size/partition table: installed to /dev/hda3, 1 gb partition

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it


I ran into the problem previously reported with pcmcia not working until
it config.opts is modified to not exclude irqs. This was annoying, and I
had to get to the main menu and restart netcfg after restarting pcmcia.
A normal user would not be able to get past this.

There was no iwconfig, but /proc/net/wireless showed link strength. Then
netcfg gave me a list of interfaces (I had to guess that eth1 was
wireless), and dhcp worked.

I saw some previously reported minor problems:
	- languagechooser arabic entry bad encoding
	- "Validating %s"

It took a long time to download stuff over the wireless, especially the 11
mb kernel. Progress displays could be improved for long downloads.

After reboot (and re-configuring pcmcia by hand again, and running dhclient
by hand), I reproduced the problem with apt-setup looping back to its menu.
Other than that, base-config went mostly ok.

However, if you run out of battery power in the middle of base-config, and
the laptop doesn't support apm (only acpi), and apm is not installed
anyway, rebooting into base-config could be a little better. The most
annoying thing was that it deleted everything apt had downloaded before,
and commented out the sources.list entries, so I had to set all that up
over again, and download 50 mb of packages again.

On the other hand this accidental reboot did let me verify that once
pcmcia's irq excludes were fixed, it comes up and gets online automatically
during boot.

I selected X and Desktop and Laptop tasks, and let it download them for
45 minutes. In the middle I realised that it would run out of disk space
before all this was unpacked, so I moved the apt cache to a different

Now comes debconf questions. I was in medium priority due to some of the
above-mentioned problems, so I did not get to see the default, high
priority install. What I did see were a number of useless debconf notes
about useful things like "my config file in in /etc" and "some settings
have changed from previous versions (that you never installed, but I'm too
dumb to realize)". Some of these already have bug reports, some rather old.

Now X config. I picked the medium priority install. It asked a slew of
questions, some with bad defaults (do not autodetect mouse type, monitor
type, default to no video modes available, etc). It gave me a cryptic list
of video drivers, and I could not find one to match the radeon card in this
laptop. I picked vesa. Despite all this nastiness, X just came up
afterwards. I will file a separate bug report on X with more details.

As has been noted, gnome and the gnome task is completly broken in testing.
Just like it has been for over 6 months. I remeber mailing the maintainer
of the gnome metapackage last spring about these problems with no response
and no forward progress. This grows annoying; perhaps we should simply
default to kde.

So I picked kde from gdm and it worked ok. One annoying thing was that its
setup wizard asked me _again_ what country I was in, bringing the grand
total of times the installer asked me stuff about that to 6:
	- language/country chooser
	- keyboard chooser
	- mirror choice (in d-i)
	- time zone selection
	- mirror choice (in base-config)
	- kde wizard

Another annoying thing is that kde wants to open the sound device on
startup, and displays an error that my user cannot access it. The user
account created by the install should be set up to have access to the sound

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (GNU/Linux)



Received: (at 226213-done) by bugs.debian.org; 4 Feb 2004 18:52:14 +0000
>From bubulle@kheops.frmug.org Wed Feb 04 10:52:14 2004
Return-path: <bubulle@kheops.frmug.org>
Received: from lns-th2-5f-81-56-227-253.adsl.proxad.net (kheops.homeunix.org) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AoS8E-0004Zq-00; Wed, 04 Feb 2004 10:52:14 -0800
Received: from localhost (localhost [])
	by kheops.homeunix.org (Postfix) with ESMTP
	id 8381A4059; Wed,  4 Feb 2004 19:51:43 +0100 (CET)
Received: from kheops.homeunix.org ([])
	by localhost (kheops []) (amavisd-new, port 10024)
	with ESMTP id 01209-07; Wed, 4 Feb 2004 19:51:37 +0100 (CET)
Received: from mykerinos.kheops.frmug.org (mykerinos.kheops.frmug.org [])
	by kheops.homeunix.org (Postfix) with ESMTP
	id 62560405F; Wed,  4 Feb 2004 19:51:24 +0100 (CET)
Received: by mykerinos.kheops.frmug.org (Postfix, from userid 7426)
	id 97EC6D06C; Wed,  4 Feb 2004 18:19:57 +0100 (CET)
Date: Wed, 4 Feb 2004 18:19:57 +0100
From: Christian Perrier <bubulle@debian.org>
To: 226213-done@bugs.debian.org
Cc: joeyh@debian.org
Subject: Installation report categorized
Message-ID: <20040204171957.GH10244@mykerinos>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-message-flag: Outlook is a good virus spreading tool. It can send mail, too.
X-pot_a_miel: honeypot@kheops.frmug.org
User-Agent: Mutt/
X-Virus-Scanned: by amavisd-new-20030616-p5 (Debian) at kheops.frmug.org
Delivered-To: 226213-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=0.0 required=4.0 tests=none autolearn=no 

clone 226213 -1
reassign -1 base-config
retitle -1 Should not clean APT cache before running
severity -1 minor

Joey, you mention in this installation report that the problem with
PCMCIA not working until config.opts is modified to not exlude irqs
has already been reported.

This is the only "bug" I find in this report, except maybe the
"base-config should not clean APT cache" bug.

Hence, I close this installation report bug and thank you, dear
debian-installer tester. Feel free to test Debian Installer again...:-)


Reply to: