[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#176399: marked as done (INSTALL REPORT)

Your message dated Tue, 3 Feb 2004 22:43:00 +0100
with message-id <20040203214300.GH19114@mykerinos>
and subject line Installation report analysis
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 12 Jan 2003 11:22:25 +0000
>From fabbione@fabbione.net Sun Jan 12 05:22:23 2003
Return-path: <fabbione@fabbione.net>
Received: from port5.ds1-sby.adsl.cybercity.dk (trider-g7.fabbione.net) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 18XgC5-0005hM-00; Sun, 12 Jan 2003 05:22:22 -0600
Received: from diapolon.fabbione.net (unknown [3ffe:100:e:3::34])
	by trider-g7.fabbione.net (Postfix) with ESMTP
	id 59D0F1F; Sun, 12 Jan 2003 12:22:18 +0100 (CET)
Received: by diapolon.fabbione.net (Postfix, from userid 1000)
	id AC22316E43; Sun, 12 Jan 2003 12:22:05 +0100 (CET)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Fabio Massimo Di Nitto <fabbione@fabbione.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
X-Mailer: reportbug 2.10
Date: Sun, 12 Jan 2003 12:22:05 +0100
Message-Id: <20030112112205.AC22316E43@diapolon.fabbione.net>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=1.2 required=5.0
X-Spam-Level: *

Package: installation-reports
Version: CVS 12 Jan 2003
Severity: normal

Debian-installer-version: locally built netdisk CVS 12 Jan 2003
uname -a: Linux gundam 2.4.20-686 #1 Sat Dec 21 15:58:35 EST 2002 i686 unknown unknown GNU/Linux
Date: 12 Jan 2003
Method: Network installation, booted from floppy, local debian mirror with no proxy

Machine: Compaq Armada M700
Processor: P3 750Mhz
Memory: 386M
Root Device: IDE /dev/hda
Root Size/partition table

/dev/hda3 on / type auto (rw,errors=remount-ro)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/hda2 on /boot type ext3 (rw,errors=remount-ro)
/dev/hda5 on /var type ext3 (rw,errors=remount-ro)
/dev/hda6 on /crypto type ext3 (rw,errors=remount-ro)
/dev/hda8 on /usr type ext3 (rw,errors=remount-ro)
usbdevfs on /proc/bus/usb type usbdevfs (rw)

Output of lspci:

gundam:~# lspci 
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:04.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: ESS Technology ES1978 Maestro 2E (rev 10)
00:09.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 09)
00:09.1 Serial controller: Lucent Microelectronics LT WinModem
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O] *
Config network:         [O] * 
Detect CD:              [ ]
Load installer modules: [O] *
Detect hard drives:     [O]
Partition hard drives:  [O] *
Create file systems:    [O] *
Mount partitions:       [O] *
Install base system:    [O] *
Install boot loader:    [O] *
Reboot:                 [O] *
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

* please read the notes below.


Most of the problems I found were already reported by other people
such as the ext3, hostname, proc, etc. so that explains some data
that are reported above since i fixed them by myself at a later stage.

- Configure network HW

It would be extremely nice if it was possible to have pcmcia support as well.
Some old laptops do not have integrated nic. But of course this is a wishlist
and not a real huge problem at the moment.

- Config network

Another good thing (IMO) would be to have IPv6 to install from the beginning.
I made an investigation in order to implement it and if the project will
stick on one floppy to start with than it useless to continue to read since there
will never be enough space :-). but if for instance it will be on 2 floppies
the IPv6 module takes approx. 65/70k, the changes to net-cfg are relativly simple
but the main issue could be busybox. commands like ifconfig and route should be
able to understand ipv6. They do in a very limited way that is actually not enough.
I need to investigate deeper in this direction anyway.

- Load installer modules

I selected some of them but I had a few doubt about the EVMS module.
it loads but how people are supposed to use it?

I have tried as well to install the 2.4.20 udebs, but at the first reboot the system
does not have 2.4.20 at all. I had to install it by hand after.

- Language chooser

It looks to me that it could be difficult for new users to understand things like:


even if enter+enter+enter fits 99% of the system. A minimum description would
be just great.

- Partition hard drives

Basically it works but it would extremely simple if we culd use cfdisk instead of fdisk
that is kinda hard to use for new users.

- Create file systems

What about the swap? I tagged a partition as Linux Swap (82) but i didn't
got any chance to tell d-i to mkswap and put the relative entry in fstab

- Mount partitions

It would be a good idea to suggest /boot as well.
More than a problem a question: is there any specific reason why we have to use
the "." to end the manual mount option? is it related to the fact that 2.4 can
mount multiple times the same device to more mount points (that will make sence)?
See also above for the swap.. not really a mount but hey... a swapon execution
will be usefull

- Install base system

the netretriver cannot be stopped. this is somehow annoying if we select a wrong
mirror to fetch data from. I have also tried disconnecting the network cable for
more than a minute but it didn't timeout (to simulate net problems) is that normal?

- Install boot loader

Well you already know that grub does not work.
Lilo does not hounor other OS installed
on the system and it comes (of course due to space problems) with a really minimal
config. Should this problem be addressed in d-i or in base-config?
I believe that atleast other OS'es recongnition should be done by d-i to avoid new
users panicing at the first reboot, even if it could be done at a later stage
during the base-config step.... just my concern

- Reboot

The same warning that others have reported.

- After reboot (small issues)

The network module selected during the installation is not loaded, that will make the
installation process stop when it is time to fetch data.

It would be nice to have the default sources.ist pointing to sarge. I saw other discussion
about this issue already in other threads but at leasting during a testing phase
it would speed up, even if it is no more a d-i problem.

Looking at / i got a bit disappointed. I do NOT want to start a flamewar but looking
all the symlinks to kernel and initrd is kinda hugly, since there is no real technical
needs for them. Anyway this is just my opinion (I had to write it :-) )

Nice work guys!
Looking forward to test new versions soon


-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux diapolon 2.4.20aa1 #1 Sat Dec 14 10:35:38 CET 2002 i686

Received: (at 176399-done) by bugs.debian.org; 3 Feb 2004 21:43:34 +0000
>From bubulle@kheops.frmug.org Tue Feb 03 13:43:34 2004
Return-path: <bubulle@kheops.frmug.org>
Received: from lns-th2-5f-81-56-227-253.adsl.proxad.net (kheops.homeunix.org) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Ao8KT-0002bf-00; Tue, 03 Feb 2004 13:43:34 -0800
Received: from localhost (localhost [])
	by kheops.homeunix.org (Postfix) with ESMTP
	id C6A1C4052; Tue,  3 Feb 2004 22:43:02 +0100 (CET)
Received: from kheops.homeunix.org ([])
	by localhost (kheops []) (amavisd-new, port 10024)
	with ESMTP id 28692-06; Tue, 3 Feb 2004 22:43:02 +0100 (CET)
Received: from mykerinos.kheops.frmug.org (mykerinos.kheops.frmug.org [])
	by kheops.homeunix.org (Postfix) with ESMTP
	id F1EDA4050; Tue,  3 Feb 2004 22:43:01 +0100 (CET)
Received: from localhost (mykerinos.kheops.frmug.org [])
	by mykerinos.kheops.frmug.org (Postfix) with ESMTP
	id BA0BED064; Tue,  3 Feb 2004 22:43:01 +0100 (CET)
Received: from mykerinos.kheops.frmug.org ([])
	by localhost (mykerinos []) (amavisd-new, port 10024)
	with ESMTP id 23311-06; Tue, 3 Feb 2004 22:43:00 +0100 (CET)
Received: by mykerinos.kheops.frmug.org (Postfix, from userid 7426)
	id CF772D05D; Tue,  3 Feb 2004 22:43:00 +0100 (CET)
Date: Tue, 3 Feb 2004 22:43:00 +0100
From: Christian Perrier <bubulle@debian.org>
To: 176399-done@bugs.debian.org, 176399-submitter@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Installation report analysis
Message-ID: <20040203214300.GH19114@mykerinos>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
X-message-flag: Outlook is a good virus spreading tool. It can send mail, too.
X-pot_a_miel: honeypot@kheops.frmug.org
User-Agent: Mutt/
X-Virus-Scanned: by amavisd-new-20030616-p5 (Debian) at mykerinos
X-Virus-Scanned: by amavisd-new-20030616-p5 (Debian) at kheops.frmug.org
Delivered-To: 176399-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=0.0 required=4.0 tests=none autolearn=no 

clone 176399 -1
reassign -1 netcfg
retitle -1 Should include IPv6 support from the beginning
severity 176399 wishlist

This installation report is very old and abviously mentions some
wishes which have been fixed and corrected more or less the say the
submitter asked.

The only remaining wish I find is the mention of IPv6 support. I
assign this to netcfg, though I'm not completely sure this belongs to


Reply to: