[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#117257: marked as done (libext2fs.so.2 or libc.so.6 version incompatibility)

Your message dated 05 Feb 2002 21:54:04 +0000
with message-id <1012946044.1568.32.camel@kc>
and subject line 
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 27 Oct 2001 03:59:58 +0000
>From nm127@hszk.bme.hu Fri Oct 26 22:59:58 2001
Return-path: <nm127@hszk.bme.hu>
Received: from mail01.axelero.hu (gil.axelero.hu) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 15xKdZ-0000tO-00; Fri, 26 Oct 2001 22:59:57 -0500
Received: from hszk.bme.hu (line-120-73.dial.matav.net [])
 by mail01.axelero.hu
 (iPlanet Messaging Server 5.0 Patch 3 (built Mar 23 2001)) with ESMTP id
 <0GLU00AA9GEPDY@mail01.axelero.hu> for submit@bugs.debian.org; Sat,
 27 Oct 2001 05:02:56 +0200 (MEST)
Date: Sat, 27 Oct 2001 05:02:37 +0200
From: Nemeth Marton <nm127@hszk.bme.hu>
Subject: libext2fs.so.2 or libc.so.6 version incompatibility
Sender: marci@axelero.hu
To: submit@bugs.debian.org
Message-id: <3BDA23CC.A7F5A1CE@hszk.bme.hu>
MIME-version: 1.0
X-Mailer: Mozilla 4.61 [en] (X11; I; Linux 2.4.9 i586)
Content-type: text/plain; charset=us-ascii
Content-transfer-encoding: 7BIT
X-Accept-Language: hu, en, de
Delivered-To: submit@bugs.debian.org

Package: cdrom
Version: Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1

I boot from the first CD, switch to the 2nd console. I have an msdos
partition on /dev/hda1.

# mount /dev/hda1 /mnt
# mkdir /mnt/tmp
# cd /mnt/tmp
# dd if=/dev/zero of=ext2.img bs=1024k count=100
100+0 records in
100+0 records out
# mkfs.ext2 ext2.img
mke2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
ext2.img is not a block special device.
Proceed anyway? (y,n) y
mkfs.ext2: error in loading shared libraries: /lib/libext2fs.so.2:
symbol __divdi3, version GLIBC_2.0 not defined in file libc.so.6 with
link time reference

This should work, I guess.


Received: (at 67624-done) by bugs.debian.org; 5 Feb 2002 21:53:46 +0000
>From philb@gnu.org Tue Feb 05 15:53:46 2002
Return-path: <philb@gnu.org>
Received: from pc1-camb6-0-cust163.cam.cable.ntl.com (kc.cam.armlinux.org) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 16YDX7-0003Xe-00; Tue, 05 Feb 2002 15:53:45 -0600
Received: from localhost
	([] helo=localhost.localdomain ident=pb)
	by kc.cam.armlinux.org with esmtp (Exim 3.34 #1 (Debian))
	id 16YDXQ-0000d5-00
	for <67624-done@bugs.debian.org>; Tue, 05 Feb 2002 21:54:04 +0000
From: Philip Blundell <philb@gnu.org>
To: 67624-done@bugs.debian.org
Content-Type: text/plain
Content-Transfer-Encoding: 7bit
X-Mailer: Evolution/1.0.1 
Date: 05 Feb 2002 21:54:04 +0000
Message-Id: <1012946044.1568.32.camel@kc>
Mime-Version: 1.0
Delivered-To: 67624-done@bugs.debian.org

I verified that the libc in a recent woody build does include the
missing __divdi3 symbol.  So it seems that either the change to
mklibs.py fixed the bug, or it went away for some other reason.  Either
way, there doesn't seem to be anything more to be done, so I'm closing
the report.


Reply to: