[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accepted nvidia-graphics-drivers 367.44-3~bpo8+1 (amd64 i386 source) into jessie-backports : problem of dependencies



Le Sun, 13 Nov 2016 23:15:51 +0000,
"Rebecca N. Palmer" <rebecca_palmer@zoho.com> a écrit :

> It's probably right to suggest removing mediawiki-extensions-base
> (backports mediawiki Breaks+Replaces that, 
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=831227), but that's 
> not new.
> 
> If nvidia-modprobe:i386 is installed, remove it (as usual for 
> executables, it implicitly Conflicts with the 64-bit version).
> 
> Try again (starting with apt-get update): it can take some hours for
> new package versions to reach your mirror.
> 
> If these don't help, post the output of:
> #versions currently installed
> dpkg -l | grep nvidia
> #versions it's trying to install
> #(doesn't actually install anything, so doesn't need root)
> apt-get -s upgrade
> 

Thank you Rebecca.

I fixed the problem by first installing the latest version of the
nvidia driver (with apt-get, aptitude refused to do it), and THEN the
upgrade phase went smoothly.

I suppose aptitude had some trouble with its algorithms for dealing
with conflicting versions... apt-get doesn't seem to have such
scruples :-)

Thanks for your time. And sorry for the noise.

\bye

-- 

Nicolas FRANCOIS                      |  /\ 
http://nicolas.francois.free.fr       | |__|
				      X--/\\
We are the Micro$oft.		        _\_V
Resistance is futile.		    
You will be assimilated.         darthvader penguin

Attachment: pgpXS3MQg0kn5.pgp
Description: OpenPGP digital signature


Reply to: