[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vlc

[ Adding pkg-multimedia-maintainers in the loop, which maintains vlc,
  ffmpeg and mplayer ]

> * Paolo Marcassoli <paolo.marcassoli@email.it> [2011-01-05 16:29:27 CET]:
>> Are you planning to include vlc player and related packages in  
>> squeeze-backports?

Note that this request already came up several times for lenny-backports:


All of them remained pretty much unanswered to me.

On Wed, Jan 05, 2011 at 18:22:16 (CET), Gerfried Fuchs wrote:
>  Hard to tell at this time of the release - actually the version in
> squeeze and currently in unstable are the same so it doesn't make any
> sense to provide a backport.  There is a newer version in experimental -
> but your chances are best if you ask the package maintainers of vlc and
> related packages themself wether they want to provide the backport.

The version in experimental (and later versions) will be uploaded to
unstable as soon as squeeze is released. That version will definitly
require FFmpeg 0.6, also currently in experimental [*]. So the question
really is if the backports team is comfortable with that backport.

As maintainer, I'd be very happy to see both in squeeze-backports. On
the bottom line, having FFmpeg 0.6 in -backports will require some other
backports as well. The exact packages that require this unknown, but
since we have symbol versioning since lenny, I expect this to be rather
small. AFAIUI, only packages that use private internal types and
symbols, like mplayer (which does this for historical reasons) should
require this. And backporting mplayer would be an excellent idea for
other reasons anyway.

[*] side note: I'm really unhappy that FFmpeg 0.6 missed squeeze. I've
tried to convince the release team at DC10, but they rejected it with
"it will hold up the freeze".

Reinhard Tartler, KeyID 945348A4

Reply to: