[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

php5-cgi backport has broken dependencies


I just tried to install the php5-cgi package from backports.org
into a Sarge system and failed:

# /usr/bin/apt-get install php5-cgi
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-cgi: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge4 is to be installed
            Depends: libdb4.4 but it is not going to be installed
            Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge3 is to be installed
            Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not going to be installed
            Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed
E: Broken packages

Is it "easy" to build these packages again on a sarge system, or are
API and build dependency different enough to make updating to
"almost-Etch" the preferred route (for a production system)?  Btw, I
was unable to find libc6 (>= 2.3.6-6) on backports.org...

Please Cc: me on answers.

Thank you!


Reply to: