[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accepted nagios2 2.4-0bpo1 (source i386 all)



On Friday 23 June 2006 12:40, Norbert Tretkowski wrote:
> * Jan Wagner wrote:
> > nagios2:~# aptitude -t sarge-backports install nagios2
> > Reading Package Lists... Done
> > Building Dependency Tree
> > Reading extended state information
> > Initializing package states... Done
> > Reading task descriptions... Done
> > The following NEW packages will be automatically installed:
> >   cpp cpp-3.3 fping gcc gcc-3.3 libc6-dev libmysqlclient14
> >   libmysqlclient14-dev libnet-snmp-perl libperl5.8 libpq3 libradius1
> >   nagios-images nagios-plugins nagios-plugins-basic
> > nagios-plugins-standard nagios2-common nagios2-doc ntpdate qstat
> > radiusclient1 samba-common smbclient snmp zlib1g-dev
>
> I don't know why the -dev packages getting selected, but try disabling
> installation of recommended packages in aptitude.
>
>                 Norbert

Okay .. I traced the problem down ... the depency path seems :

nagios2 => nagios-plugins => nagios-plugins-standard => libmysqlclient14 =>[1] 
libmysqlclient14-dev => zlib1g-dev => libc6-dev =>[2] cpp cpp-3.3 gcc gcc-3.3

So aptitude installs the recommandation of "libmysqlclient14", which 
is "libmysqlclient14-dev" and the recommandation of "libc6-dev" which is "cpp 
cpp-3.3 gcc gcc-3.3"

But wth are these recommandations are installed, while other not?

[1]
Package: libmysqlclient14
Priority: optional
Section: libs
Installed-Size: 2888
Maintainer: Christian Hammers <ch@debian.org>
Architecture: i386
Source: mysql-dfsg-4.1
Version: 4.1.11a-4sarge4
Replaces: mysql-client, mysql-gpl-client, mysql-devel
Depends: mysql-common-4.1 (>= 4.1.11a-4sarge4) | mysql-common, libc6 (>= 
2.3.2.ds1-21), zlib1g (>= 1:1.2.1)
Recommends: libmysqlclient14-dev
Conflicts: libmysqlclient14-dev (<< 4.1.11a-4sarge4), libmysqlclient6-dev, 
mysql-dev, mysql, mysql-base

[2] 
Package: libc6-dev
Priority: standard
Section: libdevel
Installed-Size: 8556
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: i386
Source: glibc
Version: 2.3.2.ds1-22sarge3
Replaces: man-db (<= 2.3.10-41), gettext (<= 0.10.26-1), ppp (<= 2.2.0f-24), 
libgdbmg1-dev (<= 1.7.3-24), ldso (<= 1.9.11-9), netkit-rpc, netbase (<< 
4.0), kerberos4kth-dev (<< 1.2.2-10)
Provides: libc-dev
Depends: libc6 (= 2.3.2.ds1-22sarge3), linux-kernel-headers
Recommends: gcc | c-compiler
Suggests: glibc-doc, manpages-dev
Conflicts: libstdc++2.10-dev (<< 1:2.95.2-15), gcc-2.95 (<< 1:2.95.3-9), 
libpthread0-dev, libdl1-dev, libdb1-dev, libgdbm1-dev, libc6-dev (<< 
2.0.110-1), locales (<< 2.1.3-5), libstdc++2.9-dev, netkit-rpc, libc-dev

With kind regards, Jan.
-- 
-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GIT d-- s+: a- C+++ UL++++ P+ L+++ E- W+++ N+++ o++ K++ w--- O M V- PS PE
Y++ PGP++ t-- 5 X R tv- b+ DI- D++ G++ e++ h-- r+++ y+++
------END GEEK CODE BLOCK------

Attachment: pgpOcZinzCkRg.pgp
Description: PGP signature


Reply to: