[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted webkit2gtk 2.20.2-1~bpo9+1 (source i386 all) into stretch-backports, stretch-backports



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 21 May 2018 09:53:17 +0300
Source: webkit2gtk
Binary: libjavascriptcoregtk-4.0-18 libjavascriptcoregtk-4.0-dev libjavascriptcoregtk-4.0-bin gir1.2-javascriptcoregtk-4.0 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-dev libwebkit2gtk-4.0-doc gir1.2-webkit2-4.0 libwebkit2gtk-4.0-37-gtk2 webkit2gtk-driver
Architecture: source i386 all
Version: 2.20.2-1~bpo9+1
Distribution: stretch-backports
Urgency: high
Maintainer: Debian WebKit Maintainers <pkg-webkit-maintainers@lists.alioth.debian.org>
Changed-By: Alberto Garcia <berto@igalia.com>
Description:
 gir1.2-javascriptcoregtk-4.0 - JavaScript engine library from WebKitGTK+ - GObject introspection
 gir1.2-webkit2-4.0 - Web content engine library for GTK+ - GObject introspection data
 libjavascriptcoregtk-4.0-18 - JavaScript engine library from WebKitGTK+
 libjavascriptcoregtk-4.0-bin - JavaScript engine library from WebKitGTK+ - command-line interpre
 libjavascriptcoregtk-4.0-dev - JavaScript engine library from WebKitGTK+ - development files
 libwebkit2gtk-4.0-37 - Web content engine library for GTK+
 libwebkit2gtk-4.0-37-gtk2 - Web content engine library for GTK+ - GTK+2 plugin process
 libwebkit2gtk-4.0-dev - Web content engine library for GTK+ - development files
 libwebkit2gtk-4.0-doc - Web content engine library for GTK+ - documentation
 webkit2gtk-driver - WebKitGTK+ WebDriver support
Closes: 888543 889659
Changes:
 webkit2gtk (2.20.2-1~bpo9+1) stretch-backports; urgency=medium
 .
   * Rebuild for stretch-backports.
   * debian/control:
     + Versions of GStreamer < 1.13 had GStreamerGL in the "bad" set, so
       depend on libgstreamer-plugins-bad1.0-dev and don't require
       GStreamer 1.13.
     + Remove build dependency on libwoff-dev, this is not available in
       this Debian release.
   * debian/rules:
     + Build with -DUSE_WOFF2=OFF.
 .
 webkit2gtk (2.20.2-1) unstable; urgency=high
 .
   * New upstream release.
     + This fixes CVE-2018-4200.
   * debian/patches/fix-atomics-build.patch:
     + Set THREADS_PREFER_PTHREAD_FLAG to ON. This fixes the build in
       riscv64 (thanks, Aurelien Jarno).
   * debian/libwebkit2gtk-4.0-doc.install, debian/rules:
     + Update path of installed documentation (see WebKit #184771).
 .
 webkit2gtk (2.20.1-1) unstable; urgency=medium
 .
   [ Alberto Garcia ]
   * New upstream release.
   * debian/rules:
     + Ubuntu doesn't install changelogs with dh_installchangelogs, so
       let's use dh_installdocs instead (but keep dh_installchangelogs for
       Debian).
   * debian/control:
     + Update Standards-Version to 4.1.4 (no changes needed).
 .
   [ Jeremy Bicha ]
   * The WebKitGTK+ security advisory WSA-2018-0003 lists the following
     security fixes in the latest versions of WebKitGTK+:
     + CVE-2018-4101, CVE-2018-4113, CVE-2018-4114, CVE-2018-4117,
       CVE-2018-4118, CVE-2018-4119, CVE-2018-4120, CVE-2018-4122,
       CVE-2018-4125, CVE-2018-4127, CVE-2018-4128, CVE-2018-4129,
       CVE-2018-4133, CVE-2018-4146, CVE-2018-4161, CVE-2018-4162,
       CVE-2018-4163, CVE-2018-4165 (fixed in 2.20.0).
   * Update Vcs fields for migration to https://salsa.debian.org/
   * Enable gstreamer-gl on Ubuntu too (LP: #1752197)
   * Bump debhelper compat to 10
 .
 webkit2gtk (2.20.0-2) unstable; urgency=medium
 .
   * Upload to unstable (Closes: #889659, #888543).
   * debian/gbp.conf:
     + Update upstream branch name.
   * debian/NEWS:
     + Add news item about the Gigacage feature.
 .
 webkit2gtk (2.20.0-1) experimental; urgency=medium
 .
   * New upstream release.
   * debian/patches/fix-ftbfs-armel.patch:
     + Detect missing __atomic_fetch_add_8() and rename patch to
       fix-atomics-build.patch.
   * debian/libwebkit2gtk-4.0-37.symbols:
     + Update symbols.
   * debian/copyright:
     + Remove nonexistent files.
   * debian/source/lintian-overrides:
     + Update source-is-missing overrides.
 .
 webkit2gtk (2.19.92-1) experimental; urgency=medium
 .
   [ Alberto Garcia ]
   * New upstream development release.
   * debian/rules:
     + Don't redefine CFLAGS or LDFLAGS when calling cmake, and don't add
       CPPFLAGS to CFLAGS/CXXFLAGS. Cmake already reads all those
       environment variables.
   * Build the documentation:
     + debian/rules:
       - Support the DEB_BUILD_OPTIONS "nodoc" tag and pass -DENABLE_GTKDOC
         to CMake depending on whether it's set or not.
       - Override the dh_install rule to make sure that a dummy doc
         directory is present if "nodoc" is set.
     + debian/control:
       - Add build dependencies on libglib2.0-doc, libgtk-3-doc and
         libsoup2.4-doc.
       - Update Standards-Version to 4.1.3 (we now support "nodoc").
     + debian/libwebkit2gtk-4.0-doc.install:
       - Install the generated documentation instead of the one provided by
         upstream.
   * debian/copyright:
     + Update copyright years.
 .
   [ Jeremy Bicha ]
   * gstreamergl has moved to gstreamer base in 1.13 so update dependencies
   * Fix Ubuntu useragent (LP: #1751484)
   * Temporarily disable WOFF2 on Ubuntu, see bug 1742743
 .
 webkit2gtk (2.19.91-1) experimental; urgency=medium
 .
   * New upstream development release.
   * Refresh all patches.
   * debian/rules:
     + Use -O1 in powerpc as well.
   * debian/libwebkit2gtk-4.0-37.symbols:
     + Update symbols.
 .
 webkit2gtk (2.19.90-1) experimental; urgency=medium
 .
   * New upstream development release.
   * debian/rules:
     + Use -O1 in sh3 and sh4 (thanks, John Paul Adrian Glaubitz).
   * Refresh all patches.
Checksums-Sha1:
 23f22d59265d0b04ffb67b34939cebbf3f46e26f 4066 webkit2gtk_2.20.2-1~bpo9+1.dsc
 ff6ea69ebc1ac9e29d3c75ddc2504d0ba839027c 56968 webkit2gtk_2.20.2-1~bpo9+1.debian.tar.xz
 da1103d47529343bebfed3b76339f6b1573256db 74038 gir1.2-javascriptcoregtk-4.0_2.20.2-1~bpo9+1_i386.deb
 82d01cf7ebe07a7a47ac5b03ef953f299272cac4 123762 gir1.2-webkit2-4.0_2.20.2-1~bpo9+1_i386.deb
 6547fdfa861f99049d8dabd7f9a6c5888b474d9f 12337996 libjavascriptcoregtk-4.0-18-dbgsym_2.20.2-1~bpo9+1_i386.deb
 c56e7855cd6beaf4fffc479ad36462e9a90a59f0 3844834 libjavascriptcoregtk-4.0-18_2.20.2-1~bpo9+1_i386.deb
 516143691b872a3ef9c5c26575f4468b3aa71a49 194122 libjavascriptcoregtk-4.0-bin-dbgsym_2.20.2-1~bpo9+1_i386.deb
 a6080d2b4845d08125486b1febbe206e15efbfcd 148234 libjavascriptcoregtk-4.0-bin_2.20.2-1~bpo9+1_i386.deb
 37bbbdd29ff2837db349e6a4eecca0af95f3f984 86532 libjavascriptcoregtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 2d047ae409a141c3040cc76d9d35c1039c5238a9 50303828 libwebkit2gtk-4.0-37-dbgsym_2.20.2-1~bpo9+1_i386.deb
 ff8ced90551db30f88d24f5df6e744abba0f18a1 40324938 libwebkit2gtk-4.0-37-gtk2-dbgsym_2.20.2-1~bpo9+1_i386.deb
 5b3f54d7c13ff6467b0c37bbab98f6fa62d3f093 10347998 libwebkit2gtk-4.0-37-gtk2_2.20.2-1~bpo9+1_i386.deb
 1c6eac555e0d2e2b6f9b3e711ba019d5ee66d729 12256154 libwebkit2gtk-4.0-37_2.20.2-1~bpo9+1_i386.deb
 3b6a06387adbc3e7caa34d9dcd479681d901def7 229846 libwebkit2gtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 7d0c930e6b39a83c723ffa371917007b19762a20 226956 libwebkit2gtk-4.0-doc_2.20.2-1~bpo9+1_all.deb
 27974126c6450821d607679f052370869fd3a48f 717988 webkit2gtk-driver-dbgsym_2.20.2-1~bpo9+1_i386.deb
 a98a2ab1f551002b071b0e68df4e73b6650e1d4d 330548 webkit2gtk-driver_2.20.2-1~bpo9+1_i386.deb
 fcb45ac239f351b9fe763900254f249aa8c091d0 21803 webkit2gtk_2.20.2-1~bpo9+1_i386.buildinfo
Checksums-Sha256:
 6f46f20c19c6566503d5be8527e30c63e1d81fb102feaab7bcc5fba7eee26d05 4066 webkit2gtk_2.20.2-1~bpo9+1.dsc
 053fe21986c481fec168d4258c031e0ad44f02c34e0296ca197219e3154a21bb 56968 webkit2gtk_2.20.2-1~bpo9+1.debian.tar.xz
 923df018c6ee279dc629904e8a006dd640371d75c28d06e6354f21070ef17995 74038 gir1.2-javascriptcoregtk-4.0_2.20.2-1~bpo9+1_i386.deb
 f7e4da78a0b0c3be45ae9b7ce25395413ac81585ae6c102eccae6fd683de911d 123762 gir1.2-webkit2-4.0_2.20.2-1~bpo9+1_i386.deb
 4f66d52890c675fbb09566797c4a006f02cca2856f4db957f831c417ae393759 12337996 libjavascriptcoregtk-4.0-18-dbgsym_2.20.2-1~bpo9+1_i386.deb
 715bf6f3f6d620689d96cf19651e9a7b784e2219ac6a2dd401e944fb0f0f2ae9 3844834 libjavascriptcoregtk-4.0-18_2.20.2-1~bpo9+1_i386.deb
 997f6fc57a22277765ca71c7caa99191ceab19eaf9eaae08fb88e2b642b37a04 194122 libjavascriptcoregtk-4.0-bin-dbgsym_2.20.2-1~bpo9+1_i386.deb
 d0d9f879f99434ef5a602bba82094043a827f11fd32f7d586bf7c7cb463c3df7 148234 libjavascriptcoregtk-4.0-bin_2.20.2-1~bpo9+1_i386.deb
 21df72826578d9b548e3ef2e7eb3f9030cdb5b00c1294de6ec00c4bd8ab14f6d 86532 libjavascriptcoregtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 d5af9cd97f63db7a8a96386fc201aa04376e9676f279fcdcfa30019c3ae7dd81 50303828 libwebkit2gtk-4.0-37-dbgsym_2.20.2-1~bpo9+1_i386.deb
 d9a0585e189266b89ce374075a9952579fa9602ad8a84920dd76a93c01bab9bb 40324938 libwebkit2gtk-4.0-37-gtk2-dbgsym_2.20.2-1~bpo9+1_i386.deb
 d44728563ab7196e6098bdea45f52298cbb91f46cb861650bc0a0975a361d0e0 10347998 libwebkit2gtk-4.0-37-gtk2_2.20.2-1~bpo9+1_i386.deb
 be499bd5dba3c4ccf8cae70c89778808323c05d8a99d1f4ea153812a68c555bb 12256154 libwebkit2gtk-4.0-37_2.20.2-1~bpo9+1_i386.deb
 6e21647a776cbcbfdd9b4e4f8137e8730e6b2f95c9dd5e2d693b02abcb610a06 229846 libwebkit2gtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 4d9d2697c5c3d257f0be73db417b00e66ca0b7fc23a807aef320225f80234378 226956 libwebkit2gtk-4.0-doc_2.20.2-1~bpo9+1_all.deb
 ee202ce29840bd99cda888afcabb57b80dfb38348a830acba34b23646ab5a360 717988 webkit2gtk-driver-dbgsym_2.20.2-1~bpo9+1_i386.deb
 8b85dc09099ba21f9fe6ddff236c7b7c40d17abcd5c45c4a92a010ab0a260115 330548 webkit2gtk-driver_2.20.2-1~bpo9+1_i386.deb
 920fe52132d26ad7a0374828e6ea41aeaf8245feab36ffb95f074935aae4db42 21803 webkit2gtk_2.20.2-1~bpo9+1_i386.buildinfo
Files:
 d3de8d23a86580c5d30c107dd14bfa65 4066 web optional webkit2gtk_2.20.2-1~bpo9+1.dsc
 b65d737d229c61f3ec393dc47c7e5f0d 56968 web optional webkit2gtk_2.20.2-1~bpo9+1.debian.tar.xz
 b17e8b4e86194d3ca83c1eaa9e521c45 74038 introspection optional gir1.2-javascriptcoregtk-4.0_2.20.2-1~bpo9+1_i386.deb
 023439275749820c9a5f73c37ef65082 123762 introspection optional gir1.2-webkit2-4.0_2.20.2-1~bpo9+1_i386.deb
 4f9bc4ef8957417bb9b567e2726a32a4 12337996 debug extra libjavascriptcoregtk-4.0-18-dbgsym_2.20.2-1~bpo9+1_i386.deb
 ebea945d1536a90e2613b2726866590a 3844834 libs optional libjavascriptcoregtk-4.0-18_2.20.2-1~bpo9+1_i386.deb
 9a1f1d555214ddd5af2c251836f70ebc 194122 debug extra libjavascriptcoregtk-4.0-bin-dbgsym_2.20.2-1~bpo9+1_i386.deb
 82a55aaf4939ecdfb5e8c054ed0f0aa8 148234 interpreters optional libjavascriptcoregtk-4.0-bin_2.20.2-1~bpo9+1_i386.deb
 5cc04641b1ce0b21b524f6679a295eed 86532 libdevel optional libjavascriptcoregtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 8bc3d93aa1602b0bf170ce34edf12b98 50303828 debug extra libwebkit2gtk-4.0-37-dbgsym_2.20.2-1~bpo9+1_i386.deb
 bb35f9cc73491ee8052c22f7032ade48 40324938 debug extra libwebkit2gtk-4.0-37-gtk2-dbgsym_2.20.2-1~bpo9+1_i386.deb
 92368e46279a9620e9dad63df9758b63 10347998 libs optional libwebkit2gtk-4.0-37-gtk2_2.20.2-1~bpo9+1_i386.deb
 b26cd2efa344db2f217ca20078b5c8c4 12256154 libs optional libwebkit2gtk-4.0-37_2.20.2-1~bpo9+1_i386.deb
 90ad73365dda839f5ce228c046997e44 229846 libdevel optional libwebkit2gtk-4.0-dev_2.20.2-1~bpo9+1_i386.deb
 77994da9efc28ddfdb9301cbe32c62f8 226956 doc optional libwebkit2gtk-4.0-doc_2.20.2-1~bpo9+1_all.deb
 bb6fbb5fb4c59cd0b76b14906053ed23 717988 debug extra webkit2gtk-driver-dbgsym_2.20.2-1~bpo9+1_i386.deb
 67bf3f15a69296931f4307b602b77ef3 330548 web optional webkit2gtk-driver_2.20.2-1~bpo9+1_i386.deb
 e759d877994dea3a5601460f963777a9 21803 web optional webkit2gtk_2.20.2-1~bpo9+1_i386.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEG4Kq8pR5Ln9Vhk8+vjIZrz7UE0EFAlsCk4EACgkQvjIZrz7U
E0H94A//UwKawkPE9C76ElpvVhtKSkIqZgJE7Dv8+P46tInqG5aNiysVrN8kG4Ms
1JvKBoSfM5IycLqXs3N4lwiPqgyBbIBGIlF3qas72sAFvRAFWObU4WyktcJNYpYU
dG9QGou7VbUZJZUHVsRjNXCGbT/SsYvGPufnxMJR3KxCafQaqqNe/Z5EQI14vLPD
03Cogf1G9Zk+9oZyv29wsNbZL7LfO8iZApzMqeL827cO2KyXvVTyz8fq9CqNXvyC
12m+j+p87toftKy9WLhT7ZC9pcAPHLcvh0vKiHDZWUnASJVKPdpbwpJLW/o+TcFK
VQi9V0Ze0CJl/bMpas7rGHyUOO8FHkd2t2Giqs1o5iWUtY5xhZeC1blqO6ltwJb/
ZE3/EffYvS3PRvDqXPkZ1uJkLyWLZEyJWGXSsi5zrd0q2VRYZYPU5/qZr5/nae3X
8Y1pG6mZaa8Whb5OAf+aU3ngrAEh2cgovJA+OLWfu2nDlIGfQcxW5nLV2nv+nXA9
TEz5jXr7EKjFE6t9L8H/vUtpK+S8KGCDTltRWvVBAnu6BMrpj5x/jc//OpNQZe/D
68ikUfK4/ERxKUkU10zJD1n5yqzyhJfapq5LfiW/CP5qbnABxDUNIpqX3TOyaKtQ
ZtVo6fCn4DOx2yDfzt1fA6YttO3ja/vl4pqy+5yIccHU5OE5kls=
=d844
-----END PGP SIGNATURE-----


Reply to: