[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Accepted imagemagick 7:6.2.4.5.dfsg1-0.8bpo1 (source i386)



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 15 Jun 2006 13:46:25 +0200
Source: imagemagick
Binary: perlmagick libmagick9 libmagick++9 libmagick9-dev imagemagick libmagick++9-dev
Architecture: source i386
Version: 7:6.2.4.5.dfsg1-0.8bpo1
Distribution: sarge-backports
Urgency: high
Maintainer: Ryuichi Arafune <arafune@debian.org>
Changed-By: Norbert Tretkowski <nobse@backports.org>
Description: 
 imagemagick - Image manipulation programs
 libmagick++9 - The object-oriented C++ API to the ImageMagick library
 libmagick++9-dev - The object-oriented C++ API to the ImageMagick library--developme
 libmagick9 - Image manipulation library
 libmagick9-dev - Image manipulation library -- development
 perlmagick - A perl interface to the libMagick graphics routines
Closes: 214623 254566 261768 263475 264033 265540 266146 266304 268357 268681 269085 270215 270381 270882 272121 272545 272794 275745 277553 277775 277795 278401 278890 278939 282173 282999 291033 291118 292094 292244 296084 296753 296753 297990 298244 299958 299996 302093 303765 304472 305057 306424 310396 310664 310690 310812 311179 313467 314758 315629 316473 316475 316725 317299 317628 318176 318255 318255 321208 325651 325720 330666 344997 345238 345595 345876 347486 352575
Changes: 
 imagemagick (7:6.2.4.5.dfsg1-0.8bpo1) sarge-backports; urgency=low
 .
   * Rebuilt for sarge.
   * Renamed libmagick++9c2a back to libmagick++9.
   * Removed conflicts/replaces with libmagick++9.
 .
 imagemagick (7:6.2.4.5.dfsg1-0.9) unstable; urgency=low
 .
   * Non-Maintainer Upload
   * Remove all instances of the imagemagick logo from the original
     sourcefile and repack. (closes: #214623)
   * Add back the free logo patch
   * Add clean-tarball rule to accomplish this
   * Change the copyright file to indicate that the logo is no longer
     included, and indiciate that the included logo is actually text saying
     "imagemagick" with the Debian open use logo.
 .
 imagemagick (7:6.2.4.5-0.8) unstable; urgency=low
 .
   * Non-maintainer upload.
   * Back to 6.2.4.5 as requested by the release team to maintain binary
     compatibility. Bumped epoch once more.
 .
 imagemagick (6:6.2.6.7-1) unstable; urgency=low
 .
   * New upstream version.
 .
 imagemagick (6:6.2.4.5-0.7) unstable; urgency=high
 .
   * Non-maintainer upload.
   * coders/url.c: Do not treat local file:// URIs as temporary files that
     are removed after reading. Closes: #352575
 .
 imagemagick (6:6.2.4.5-0.6) unstable; urgency=high
 .
   * Non-maintainer upload.
   * magick/display.c: In DisplayImageCommand(), expand command line before
     allocating ressources based on argc. Patch and analysis thanks to
     Eero Häkkinen. Closes: #345595
   * magick/{animate.c,blob.c,display.c,image.c,log.c,montage.c,string.c,
     string_.h}: Implement new utility function FormatMagickStringNumeric()
     to securely expand a user-supplied format string with a single numeric
     argument. Adjust code to use this function where appropriate.
     (CVE-2006-0082) Closes: #345876
   * coders/pdf.c,coders/ps.c,magick/delegate.c,magick/delegate.h,
     magick/methods.h: Do not call external delegates with user-supplied
     filename, but with securely named symlinks only to prevent shell command
     injection (CVE-2005-4601). Closes: #345238
   * debian/rules: Make sure to include trailing spaces in multi-line
     commands to keep recent make happy. Cures problems with ghostscript
     font path. Fix thanks to Jeff Lessem. Closes: #347486
   * debian/imagemagick.mime: Rather than autodetect the type of an image,
     derive it from the mime type. As a side effect, this change allows to
     use arbitrary filenames with the 'see' command, even if they have
     special meaning to imagemagick internally. Also clean up some typos
     and superfluous entries once we're at it. Closes: #344997
 .
 imagemagick (6:6.2.4.5-0.5) unstable; urgency=low
 .
   * Another NMU to complete the installability fixes from 6:6.2.4.5-0.4.
   * Adjust libmagick9-dev dependencies to account for the removal of
     xlibs-dev from unstable, and bring them in line with build-deps.
 .
 imagemagick (6:6.2.4.5-0.4) unstable; urgency=low
 .
   * Non-maintainer upload to resolve buildability/installability.
   * debian/{control,rules}: Disable DPS support, which is no longer shipped
     in Xorg 6.9/7.0 (and was making us both FTBFS and uninstallable in sid)
   * debian/control: explicitely build-depend on libxext-dev, since we both
     test for and use it directly, rather than indirectly.
 .
 imagemagick (6:6.2.4.5-0.3) unstable; urgency=low
 .
   * Non-maintainer upload.
   * debian/control: Rename libmagick++9 to libmagick++9c2a, following a
     C++ ABI transition. Conflicts with and Replaces old version.
   * debian/*: Rename various debhelper support files due to above name
     change.
 .
 imagemagick (6:6.2.4.5-0.2) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * debian/control: libmagick9-dev Conflicts/Replaces libmagick6-dev.
     Likewise for libmagick++9-dev. Closes: #330666
   * debian/control: Provide unversioned libmagick-dev and libmagick++-dev
     and conflict/replace them for future-proof handling of soname bumps.
 .
 imagemagick (6:6.2.4.5-0.1) unstable; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Yet another bump of the soname version, this time going from
       7 to 9.
   * debian/*: Cater for soname change and corresponding change of
     library packages names in multiple places.
 .
 imagemagick (6:6.2.4.4-0.1) experimental; urgency=low
 .
   * Non-maintainer upload.
   * New upstream version.
     + Version in library soname was increased from 6 to 7 due to
       changes in binary interface starting with 6.0.7. (Yes, this
       should have happened earlier.) Closes: #318176, #325651, #325720
   * debian/*: Rename packages from libmagick6 to libmagick7, and similar.
     Adjust version in various places accordingly. Drop c2 suffix from
     C++ library package.
   * debian/control: Use shlibs information to generate Depends line for
     imagemagick binary package.
   * debian/control: Remove Pre-Depends on prehistoric version of dpkg.
   * debian/control: Package complies with policy version 3.6.2. Bump
     Standards-Version accordingly.
   * Patches to upstream sources:
     + [bin/Magick++-config.1.debdiff]
       Stray file that seems to have slipped into the previous Debian
       diffs by mistake. Removed now.
     + [magick/blob.c]
       Originally a patch from upstream, now mostly merged. Retaining a
       single hunk that upstream reverted later on, though it still looks
       correct.
     + [configure.ac, configure]
       Override location of documentation files to Debian's default
       /usr/share/doc/imagemagick. Patch to configure was present before.
       This release promotes it back to configure.ac as well. (No ill
       effects because AM_MAINTAINER_MODE is used.)
     + [coders/magick.c]
       Drop patch that exchanges upstream's logo for a DFSG-free version.
       This attempt to address #214623 (distribution of non-free logo)
       missed several other instances of the logo, must be applied to
       the orig.tar.gz rather than the Debian diff, and should have
       some input from upstream, so no point in carrying it around still.
 .
 imagemagick (6:6.2.3.6-3) unstable; urgency=low
 .
   * Fix missing "g" in imagema"g"ick in man pages.  closes: #318255
 .
 imagemagick (6:6.2.3.6-2) unstable; urgency=low
 .
   * Add comment on README for perlmagick. closes: #272545
   * upstream fix: perlmagick: broken link in manpage.  closes: #305057
 .
 imagemagick (6:6.2.3.6-1) unstable; urgency=low
 .
   * New upstream release
   * upstream fixes:
      - fix typo in mogrify manpage: closes: #317628, #321208
      - update config.sub/config.guess closes: #317299
      - fix " configure.ac takes wrong assumptions" closes: #303765
   * point to the correct URL in manpages. closes: #318255, #315629
   * man pages are rerwrited.    closes: #264033, #316475
   * closing bugs fixed by NMs. closes: #310690, #310812, #268357, #269085, #278401, #291033, #291118, #297990, #302093, #265540, #296084, #277775, #306424, #266146, #270882, #282173, #277795,
 .
 imagemagick (6:6.2.3.5-1) unstable; urgency=low
 .
   * New upstream release
 .
 imagemagick (6:6.2.3.4-1) unstable; urgency=low
 .
   * New upstream release
   * Add .ico rule to mime/package/imagemagick. closes: #272121
   * Upstream fixes:
      - -ping not documented well.
      - cropped PNGs have a wrong offset
      - cine-DICOM does not work due to JPEG processing problem
      - display does not interpret the options correctly any more
      - imagemagick: unexpected faillure from PDF to EPS
      - -trim -monochrome used together made empty image
      closes: #296753, #263475, #296753, #282999, #254566, #316473
 .
 imagemagick (6:6.2.3.3-1) unstable; urgency=low
 .
   * New upstream release.
     upstream fix: header file exception.h needs to include stdarg.h. closes: #316725
   * rules scripts does not stop building.  closes: #314758
   * libmagick++6 -> libmagick++6c2 (ABI transition).
   *
 .
 imagemagick (6:6.2.3.1-1) unstable; urgency=low
 .
   * New upstream release
   * Add libltdl3-dev to Build-Depends.  I believe that a reported bug on powerpc
     system , "missing libltdl3 dependency", should be fixed in the next
     upload.  closes: #313467
 .
 imagemagick (6:6.2.3.0-2) unstable; urgency=low
 .
   * Add libwmf-bin to Suggests for libmagcik6.  closes: #278890
   * Upstream fixes the bugs.
    - PerlMagick's Profile() method produces an assertion error when the
    profile parameter is set to undef. closes:#292094
    - perlmagick: segmentation fault while converting .tif to .pdf. closes: #299958
    - 8bpp images are not supported. closes: #270381
    - convert to postscript is still broken (geometry/resolution) closes: #270215
    - imagemagick produces useless (and wrong!) error output when a tiff has a
    bad magic number. closes: #272794
    - /usr/bin/identify: png bit depth count wrong? closes: #275745
    - convert makes garbled eps-->ppm conversion (at least, it works well on my
    system.) closes: #261768
    - -page option does not work correctly. closes: #268681
    - -depth option has no effect. closes: #278939
    - libmagick++6-dev: MaxRGB macro does not work if not ``using namespace
    Magick;'' closes: #292244
    - Image::Magic (sometimes) dies on errors (instead of providing an error
    string)  closes: #304472
    - imagemagick: convert ignores flags to turn off antialiasing. closes:
    #310664
 .
 imagemagick (6:6.2.3.0-1) unstable; urgency=low
 .
   * New upstream release closes: #298244
   * Because of API chage of ImageMagick libraries, switching a new version
     may cause trouble.  (e.g. not using some packages.)  I feel that some of
     the trouble pacakges are usable by only simply rebuilding on the new
     library, but the others may need more complicated solution.
   * If you met the trouble about the package that depends on the libmagick,
     I hope, you try to rebuld the package.
     And let me know the results to me or the package maintainer.
   * Upsteram fixes the bugs.
     - tga support seems to be broken. closes: #311179
     - Option -geometry is completely broken for JPEG images. closes: #277553
     - fails to load 16 colors RLE encoded BMP files. closes: #310396
     - display with options -crop, -geometry and "-window root" is broken.
     closes: #266304
   * Fix typo in package description. closes: #299996
Files: 
 2d4a7fd344cb0ef58b673c0b70bb30e4 973 graphics optional imagemagick_6.2.4.5.dfsg1-0.8bpo1.dsc
 2c5d3723d25c4119cf003efce2161c56 5203463 graphics optional imagemagick_6.2.4.5.dfsg1.orig.tar.gz
 8648206c4f755427b620393cdd95050c 83391 graphics optional imagemagick_6.2.4.5.dfsg1-0.8bpo1.diff.gz
 5956a9d98b2bf8b810290a8e22d3020b 885442 graphics optional imagemagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb
 64fa2c2bc3e5fbf9c9e66d6be96e5a02 1242508 libs optional libmagick9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
 f37269567e808c75d48c5bfcc7e3af48 1574312 libdevel optional libmagick9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
 04d00e03a8e50a9b496dac3dd1bdd7b6 25522 libs optional libmagick++9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
 5f8ee54e26357ea9db968660a1182646 212912 libdevel optional libmagick++9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
 3cab0807afb4d863597d90a97474842b 167154 perl optional perlmagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFE3Y9Kr/RnCw96jQERAm88AJ9mXFAf+tqwuEsH6PLdx0igoev44gCfVXVM
nSBwi6pw/4Id4CARUZ0xDVc=
=/Rt/
-----END PGP SIGNATURE-----


Accepted:
imagemagick_6.2.4.5.dfsg1-0.8bpo1.diff.gz
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-0.8bpo1.diff.gz
imagemagick_6.2.4.5.dfsg1-0.8bpo1.dsc
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-0.8bpo1.dsc
imagemagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb
imagemagick_6.2.4.5.dfsg1.orig.tar.gz
  to pool/main/i/imagemagick/imagemagick_6.2.4.5.dfsg1.orig.tar.gz
libmagick++9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/libmagick++9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
libmagick++9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/libmagick++9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
libmagick9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/libmagick9-dev_6.2.4.5.dfsg1-0.8bpo1_i386.deb
libmagick9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/libmagick9_6.2.4.5.dfsg1-0.8bpo1_i386.deb
perlmagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb
  to pool/main/i/imagemagick/perlmagick_6.2.4.5.dfsg1-0.8bpo1_i386.deb



Reply to: