[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

AW: Re: Sheevaplug with new kernel 2.6.39


What are does printenv say in u-boot?



Gesendet von meinem Windows Phone Von: Arnaud Patard
Gesendet: Donnerstag, 9. Juni 2011 15:06
An: Hai Nguyen Dang
Cc: Debian ARM
Betreff: Re: Sheevaplug with new kernel 2.6.39
Hai Nguyen Dang <danghai2k@gmail.com> writes:

> Hi All,


> I tried to compile and upgraded my Sheevaplug from kernel 2.6.38 to 2.6.39
> with my own compiled kernel, however I always got the mount root problem as
> below.
> This is a part of uBoot messages before kernel panic and hang, my SheevaPlug
> boots from USB normally with kernel 2.6.38 (I tried to compile the kernel
> 2.6.39 many times, the last time I used kirkwood_defconfig without changes
> as my kernel configuration but it doesn't work).
> ========================================
> usb 1-1: new high speed USB device number 2 using orion-ehci
> ata2: SATA link down (SStatus 0 SControl F300)
> Root-NFS: no NFS server address
> VFS: Unable to mount root fs via NFS, trying floppy.
> VFS: Cannot open root device "(null)" or unknown-block(2,0)
> Please append a correct "root=" boot option; here are the available
> partitions:
> 1f00            1024 mtdblock0  (driver?)
> 1f01            4096 mtdblock1  (driver?)
> 1f02          519168 mtdblock2  (driver?)
> Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(2,0)

Can you please provide your kernel command line ? Are you booting with
an initrd ?
If you're booting without initrd, from the part of the log, an usb
devices seems to be detected but not yet probed. Maybe you're missing a
rootwait in your kernel command line or missing usb mass storage support
in your kernel ?


To UNSUBSCRIBE, email to debian-arm-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 8739jjma9h.fsf@lebrac.rtp-net.org">http://lists.debian.org/8739jjma9h.fsf@lebrac.rtp-net.org

Reply to: