[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sheevaplug with new kernel 2.6.39

Hi All,
I tried to compile and upgraded my Sheevaplug from kernel 2.6.38 to 2.6.39 with my own compiled kernel, however I always got the mount root problem as below.

This is a part of uBoot messages before kernel panic and hang, my SheevaPlug boots from USB normally with kernel 2.6.38 (I tried to compile the kernel 2.6.39 many times, the last time I used kirkwood_defconfig without changes as my kernel configuration but it doesn't work).

usb 1-1: new high speed USB device number 2 using orion-ehci
ata2: SATA link down (SStatus 0 SControl F300)
Root-NFS: no NFS server address
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "(null)" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00            1024 mtdblock0  (driver?)
1f01            4096 mtdblock1  (driver?)
1f02          519168 mtdblock2  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
[<c002bf5c>] (unwind_backtrace+0x0/0xf0) from [<c03521d0>] (panic+0x70/0x198)
[<c03521d0>] (panic+0x70/0x198) from [<c0008d98>] (mount_block_root+0x1c8/0x208)
[<c0008d98>] (mount_block_root+0x1c8/0x208) from [<c0008e78>] (mount_root+0xa0/0xc0)
[<c0008e78>] (mount_root+0xa0/0xc0) from [<c0008fb4>] (prepare_namespace+0x11c/0x174)
[<c0008fb4>] (prepare_namespace+0x11c/0x174) from [<c0008460>] (kernel_init+0x100/0x13c)
[<c0008460>] (kernel_init+0x100/0x13c) from [<c0028330>] (kernel_thread_exit+0x0/0x8)

I don't use the mtd* for booting anymore, I used Martin's tutorial and have Sheevaplug boot from USB instead.

Any help is appreciated.

Sorry for my English.

Thanks and rgds,

Reply to: