[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Thecus N2100 installation fails

On Thu, 2010-02-04 at 17:42 +0100, Kai K. wrote:
> On Thu, Feb 04, 2010 at 02:42:29PM +0100, Tobias Frost wrote:
> > > Hi All,
> > >
> > > I bought an used N2100 at the bay, and tried to install Debian,
> > > following Martin Michlmayr's great instructions, but I fail.
> > > After uploading the Debian firmware it prompts for the reboot, but
> > > does not come up again. Also, the LEDs stop flashing after Redboot
> > > tried to load the OS (that's a guess in fact).
> > 
> > Thats fine, its a sign that the kernel indeed boots, but seems to stuck
> > somewhere else, for example the network config?
> > 
> > First thought is that LAN is not up or you expecting another IP address.
> > Is the network LED blinking during boot? Can you use a network sniffer to
> > see if dhcp packages are exchanged? Nmap'ed your LAN?
> Yes I nmap'ed, as this is the subnet my DHCP server is
> in (stock Linksys WAG200G). I configured the box with a static IP 
>, and believed it would keep this configuration. Also,
> after a few seconds all LEDs stop flashing.
> When I am home, I will sniff for DHCP traffic.
> > I think I had these issues as well when I installed my box, so I used a
> > local dhcp server to "see" the exchange of the packages. I wrote also a
> > howto that time:
> > http://blog.coldtobi.de/1_coldtobis_blog/archive/166_installing_debian_on_the_thecus_n2100_--_part_1_--_preparation_for_install.html
> Great howto, thank you! Why didn't I find it earlier? But what's
> puzzling me is that you've written:
> "ACPI events are catched by the installer, so the power button works."

Disclaimer: I *might* also be wrong on this. This is what I had in mind,
but on a second thought it can also be that I mixed this up with the
installed debian...

> It is definately not working for me, so maybe that's a hint, that the
> kernel actually does not boot.
> > Just another thought: Which LAN connection are you using. I am unsure if
> > anything else than "LAN1" will work.
> I am using LAN port 1.
> > > I used official firmware 2.01.09 and 2.01.10, which run very well, but
> > > installing Debian does not work. I would like to try an older official
> > > Thecus firmware, but the oldest one I can find is 2.01.09.
> > > At least the device itself seems to be ok, as the stock firmwares
> > > don't give me any errors.
> > 
> > As you are replacing the firmware, it is gone with the flashing of the
> > installer. Therefore, it is independent of the original version.
> > With very old firmware you cannot access RedBoot over ethernet, but that
> > is the only difference I'm aware of.
> OK, makes sense. So this is not the problem.
> > > Maybe someone has a hint for me, or an older official firmware
> > > available so I can try it? Did someone experience the same, or similar
> > > problems?
> > > Unfortunately I don't have a serial connection, so I cannot give further
> > > debugging information.
> > 
> > If you got a change to get one of these USB-serial adapters, this will
> > probably will really help finding the problem. (They are only a few bucks
> > though and might be handy if at a later time something is wrong -- for
> > example my box once did an hickup as fsck thought it has found an
> > corruption due "last mounted in the future" waiting for a desperate "Yes")
> I have a serial port on my computer, that's not the problem, but
> soldering the pins on my N2100. ;-)

You do not need to solder pins on it. There are this "pin headers"
available which will give you enough contact when just put in. 
I do not now the exact English term, but here's a picture:

> -- 
> Greetings, Kai
> "In a world without walls and fences, who needs Windows and Gates?"

Reply to: