[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sheevaplug running Debian won't boot after initial "apt-get dist-upgrade"

Martin Michlmayr wrote:
> I tried your bad boot files on my SheevaPlug and interestingly enough
> it boots just fine.  Can you very the md5sums to ensure we're talking
> about the same images:
> e2f5e411e4132c71edd07ebd8578fd56  /boot/uImage
> 5d6135afd29db6ae00981d50a2d5c846  /boot/uInitrd

Checked - same.

> When you copy those files to /boot again, do you get the "Bad Magic
> Number" error?  Can you show me the full boot log and maybe also the
> output of "printenv" from u-boot.

I copied the *.bad files back into place and...  it booted just fine!

I really can't explain that.  When the problem first occurred I tried
lots of boots, and completely disconnecting the power for several
minutes to make sure it was properly reset.  Always "Bad magic number".

When I moved those files out of the way and replaced them with the *.bak
versions then suddenly it booted again.  But now I've put the *.bad ones
back and it boots.  I'm sure it's using those because:

john@sheeva:~$ uname -a
Linux sheeva 2.6.30-1-kirkwood #1 Mon Aug 17 14:01:54 UTC 2009 armv5tel

I'm at a loss to explain why it wouldn't boot before.  Sorry to have
worried you and thanks for all your assistance.


Reply to: