[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

NSLU2 wont boot/reboot with 2 drives attached

From http://www.nslu2-linux.org/wiki/Debian/TroubleShooting


The slug fails to reboot with 2 drives connected

If you connect a second drive after you have installed Debian, for example to store your data files, the order of the drives will be random after rebooting, i.e. the new drive could become /dev/sda with your root filesystem being /dev/sdb. If that happens the slug will fail to boot because it will be looking for its root filesystem on the wrong disk. To recover, boot with only the root drive connected and change your fstab to mount your root drive by UUID by following the procedure outlined below.

List the UUIDs of your drives with the tree (apt-get install tree) command

$ tree /dev/disk


|-- by-id

|   |-- usb-[=ST340014=]_A_5000000000002886 -> ../../sda

|   |-- usb-[=ST340014=]_A_5000000000002886-part1 -> ../../sda1

|   |-- usb-[=ST340014=]_A_5000000000002886-part2 -> ../../sda2

|   `-- usb-[=ST340014=]_A_5000000000002886-part5 -> ../../sda5

|-- by-path

|   |-- pci-0000:00:01.2-usb-0:1:1.0-scsi-0:0:0:0 -> ../../sda

|   |-- pci-0000:00:01.2-usb-0:1:1.0-scsi-0:0:0:0-part1 -> ../../sda1

|   |-- pci-0000:00:01.2-usb-0:1:1.0-scsi-0:0:0:0-part2 -> ../../sda2

|   `-- pci-0000:00:01.2-usb-0:1:1.0-scsi-0:0:0:0-part5 -> ../../sda5

`-- by-uuid

   `-- 424ba820-8e80-422e-aaeb-b343b4a462f1 -> ../../sda1

and then modify your fstab by replacing /dev/sda1 (your root partition) with the UUID, e.g.

# /etc/fstab: static file system information.


# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    defaults        0       0

UUID=424ba820-8e80-422e-aaeb-b343b4a462f1       /       ext3 defaults,errors=remount-ro 0       1

/dev/sda5       none            swap    sw              0       0

/dev/sda1       /media/usb0     auto    rw,user,noauto  0       0

/dev/sda5       /media/usb1     auto    rw,user,noauto  0       0

Then update the initramfs:

$ sudo update-initramfs -u

and flash the new initramfs

$ sudo flash-kernel

You may want to make a copy of your existing flash before this last step in case something goes wrong.





Right, im having trouble with it not always booting up with the 2nd drive attached...


It worked fine a few times before I changed it, but its not working now...


Another user on IRC is having the same problem – He’s also made the changes as per that post above, and its still not working




Anyone got any other suggestions?









Reply to: