[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [D-I] Preparing for update in stable



This is a follow-up to [1] which proposed a plan for the update of D-I 
using the latest kernel update for stable in preparation for Sarge r3.

Follow-ups please in principle _only_ to d-release and d-boot and maybe to 
one of the CCed lists if relevant for them.

On Friday 21 April 2006 02:01, Frans Pop wrote:
> In more detail:
> 1) Upload new i386 kernel udebs for both 2.4 and 2.6 to s-p-u (I've
>    already prepared a set)
> 2) Get these acked by SRM so they actually show up in s-p-u; s-p-u
> already has debian-installer sections, I'm not sure if the acceptance
> queue and approval stuff supports udebs though (aj?)
> 3) Try a local build of d-i using a sources.list that has both stable
> and s-p-u in it [1].

After a bit of a wait, stage 2 was completed and I have completed the test 
in stage 3. Building the installer using s-p-u to get kernel udebs worked 
as expected and the mini.iso booted with the correct kernel and ran 
successfully for the first installation steps.

Attached are the patches that are needed in the installer to make use of 
the new kernels. One patch for d-i itself and one for base-installer (for 
alpha). Patches for kernel udeb packages not included as they are 
trivial.

Some comments on the patch for debian-installer:
- AMD64 currently has _no_ kernel updates in their s-p-u Packages file;
  I understand that Joerg Jaspert needs to work on this for AMD64 to be
  included in the r3 point release. It will probably also need work by
  him to get the udebs into the debian-installer section in s-p-u.
- The following architectures have no ABI version in the packages names
  and thus do not need a change in their config files:
  arm, m68k, mips, mipsel
- Powerpc did not have any ABI version in the kernel-image package names,
  but with this release they have been added for 2.6.8 (not for 2.4.27!).
  As there also seem to be (new?) meta-packages, base-installer should
  continue to work.
- The other arches all has an ABI change from 2 to 3.

Request to d-i porters: please check if the changes for your architecture 
are complete.

So, the next steps are:
> 4) If this works, poke^Wask porters to upload updated kernels udebs for
>    their arches.

We are going to delay step 4 until the kernel security updates that are 
currently being prepared are available in s-p-u. These do not include an 
ABI change.

> 5) Upload new base-installer.
> 6) Get those uploads acked by SRM.
> 7) Upload d-i and let the buildds do their stuff.

The steps after that are:
8) Prepare necessary updates for debian-cd (if any).
9) Release r3 with very clear communication (debian-announce) that old
   installer images may break and that preferably new images should be
   used. Also communicate that availability of CD images may take up to
   a week.
10) Generate new package lists for debian-cd with new kernel versions.
11) Build and test images for all arches (with porter help).

Cheers,
FJP

[1] http://lists.debian.org/debian-release/2006/04/msg00122.html
Index: debian/postinst
===================================================================
--- debian/postinst	(revision 36545)
+++ debian/postinst	(working copy)
@@ -513,7 +513,7 @@
 		trykernel=kernel-image-$version-$flavor
 	;;
 	alpha)
-		version=2.4.27-2
+		version=2.4.27-3
 		if dmesg | grep -q ^Processors:; then
 			CPUS=`dmesg | grep ^Processors: | cut -d: -f2`
 		else
Index: config/powerpc/power3.cfg
===================================================================
--- config/powerpc/power3.cfg	(revision 37370)
+++ config/powerpc/power3.cfg	(working copy)
@@ -1,7 +1,7 @@
 MEDIUM_SUPPORTED = cdrom netboot
 
 # The version of the kernel to use.
-KERNELVERSION = 2.6.8-power3
+KERNELVERSION = 2.6.8-3-power3
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinux
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/powerpc/powerpc.cfg
===================================================================
--- config/powerpc/powerpc.cfg	(revision 37370)
+++ config/powerpc/powerpc.cfg	(working copy)
@@ -1,7 +1,7 @@
 MEDIUM_SUPPORTED = cdrom netboot floppy floppy-2.4 hd-media cdrom-minimal netboot-minimal # monolithic
 
 # The version of the kernel to use.
-KERNELVERSION = 2.6.8-powerpc
+KERNELVERSION = 2.6.8-3-powerpc
 # Targets for 2.4 kernel images will use this version instead.
 KERNELVERSION_2.4 = 2.4.27-powerpc
 KERNEL_FLAVOUR = di
Index: config/powerpc/power4.cfg
===================================================================
--- config/powerpc/power4.cfg	(revision 37370)
+++ config/powerpc/power4.cfg	(working copy)
@@ -1,7 +1,7 @@
 MEDIUM_SUPPORTED = cdrom netboot
 
 # The version of the kernel to use.
-KERNELVERSION = 2.6.8-power4
+KERNELVERSION = 2.6.8-3-power4
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinux
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/alpha.cfg
===================================================================
--- config/alpha.cfg	(revision 37370)
+++ config/alpha.cfg	(working copy)
@@ -1,7 +1,7 @@
 MEDIUM_SUPPORTED = cdrom netboot miniiso
 
 # The version of the kernel to use.
-KERNELVERSION = 2.4.27-2-generic
+KERNELVERSION = 2.4.27-3-generic
 KERNELMAJOR = 2.4
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinuz
Index: config/alpha/miniiso.cfg
===================================================================
--- config/alpha/miniiso.cfg	(revision 37370)
+++ config/alpha/miniiso.cfg	(working copy)
@@ -1,6 +1,6 @@
 # This is completely meaningless, since the mini-ISO uses prebuilt
 # boot images, but some Makefile magic depends on those definitions.
-KERNELVERSION = 2.4.27-2-generic
+KERNELVERSION = 2.4.27-3-generic
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinuz
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/hppa.cfg
===================================================================
--- config/hppa.cfg	(revision 37370)
+++ config/hppa.cfg	(working copy)
@@ -2,7 +2,7 @@
 
 KERNEL_FLAVOUR = di
 
-BASEVERSION_2.6 = 2.6.8-2
+BASEVERSION_2.6 = 2.6.8-3
 KERNELIMAGEVERSION_2.6 = $(BASEVERSION_2.6)-32 $(BASEVERSION_2.6)-64
 KERNELVERSION_2.6 = $(foreach ver,${KERNELIMAGEVERSION_2.6},$(ver))
 KERNELNAME_2.6 = $(foreach ver,${KERNELVERSION_2.6},vmlinux-$(ver))
Index: config/i386.cfg
===================================================================
--- config/i386.cfg	(revision 37370)
+++ config/i386.cfg	(working copy)
@@ -1,10 +1,10 @@
 MEDIUM_SUPPORTED = cdrom netboot floppy hd-media #monolithic
 
 # The version of the kernel to use.
-KERNELVERSION = 2.4.27-2-386
+KERNELVERSION = 2.4.27-3-386
 KERNELMAJOR = 2.4
 # Targets for 2.6 kernel images will use this version instead.
-KERNELVERSION_2.6 = 2.6.8-2-386
+KERNELVERSION_2.6 = 2.6.8-3-386
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinuz
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/s390.cfg
===================================================================
--- config/s390.cfg	(revision 37370)
+++ config/s390.cfg	(working copy)
@@ -3,7 +3,7 @@
 KERNEL = $(DEST)/image.debian
 
 KERNELMAJOR = 2.4
-KERNELVERSION = 2.4.27-2-s390
+KERNELVERSION = 2.4.27-3-s390
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinuz
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/ia64.cfg
===================================================================
--- config/ia64.cfg	(revision 37370)
+++ config/ia64.cfg	(working copy)
@@ -5,8 +5,8 @@
 
 # The version of the kernel to use.
 KERNELMAJOR = 2.4
-KERNELVERSION = 2.4.27-2-itanium-smp
-KERNELVERSION_2.6 = 2.6.8-2-itanium-smp
+KERNELVERSION = 2.4.27-3-itanium-smp
+KERNELVERSION_2.6 = 2.6.8-3-itanium-smp
 KERNEL_FLAVOUR = di
 KERNELNAME = vmlinuz
 KERNELIMAGEVERSION = $(KERNELVERSION)
Index: config/sparc.cfg
===================================================================
--- config/sparc.cfg	(revision 37370)
+++ config/sparc.cfg	(working copy)
@@ -4,8 +4,8 @@
 VERSIONED_SYSTEM_MAP = t
 
 KERNELMAJOR = 2.4
-BASEVERSION = 2.4.27-2
-BASEVERSION_2.6 = 2.6.8-2
+BASEVERSION = 2.4.27-3
+BASEVERSION_2.6 = 2.6.8-3
 KERNELIMAGEVERSION = $(BASEVERSION)-sparc32 $(BASEVERSION)-sparc64
 KERNELIMAGEVERSION_2.6 = $(BASEVERSION_2.6)-sparc32 $(BASEVERSION_2.6)-sparc64
 KERNEL_FLAVOUR = di
Index: pkg-lists/cdrom/sparc.cfg
===================================================================
--- pkg-lists/cdrom/sparc.cfg	(revision 37370)
+++ pkg-lists/cdrom/sparc.cfg	(working copy)
@@ -8,9 +8,9 @@
 scsi-modules-${kernel:Version}
 
 # SUPER XXX
-# FJP: Include these ass the above #includes don't work for cdrom builds
-ide-modules-2.4.27-2-sparc64-di
-usb-modules-2.4.27-2-sparc64-di
+# FJP: Include these as the above #includes don't work for cdrom builds
+ide-modules-2.4.27-3-sparc64-di
+usb-modules-2.4.27-3-sparc64-di
 
 console-keymaps-usb
 discover1-data-udeb

Attachment: pgp8ZsHgApWMX.pgp
Description: PGP signature


Reply to: