[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cross compilation error


To whom it may concern


I am currently working on my Thesis project where I have to set in operation a Linux distribution on a computer with an

Xscale processor(IXC1100). I have been trying to build and compile a kernel that I can use (unfortunately I have failed).

I am working on an i686 machine with debian installed.


The kernel that I have downloaded is the kernel (supports the IXP4xx architecture - similar to IXC1100)

I have also downloaded the 2.95.3 and 3.0 cross-compilers (have used both - same error)


I have unpacked the kernel in my home directory (/home/rani/kernel/linux-

The cross compiler is in /usr/local/arm


I have changed the Makefile in the llinux- directory so that it looks like this


ARCH                  ?= arm

CROSS_COMPILE         ?= /usr/local/arm/3.0/bin/arm-linux- (I have also tried to add the compiler to the path and just write arm-linux-)


After that I do the "make menuconfig" and change the processor type to IXP4xx.


The thing is that when I try to "make" - I get the following error


debian:/home/rani/kernel/linux- make

  CHK     include/linux/version.h

  SPLIT   include/linux/autoconf.h -> include/config/*

  CC      scripts/mod/empty.o

Assembler messages:

Error: Invalid processor variant -mcpu=xscale

make[2]: *** [scripts/mod/empty.o] Error 1

make[1]: *** [scripts/mod] Error 2

make: *** [scripts] Error 2


I am following the instructions as described, so I have no clue what I have done wrong.


I have also tried to patch the kernel with the patches found on the intel website for the ixp4xx processors, but I haven't been able to succeed in patching it.


debian:/home/rani/kernel/linux- patch -p1 < ../ixp400LinuxKernel-BE-1_2.patch

can't find file to patch at input line 4

Perhaps you used the wrong -p or --strip option?

The text leading up to this was:


|diff -Naur old/arch/arm/config.in new/arch/arm/config.in

|--- old/arch/arm/config.in     2004-10-12 17:30:07.000000000 +0100

|+++ new/arch/arm/config.in     2004-10-12 17:33:04.000000000 +0100


File to patch:



I am hoping that you can help me and would appreciate any help that I can get


thanks in advance






Reply to: