[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: packages requiring ia32-libs ia32-libs-gtk



On my Athlon PC, multiarch (amd64,i386) is enabled and all packages are latest update 'testing', none broken.

I've downgraded to testing, downloaded the latest googleearth version (6.0.3) and installed all dependencies, including ia32-libs.

Now still i get 

 /usr/lib/googleearth/googleearth-bin: error while loading shared libraries: libGL.so.1: 
 cannot open shared object file: No such file or directory

when i start googleearth from commandline. 

It should be noted that the package requires libgl1-mesa-glx but recommends libgl1-nvidia-glx-ia32, which should be in question for this computer with nvidia GeForce GPU.  To provide this, i had to move to 386 with some more packages, like from nvidia-glx to nvidia-glx-ia32 along some other libraries as well. It endet up requiring move whole xorg to i386, which did not work because xorg-core requires keyboard-configuration which is not available as i386.

Anyway, i doubt the chain would have endet with xorg; i guess kernel was next and i'd end up with a complete i386 system.

Am i supposed to do this just to run one application ? 
Wouldn't it mean the whole multiarch thing doesn't work for googleearth ?


Reply to: