[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups printer stopped printing locally



I just solved the problem.  It appears the driver for the ML-1750 no
longer works with ML-1740.  The solution for was to use package splix,
which provides a driver for this exact model, among many others.  I
probably should have been using this from the beginning.



On Sat, 21 Feb 2009 12:28:30 -0600,
Seb <spluque@gmail.com> wrote:

> Hi, Since the recent CUPS package (1.3.9-14) upgrade in sid, a Samsung
> ML-1740 stopped printing from the local machine.  Let me explain.

> - I've had 2 printers in my local machine managed through CUPS: the
> model above, and a Canon PIXMA MP150.  Both printers set up in CUPS to
> be shared across my home network, and were working perfectly for
> years, printing from any computer in the network.  When adding the
> Samsung printer to the CUPS server, there wasn't an option for a
> driver for this exact model, but the one for ML-1750 worked without
> problems.  For the Canon printer, I had to install the Gutenprint
> drivers (cups-driver-gutenprint) package, to make it work properly.

> - Since the upgrade, the Samsung ML-1740 no longer prints from my
> local machine, but strangely, it does print from other computers in
> the network.  The Canon printer continues to print fine from anywhere
> in the network.

> - Checking the logs, jobs sent to the Samsung ML-1740 from my local
> machine don't show any errors, but the server appears to be unable to
> determine the number of pages.  Below are log entries for a file
> printed from local machine, and from another computer in the net:

> +------------+------+---------+------+-------+-----------------------+-------+
>> ID |Name |User |Size |Pages |State |Control|
> +------------+------+---------+------+-------+-----------------------+-------+
Samsung-1087> fileA |netuser |2030k |1 |completed at Fri Feb 20| |
>> | | | | |15:11:09 2009 | |
> +------------+------+---------+------+-------+-----------------------+-------+
Samsung-1085> fileA |localuser|2030k |Unknown|completed at Fri Feb 20| |
>> | | | | |15:07:17 2009 | |
> +------------+------+---------+------+-------+-----------------------+-------+

> Does anybody have any idea what may be happening, or see the same
> problem with the same printer?  I'm copying my /etc/cups/cupsd.conf
> below, in case it's useful.  Thanks in advance.

> LogLevel warning SystemGroup lpadmin # Allow remote access Port 631
> Listen /var/run/cups/cups.sock # Enable printer sharing and shared
> printers.  Browsing On BrowseOrder allow,deny BrowseAllow all
> BrowseAddress @LOCAL DefaultAuthType Basic <Location /> # Allow shared
> printing...  Order allow,deny Allow @LOCAL </Location> <Location
> /admin> Encryption Required # Restrict access to the admin pages...
> Order allow,deny </Location> <Location /admin/conf> AuthType Default
> Require user @SYSTEM # Restrict access to the configuration files...
> Order allow,deny </Location> <Policy default> <Limit Send-Document
> Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs
> Set-Job-Attributes Create-Job-Subscription Renew-Subscription
> Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job
> Suspend-Current-Job Resume-Job CUPS-Move-Job> Require user @OWNER
> @SYSTEM Order deny,allow </Limit> <Limit CUPS-Add-Modify-Printer
> CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class
> CUPS-Set-Default> AuthType Default Require user @SYSTEM Order
> deny,allow </Limit> <Limit Pause-Printer Resume-Printer Enable-Printer
> Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs
> Release-Held-New-Jobs Deactivate-Printer Activate-Printer
> Restart-Printer Shutdown-Printer Startup-Printer Promote-Job
> Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs> AuthType Default
> Require user @SYSTEM Order deny,allow </Limit> <Limit Cancel-Job
> CUPS-Authenticate-Job> Require user @OWNER @SYSTEM Order deny,allow
> </Limit> <Limit All> Order deny,allow </Limit> </Policy>

> During the upgrade I chose to rewrite the configuration file, and
> diff'ing them:

> *** cupsd.conf 2009-02-17 10:40:19.000000000 -0600 ---
> cupsd.conf.dpkg-old 2008-03-29 16:48:55.000000000 -0500
> *************** *** 10,29 **** BrowseAddress @LOCAL DefaultAuthType
> Basic <Location /> !  # Allow shared printing...  Order allow,deny !
> Allow @LOCAL </Location> <Location /admin> !  Encryption Required !  #
> Restrict access to the admin pages...  Order allow,deny </Location>
> <Location /admin/conf> AuthType Default Require user @SYSTEM !  #
> Restrict access to the configuration files...  Order allow,deny
> </Location> <Policy default> <Limit Send-Document Send-URI Hold-Job
> Release-Job Restart-Job Purge-Jobs Set-Job-Attributes
> Create-Job-Subscription Renew-Subscription Cancel-Subscription
> Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job
> Resume-Job CUPS-Move-Job> --- 10,30 ---- BrowseAddress @LOCAL
> DefaultAuthType Basic <Location /> !  # Allow shared printing and
> remote administration...  Order allow,deny !  Allow all </Location>
> <Location /admin> !  # Allow remote administration...  Order
> allow,deny + Allow all </Location> <Location /admin/conf> AuthType
> Default Require user @SYSTEM !  # Allow remote access to the
> configuration files...  Order allow,deny + Allow all </Location>
> <Policy default> <Limit Send-Document Send-URI Hold-Job Release-Job
> Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription
> Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job
> Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>


-- 
Seb


Reply to: