[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fglrx 8.29.6 and Xorg 7.1.1 :: ABI major version mismatch



It is updated for i386 but not for amd64 ;-(
http://packages.qa.debian.org/f/fglrx-driver/news/20060923T021712Z.html

Max

On 9/24/06, Jesper Nyholm Jensen <nyholm@vip.cybercity.dk> wrote:
When I do a dist-upgrade there are a lot of xserver-xorg updates; and
fglrx-kernel-src is also to be updated, but fglrx-driver is not
updated - in fact it is marked for removal. fglrx-driver depends on
xserver-xorg (<< 1:7.0.99), so I'm wary to update at the moment;
hopefully fglrx-driver will be updated soon.

On Thu, Sep 21, 2006 at 03:10:14PM -0700, Max A. wrote:
> fglrx 8.29.6 claims to support Xorg 7.1
> http://www2.ati.com/drivers/linux/linux_8.29.6.html
>
> But I cannot get it work because of the following error:
>
> (II) LoadModule: "fglrx"
> (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
> (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
>        compiled for 6.8.99.8, module version = 8.29.6
>        Module class: X.Org Video Driver
>        ABI class: X.Org Video Driver, version 0.7
> (EE) module ABI major version (0) doesn't match the server's version (1)
> (II) UnloadModule: "fglrx"
> (II) Unloading /usr/lib/xorg/modules/drivers/fglrx_drv.so
> (EE) Failed to load module "fglrx" (module requirement mismatch, 0)
>
> Does anybody know how to fix that?
--
Jesper Nyholm Jensen




Reply to: