[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc



Francesco Pietra wrote:
On Tuesday 06 June 2006 23:24, Alexander Samad wrote:
On Tue, Jun 06, 2006 at 08:11:01PM +0200, Francesco Pietra wrote:
#apt-get install gcc-4.0
Reading..
Building dependency tree...
Package 4.0 is not available, but is referred to by another package. This
may mean that the package is missing, has been obsoleted, or is only
available from another source.
However the following packages replace it:
gcc-4.0-locales
W. (a series of warnings that Couldn't stat source package list at
http:... E: Package gcc-4.0 has no installation candidate.

My sources.list from which the net installation was carried out with only
main and the row end (subsequently, apt-get update did nothing):
deb http://debian.inode.at/debian-amd64/debian/ etch main contrib
non-free deb-src http://debian.inode.at/debian-amd64/debian/ etch main
contrib non-free
Think you have to change your repository to the main debain ones, as
etch has been moved to there

something like
ftp://ftp.au.debian.org/debian etch main contrib non-free

Now tried:
#apt-get update (or upgrade) with sources.list
 deb ftp://ftp.au.debian.org/debian etch main contrib non-free
 deb-src ftp://ftp.au.debian.org/debian etch main contrib non-free
 deb http://security.debian.org/ etch/updates main contrib non-free
 deb-src http://security.debian.org/ etch/updates main contrib non-free
fails to give access to either sources or security updates and no update/upgrade occurs at all

Then also tried:
#apt-get update (or upgrade) with sources.list
 deb ftp://ftp.debian.org/debian etch main contrib non-free
 deb-src ftp://ftp.debian.org/debian etch main contrib non-free
 deb http://security.debian.org/ etch/updates main contrib non-free
 deb-src http://security.debian.org/ etch/updates main contrib non-free
fails to give access to either sources or security updates and no update/upgrade occurs at all

(installation was from etch beta 2 release installer; netinstall from debian.inode.at) TO ADD that with either 'au' or without in the sources.list, the result of gcc trial install is the same as with debian.inode.at, i.e.:

#apt-get install gcc-4.0
Reading..
Building dependency tree...
Package 4.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.
However the following packages replace it:
gcc-4.0-locales
W. (a series of warnings that Couldn't stat source package list at http:...
E: Package gcc-4.0 has no installation candidate.

Have you done "apt-get update"???

Albert



Reply to: