[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: amd64-archive (openoffice) dpkg ERROR HELPPPPPPPPPPPPPPP

"Brian R. Whitecotton" <brwhitecotton@cox.net> writes:

> Hello,
> For some reason, Goswin's amd64-archive deb package is giving me grief that it 
> didn't used to.
> I am running testing...
> My apt sources.list contains...
> deb http://amd64.debian.net/debian testing main contrib non-free
> deb-src http://amd64.debian.net/debian testing main contrib non-free
> uname -a gives:
> Linux Goliath 2.6.11-9-amd64-k8 #1 Wed Jun 29 17:33:01 CEST 2005 x86_64 
> GNU/Linux
> When I run  <<< dpkg -i amd64-archive_0.2_amd64.deb >>> as root
> I have tried several versions of the archive including the most recent, all to 
> no avail.  The version below is the one that worked the last time I setup Oo.
> I get the following output...
> Goliath:/home/brianw# dpkg -i amd64-archive_0.2_amd64.deb
> (Reading database ... 115680 files and directories currently installed.)
> Preparing to replace amd64-archive 0.2 (using amd64-archive_0.2_amd64.deb) ...
> Unpacking replacement amd64-archive ...
> Setting up amd64-archive (0.2) ...
> gpg: fatal: can't create directory `//.gnupg': Permission denied
> secmem usage: 0/0 bytes in 0/0 blocks of pool 0/32768
> mkdir: cannot create directory `/var/lib/amd64-archive/conf': No such file or 
> directory

This looks like the amd64-archive user is setup wrong. The HOME dir
seems to become / (maybe because the real one is missing) and then gpg
(run as amd64-archive) obviously fails.

The failure to create the conf subdir also indicates that the homedir
(/var/lib/amd64-archive) is missing.

The /etc/passwd should contain

amd64-archive:x:109:0:Amd64-Archive user,,,:/var/lib/amd64-archive:/bin/sh

and the FS should have

drwxr-xr-x  8 amd64-archive root 4.0K Jul 15 21:12 /var/lib/amd64-archive/

Try purging the package or removing the passwd entry manually to get a
fresh start.

> dpkg: error processing amd64-archive (--install):
>  subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
>  amd64-archive
> Goliath:/home/brianw# 
> Any help would be greatly appreciated.  There is so much that I do not 
> understand YET! :-)
> Thank You in Advance!!!
> Brian R. Whitecotton


Reply to: