[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: openoffice2 on amd64

El mié, 14-09-2005 a las 19:12 -0400, Mathieu Lutfy escribió:
> Hi,
> After reading the amd64 howto[1] and the wiki DebianAMD64Faq[2],
> I tried to install Open Office 1.9 beta using the i386 packages,
> but ran into a few problems. To be short, the error message was
>   javaldx: Could not find a Java Runtime Environment! 
>   no suitable windowing system found, exiting.
> [1] https://alioth.debian.org/docman/view.php/30192/21/debian-amd64-howto.html
> [2] http://wiki.debian.net/?DebianAMD64Faq
> Here's how I proceeded:
> - installed ia32-libs (apt-get install ia32-libs)
> - then installed most of the i386 packages for OOo2 using
>   dpkg -i --force-architecture *.deb
>     where *.deb = 
>        openoffice.org2-common_1.9.125+2.0beta2-1_all.deb
>        openoffice.org2-writer_1.9.125+2.0beta2-1_i386.deb
>        openoffice.org2-core_1.9.125+2.0beta2-1_i386.deb
>        python-uno_1.9.125+2.0beta2-1_i386.deb
>        openoffice.org2-l10n-en-us_1.9.125+2.0beta2-1_all.deb
> - installed more ia32 libs until executing oowriter2 did not
>   complain about linking errors, such as libstdc++6, libpam0g,
>   etc. I used the method recommended in the ia32 README.Debian 
>   (# dpkg -X libfoobar_i386.deb /emul/ia32-linux)
> Finally, when I tried running "oowriter2", it prints the error:
>   javaldx: Could not find a Java Runtime Environment! 
                              ^^^^^^ ^^^^^^ ^^^^^^
Have you JRE installed??

>   no suitable windowing system found, exiting.

> I read on some forums that this was caused by a missing 
> libstartup-notification, so I installed it in the /emul/ia32-linux
> environment, but without any success.
> I'm guessing that since OOo2 uses the ia32-libs, I will probably
> need to install many more ia32 libs, but before doing this, I would
> like to know if there are any simpler ways of installing OOo2,
> other documentation, etc.
> And since I'm curious: what is blocking the build of OOo2 on amd64?
> There was discussion in this thread[3] but no news since. I guess
> I will try to build it tomorrow, but I would prefer not loose too 
> much time repeating what others have probably already done. :-)
> [3] http://lists.debian.org/debian-amd64/2005/09/msg00019.html
> Mathieu
> p.s. In general, installing Debian on a AMD Sempron 3100+ using 
> the unofficial sarge netboot CD-ROMs succeded without a glitch.
> -- 
> Mathieu Lutfy        <mathieu@bidon.ca>       http://www.bidon.ca
> GPG 0x5F5BCEB4 0D3B 1AEE EF9B FB34 2FE7  80EC 8E8D F00A 5F5B CEB4
Angel Claudio Alvarez
Usuario Linux Registrado 143466
GPG Public Key en http://pgp.mit.edu
key fingerprint = 3AED D95B 7E2D E954 61C8  F505 1884 473C FC8C 8AC4

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: