[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnutls28 transition

Le dimanche, 4 mai 2014, 02.14:17 peter green a écrit :
> Personally I'd add a (build-)depends on the relicensed gmp in the next
> gnutls28 upload. That way packages can (build-)depend on the new
> gnutls and be assured of getting a GPLv2 compatible version.

For cups, as it doesn't build-depend on libgmp directly, I added the 
inverse relationship:

# libgmp-dev is not GPL-2 compatible before it's 6 release, which makes
# it also GPL-2+
Build-Conflicts: libgmp-dev (<< 2:6)

Dimitri John Ledkov wrote:
> Should we start transition to gnutls28 by default, for all packages
> that are compatible?

Yes, please.


Reply to: