[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnutls28 transition

Dimitri John Ledkov wrote:
Hello all,

gmp has been recently re-licensed and all architectures and ports have
the updated gmp in jessie/sid. Well, all but powerpcspe & x32 both of
which recently have negative slope on their build status graphs.
Thus GPLv2 and LGPLv3 compatible software packages can link against gnutls28.

Should we start transition to gnutls28 by default, for all packages
that are compatible?

Can powerpcspe & x32 porters try to get latest gmp built?
Personally I'd add a (build-)depends on the relicensed gmp in the next gnutls28 upload. That way packages can (build-)depend on the new gnutls and be assured of getting a GPLv2 compatible version.

Reply to: