[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Partimage broken on 64bit archs, was: Re: uncompatible version of gcc

severity 268248  important

On Wed, Oct 13, 2004 at 10:38:04AM +0200, Helge Kreutzmann wrote:
> Hello,
> On Wed, Oct 13, 2004 at 11:05:40AM +0300, aozturk wrote:
> > debian:~# partimage
> > Error: sizeof(DWORD) != 4 (8)
> > This version has been compiled with an uncompatible version of gcc.
> This has already been filed as a bug:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=268248
> Looks like partimage is not 64bit clean. 
> I wonder if the severity should be raised from normal, as IMHO Sarge
> should not ship a broken partimage (better no partimage on 64bit).

I see that the same error was reported for ia64


and was closed with the comment:

"I am sorry to say that ia64 will not be supported anymore"

Since this was the only change in the upload, and #259523 does not
give any further details, it seems to me that there was no work on
getting it 64bit clean. 

I wonder if instead of removing ia64 only, all 64bit archs have to be

I CC:ed the bug-submitter on this issue, maybe he got more info
out of band?

I also raised the severity to important, though I ask the
bug-submitter to consider raising it to "grave" as IMHO this is
release critical.



Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de
                       gpg signed mail preferred 
    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm
       Help keep free software "libre": http://www.freepatents.org/

Attachment: pgpS9ESW1Ixwl.pgp
Description: PGP signature

Reply to: