[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Installer - Problems Partitioning

When I boot from the CD to install Sarge it automatically loads the Debian Installer.  It prompts for language, and then begins.


Problem #1:

[?] Detect Network Hardware –

Error while running ‘modprobe –v DAC960’


I press ‘Continue”…


Problem #2: Let me describe…

“Starting up the partitioner” brings me to a “Partition disks” main menu with five choices…


o        Finish partitioning and write changes to disk

o        Undo changes to partitions

o        Blank

o        Blank

o        Help on partitioning

o        Guided partitioning

o        Configure the Logical Volume Manager


After reading “Help on Partitioning” I choose “Guided Partitioning”.  I now see a menu with one option “Manually edit partition table”, so I choose that option, which returns me to the main “Partition disks” menu.  I then try to “Configure the Logical Volume Manager” but it does not allow me to complete any of the options (Volume Groups or Logical Volumes) because “No usable physical volumes found”.


I believe I know how I want to partition my system but I do not know how to proceed.  The docs I read indicate that because I am booting from SRM I must use FDISK, but I do not know how to find or run this program.  The Debian Installer does have an option to “Execute a Shell” which runs “ash” using an editor called “nano”.  It explains that “the root file system is a RAM disk”.  Also “the hard disk file systems are mounted on ‘/target’”.  However, once there I do not know how to find or run FDISK.


So what?


Well I don’t know if the first error I get is going to be a problem for me or not.  Since it mentions DAC960, I may have some problems with my RAID storage devices.  Since this has to do with storage, is it possible that I cannot partition my drives until this is resolved?  Are there issues partitioning drives set up with RAID5?  Should I partition *before* I run the Debian Installer?  If so, how do I do this?


Thanks again for your infinite Linux wisdom!




My system:

AlphaServer 800 5/400

256MB RAM (128MB in each bank)

Alphabios: v5.69

SRM: v5.4-113

Mylex DAC960 RAID Controller

-          Bank 0 (2007MB)

-          Bank 1 (8182MB)

QLogic ISP SCSI Controller for CD-ROM


Reply to: