[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#811009: marked as done (libatspi2.0-dev: is dependency to libdbus-glib-1-dev still required for all archs?)

Your message dated Thu, 14 Apr 2016 08:37:14 +0200
with message-id <20160414063714.GA3189@var.upmc.fr>
and subject line Re: Bug#811009: libatspi2.0-dev: is dependency to libdbus-glib-1-dev still required for all archs?
has caused the Debian Bug report #811009,
regarding libatspi2.0-dev: is dependency to libdbus-glib-1-dev still required for all archs?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

811009: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=811009
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libatspi2.0-dev
Version: 2.18.3-3
Severity: wishlist

Dear Maintainer,

Would it be possible to have dependency on libdbus-glib-1-dev for [powerpcspei] arch only (= 2.14.0)?
So that libdbus-glib-1-dev and lib packages are not pulled when installing at-spi2-core
packages on archs having version 2.18.3.
I think that it is deprecated and oldlib, isn't it?


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.4.0-rc8-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libatspi2.0-dev depends on:
ii  gir1.2-atspi-2.0    2.18.3-3
ii  libatspi2.0-0       2.18.3-3
ii  libdbus-1-dev       1.10.6-1
pn  libdbus-glib-1-dev  <none>
ii  libglib2.0-dev      2.46.2-3
ii  libxtst-dev         2:1.2.2-1+b1

libatspi2.0-dev recommends no packages.

libatspi2.0-dev suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 2.18.3-4

Simon McVittie, on Thu 14 Apr 2016 07:29:16 +0100, wrote:
> On Thu, 14 Jan 2016 at 20:41:52 +0100, Samuel Thibault wrote:
> > Patrice Duroux, on Thu 14 Jan 2016 20:29:54 +0100, wrote:
> > > I think that [dbus-glib] is deprecated and oldlib, isn't it?
> > 
> > Apparently, yes. at-spi2-core actually doesn't use it any more, so we
> > can just drop the dependency.
> Was this fixed by
>   * control: Replace libdbus-glib-1-dev dependencies with libdbus-1-dev.
> in 2.18.3-4?

Ah, indeed, sorry I missed closing the bug.


--- End Message ---

Reply to: