[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#526642: [gnome-mousetrap] unable to create config dir and files

Samuel Thibault ha scritto:
> Giovanni Mascellani, le Sat 02 May 2009 17:20:02 +0200, a écrit :
>> /usr/lib/pymodules/python2.5/mouseTrap/mouseTrap.py is a symlink, so
>> I've tried putting the file you gave me in the location pointed by the
>> link. The result is not very nice:
>>> $ mousetrap 
>>> ValueError: Attempted relative import in non-package
> Ok, let's not try to debug it by hand :)
> Could you try the package URLed below instead?
> http://brl.thefreecat.org/gnome-mousetrap_0.3+svn17-2~0_all.deb

I tried it. At first it didn't work, triggering the same problem as
before. But then I discovered that the bash wrapper was using the copy
of mouseTrap.py present in my home, rather than that installed in
/usr/blah blah. I don't know, but maybe this could have faked my
previous result with the script you attached me.

Anyway, now the program runs.

Thank you, Giovanni.
Giovanni Mascellani <g.mascellani@gmail.com>
Pisa, Italy

Web: http://poisson.phc.unipi.it/~mascellani
Jabber: g.mascellani@jabber.org / giovanni@elabor.homelinux.org
GPG: 0x5F1FBF70 (FP: 1EB6 3D43 E201 4DDF 67BD  003F FCB0 BB5C 5F1F BF70)

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: